Results 1 to 9 of 9
  1. #1
    3 Star Lounger
    Join Date
    Dec 2008
    Location
    Garrisonville, Virginia
    Posts
    288
    Thanks
    46
    Thanked 1 Time in 1 Post

    Exclamation "Only secure content" error in IE 9

    I have no clue how it got started earlier today, but for the last several hours I am getting the following yellow strip appear at the bottom of a number of webpage (mostly on Facebook): "Only secure content is displayed. What's the risk?" And then there is a button at the right end reading "Show all content" that if pushed makes the dialogue go away, but it ALWAYS comes back on the next similar page.

    This is beginning to get very annoying, and it only started earlier today when I had a problem with IE9. The problem was easily resolved, but since then I am getting this annoying dialogue. Did I somehow unintentionally reset something that I should not have, and if so how do I find and reset it back again and disable this darned thing?

    David E. Cann

  2. #2
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,625
    Thanks
    161
    Thanked 930 Times in 851 Posts
    I would first try to delete all TIF and cookies. You might also try to disable all add-ons to see if this has any affect.

    There may be a setting under Internet Options, Advanced. Have you changed anything recently.

    I also sometimes get this warning, but it generally does not affect me, and can be ignored most of the time, at least in my case.
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  3. #3
    3 Star Lounger
    Join Date
    Dec 2008
    Location
    Garrisonville, Virginia
    Posts
    288
    Thanks
    46
    Thanked 1 Time in 1 Post
    Medico,

    This happened to me once before, I think also following an issue with IE. The warning in itself is not a major problem as you suggested, but it does get annoying after awhile when it occurrs on something I use as much as Facebook. I vaguely remember from last time someone (maybe someone here) referring me to a security setting labelled "Display mixed content" or something like that. It took me awhile to find it (Tools/Internet Options/Security tab/Custom level then scroll down to "Display mixed content" and choose the "enable" toggle. It took me quite awhile to find it again, but it seems to have fixed the problem so far, but I will continue to monitor it. I do not mean to question your knowledge, but I just could not see how deleting all of the cookies and disabling all of the add-ons would help this, much less using IE afterwards with all of that stuff gone, so I tried this first. I can only assume the issue with IE yesterday tripped this setting somehow, but that is a pure guess.
    Quote Originally Posted by Medico View Post
    I would first try to delete all TIF and cookies. You might also try to disable all add-ons to see if this has any affect.

    There may be a setting under Internet Options, Advanced. Have you changed anything recently.

    I also sometimes get this warning, but it generally does not affect me, and can be ignored most of the time, at least in my case.

    David E. Cann

  4. #4
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,625
    Thanks
    161
    Thanked 930 Times in 851 Posts
    The disable add-ons was for T/S purposes only. This can be used to eliminate whether an add-on is causing problems. You would start enabling them one at a time to see what happens.

    I also could not remember where to look for the Display Mixed Content. I tried to find it and could not. It never hurts to delete all TIF and Cookies to eliminate an old page as causing a problem. It just did not make sense that the Display Mixed Content change would come back on it's own.
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  5. The Following User Says Thank You to Medico For This Useful Post:

    decann (2013-04-05)

  6. #5
    3 Star Lounger
    Join Date
    Dec 2008
    Location
    Garrisonville, Virginia
    Posts
    288
    Thanks
    46
    Thanked 1 Time in 1 Post
    Medico,

    What is meant by "T/S" purposes only? Also "TIF?" That is another reason this non-techie didn't/couldn't follow your directions, because he didn't really understand them including reenabling the cookies and add-ons one at a time.
    Quote Originally Posted by Medico View Post
    The disable add-ons was for T/S purposes only. This can be used to eliminate whether an add-on is causing problems. You would start enabling them one at a time to see what happens.

    I also could not remember where to look for the Display Mixed Content. I tried to find it and could not. It never hurts to delete all TIF and Cookies to eliminate an old page as causing a problem. It just did not make sense that the Display Mixed Content change would come back on it's own.

    David E. Cann

  7. #6
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,625
    Thanks
    161
    Thanked 930 Times in 851 Posts
    T/S - troubleshoot, TIF - Temp internet files.

    If you go to the Gear icon and choose Manage Add-ons, you can disable all add-ons here, then re-enable them one at a time and test to see if the problem remains. It might take a while, but often T/S is time consuming.
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  8. #7
    Star Lounger
    Join Date
    Feb 2011
    Location
    Cornwall, UK
    Posts
    71
    Thanks
    7
    Thanked 1 Time in 1 Post

    Unhappy 'Secure content only' Internet Explorer 9

    I've been having this problem ever since I loaded IE9 - I also get 'Your last browsing session closed abruptly' - this is stupid, as I close it myself! The 'close' cross on the banner also does not work - the thing seems to go on its own!
    I've got rid of cookies and TIFs, and there are only 4 add-ons which were present in IE8 and not added to. I don't wan't to go back to IE8 as Paypal already tells me I have an out-of-date browser!

    IE9 is soooooo slow - and often does not connect to links - notably Windows Secrets links!

    This almost makes me want to go to something like Linux, but I am too old to change now, having used Windows since 3.11, and didn't understand that well either!

  9. #8
    Star Lounger
    Join Date
    Apr 2011
    Posts
    81
    Thanks
    5
    Thanked 15 Times in 14 Posts
    Quote Originally Posted by Medico View Post
    I also could not remember where to look for the Display Mixed Content. I tried to find it and could not. It never hurts to delete all TIF and Cookies to eliminate an old page as causing a problem. It just did not make sense that the Display Mixed Content change would come back on it's own.
    The "Display Mixed Content" setting is under Tools\Internet Options\Security\Internet Zone\Custom Level. It's hard to find...a little more than half way down. You will probably find it set to "Prompt". Change it to "Enable". For me, it sticks at home, but we have group policy at work that changes it back within a few minutes.

  10. #9
    New Lounger
    Join Date
    Dec 2009
    Location
    Magnolia, Mississippi, USA
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    The "Display Mixed Content" setting only applies to secure (https) sites. When set to "Prompt", it will infrom you of the presence of insecue items on a secure page, giving you the option to display them or not. Such items could include malicious files which, if clicked on, could send the user to a malicious website or execute a malicious file. If you trust the site, you can select the option to display it/them. If not you can choose no to. I never display them. The default setting is "Prompt", giving you control on an individual-site basis. The other two settings are "Enable" & "Disable". I leave mine on "Prompt", because I like to know which secure pages have insecure items on them. "Disable" would seem OK to me, but I think that selecting "Enable" would be foolish.
    Last edited by edchau3; 2013-04-11 at 18:24.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •