Results 1 to 7 of 7
  1. #1
    Star Lounger
    Join Date
    Mar 2004
    Location
    White Oak, Pennsylvania, USA
    Posts
    94
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Deleting tables in Access 2013

    Working on upgrading from Access 2002 to Access 2013.

    In 2002, to delete tables, one merely selected the table and hit the Del key on the keyboard.

    This doesn't appear to work in 2013. Also, right clicking on the table name doesn't cause the Delete option to be activated.

    I am able to use code (DoCmd DeleteObject process) but I do a significant amount of testing and like to be able to create copies of tables (which is not as easy as it was in 2002 either) for short term backups and then delete them as necessary. Having to use code to specifically name each table is cumbersome.

    Any help will be appreciated.

  2. #2
    Administrator
    Join Date
    Jun 2010
    Location
    Portugal
    Posts
    12,519
    Thanks
    152
    Thanked 1,398 Times in 1,221 Posts
    Deletion works just as before, as far as I can tell. All databases I have tried, either created with Access 2013 or older versions, allow me to do that. I can also copy tables by using copy and paste...

    Are you sure you are not using the database in read only mode. Is the location of the database trusted?
    Rui
    -------
    R4

  3. #3
    Super Moderator
    Join Date
    Aug 2001
    Location
    Evergreen, CO, USA
    Posts
    6,624
    Thanks
    3
    Thanked 60 Times in 60 Posts
    One other possibility is that your 2002 database was secured (Access User Security was setup), and you aren't using the same .MDW file in 2013. I see that problem with 2010 as well in some instances.
    Wendell

  4. #4
    Star Lounger
    Join Date
    Mar 2004
    Location
    White Oak, Pennsylvania, USA
    Posts
    94
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Wendell,

    I understood that Access 2013 did away with the MDW files. I also understood that in order to install Office 13 properly I had to remove all Office XP programs and the install Office 2013. I did not see any reference to MDW files in Access 2013 nor do I find any on the computer on which I installed Access 2013.

    FYI - the database was created in Access 2 and has migrated through Access 97 and Access XP (2002). I believe we added security at the Access 97 transformation but I forget.

  5. #5
    Star Lounger
    Join Date
    Mar 2004
    Location
    White Oak, Pennsylvania, USA
    Posts
    94
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Upon further investigation, I found that one can a command line switch /wrkgrp to tell Access 2013 to utilize the workgroup under which the Access XP database was secured.

    However, when it tried that, I get an error message that states "Access couldn't find file "K:Workgrp.MDW1" appending a 1 to the extension. I don't understand that at all.

  6. #6
    Super Moderator
    Join Date
    Aug 2001
    Location
    Evergreen, CO, USA
    Posts
    6,624
    Thanks
    3
    Thanked 60 Times in 60 Posts
    You can also activate the Workgroup Dialog box using VBA in the immediate window with docmd.runcommand accmdWork.... - I believe you may have a typo in your attempt to use the /wrkgrp switch.
    Wendell

  7. #7
    Star Lounger
    Join Date
    Mar 2004
    Location
    White Oak, Pennsylvania, USA
    Posts
    94
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Wendell,

    You were correct in stating that there may be a typo in the command line using the /wrkgrp switch.

    However, once I enter it correctly, I get the message "Cannot open a database created with a previous version of your application."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •