Results 1 to 3 of 3
  1. #1
    Lounger
    Join Date
    Dec 2009
    Location
    Vancouver, BC, Canada
    Posts
    37
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Google thinks I am French?

    On Saturday night, suddenly Google results were showing in French. This happened shortly after I did a search from the Address Bar of Firefox and it took me to the French Wikipedia page. (I don't recall what I searched for.) My browser is set to use Google's "I'm Feeling Lucky" search function when I type in the address bar.

    On Sunday, everything was back to English again.

    Now, suddenly, it's serving up French results and French wikipedia pages.

    I have read things about it being the ISP or my location or the Google page I use. Let me make this clear: I live in Canada, yes, but I have long ago switched from the forced google.ca to the default google.com. That alone should keep me free of French results.
    All searches go through google.com, not google.ca.
    I've had the same ISP for 9 years, and they are a western-based company - meaning it is unlikely they would be mistaken as serving a French community.

    I have "fixed" my bookmarks by adding ?hl=en to the end of the addresses, but it still shows translation links in the results. And if I type something into the address bar, it still takes me to the French wikipedia page.

    There seems to be no way to change this. Google provides no help links. How do I fix this? Permanently!

    Thanks!

  2. #2
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    Slough, Berkshire UK
    Posts
    924
    Thanks
    55
    Thanked 52 Times in 50 Posts

    Cool

    1. Check your regional language settings in control panel in case something has changed it.
    2. Clear your cache in Firefox or whatever browser you use. (Options / privacy tab in Firefox)
    3. Empty your temp internet folder.
    4. Check your cookies folder for links to french sites.
    Last edited by curiousclive; 2013-05-01 at 07:14.
    Clive

    All typing errors are my own work and subject to patents pending. Except errors by the spell checker. And that has its own patients.

  3. #3
    Lounger
    Join Date
    Dec 2009
    Location
    Vancouver, BC, Canada
    Posts
    37
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Soooo ... none of that worked.

    I am using Firefox. It's my main browser. But I wondered if it was also happening on other browsers.
    Chrome works fine.
    Internet Explorer works fine. (By that I mean that Google serves up results in English on Internet Explorer, not that the browser itself works fine!)
    Firefox ... still serving up French results.

    Since Firefox is the only one on which I am signed in to Google, I began to wonder if my settings had been maladjusted. When I checked them, it told me I had it set to English (United States). So why does Google serve me French results?
    I was signed in to another account as well. I checked the language settings there and nothing was set. So I set it. Twice: English US, and English UK. Still showing French.

    I logged out of both accounts and Google served up English results. WTH?

    I logged in again - to both accounts - and now I am getting English results.

    No idea what happened. No idea how long this "fix" will last. Very frustrating....

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •