Results 1 to 9 of 9
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    Jefferson City, MO
    Posts
    9
    Thanks
    0
    Thanked 1 Time in 1 Post

    Network Discovery and File Sharing are turned off in Windows 7

    We live in a rural area, so I am not too worried about security. We'd be able to see if anyone got close enough to get into our network. In fact I get annoyed when something is so secure it's unusable. So none of these PCs discussed below have passwords and I generally use the public folder and don't use any password protection for it.

    So we have 2 Windows 7 PCs and I think an XP PC. I don't share files among them frequently, but my daughter wanted to do something with a font that was on one PC and not another, so I was just going to put it on one of the public folders on either my PC or hers. Then dunh-duhn-DUHN...

    There was nothing showing up under the network! And it told me that Network Discovery and File Sharing are turned off in Windows 7. It didn't matter what I did, I couldn't get it turned on. I would click things that said it would turn it on, but they were lying to me. I looked on the web and found a lot of references to this occurring so I did the following:

    I ensured the following services were running:
    Computer Browser
    DNS Client
    Function Discovery Resource Publication
    Network List Service
    Network Location Awareness
    Network Store Interface Service
    SSDP Discovery
    UPnP Device Host

    I have tried turning off Windows Firewall. I am using Microsoft Security Essentials.

    I still can't see any of the other PCs. One is new, so I wouldn't be surprised if that didn't have the right workgroup name, but I used to have no problem with the one that I think is XP. It's been months since I've needed to copy anything, so I can't point to a particular Windows update that might have changed something.

    We can transfer things on a flash drive, but it certainly is annoying.

    I've not checked the other PCs to see if they can see anything.

  2. #2
    Silver Lounger
    Join Date
    Oct 2012
    Posts
    2,335
    Thanks
    13
    Thanked 267 Times in 260 Posts
    For Windows 7; Start>Control Panel>Network and Sharing center. Then, Change advanced sharing settings (for Home or Work).

  3. #3
    New Lounger
    Join Date
    Dec 2009
    Location
    Jefferson City, MO
    Posts
    9
    Thanks
    0
    Thanked 1 Time in 1 Post
    I guess I wasn't clear in my original message. When I said, "It didn't matter what I did, I couldn't get it turned on. I would click things that said it would turn it on, but they were lying to me." That was one of the things I was referring to.

    I would turn both things on, and save settings. Go back in and they are turned off.

  4. #4
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,593
    Thanks
    5
    Thanked 1,059 Times in 928 Posts
    Try running "SFC /SCANNOW" from an elevated command prompt.

    Joe

  5. #5
    Silver Lounger
    Join Date
    Oct 2012
    Posts
    2,335
    Thanks
    13
    Thanked 267 Times in 260 Posts
    Ya you didn't mention that settings page and that's where they all are.
    You have an Internet connection through the network adapter in each of the Windows 7 systems? Are you using an administrative account to make the changes with? What is the state/settings of UAC?

    Ah! Just thought of something, add a password to the account. You can remove the need to sign in by using the Run command and entering, control userpasswords2, but you may need to have a pass-worded account to make it stick.

  6. #6
    New Lounger
    Join Date
    Dec 2009
    Location
    Jefferson City, MO
    Posts
    9
    Thanks
    0
    Thanked 1 Time in 1 Post
    Windows Resource Protection did not find any integrity violations.

  7. #7
    New Lounger
    Join Date
    Dec 2009
    Location
    Jefferson City, MO
    Posts
    9
    Thanks
    0
    Thanked 1 Time in 1 Post
    Have they updated something that makes you have to have a password now? I'd hate to put a password on. How can I run as an administrator? I found I could run a command prompt by entering cmd and CTRL+SHIFT+Enter. Is there a something I can enter at the command line to get to those setting to ensure I am doing it as an administrator?

  8. #8
    Super Moderator jwitalka's Avatar
    Join Date
    Dec 2009
    Location
    Minnesota
    Posts
    6,797
    Thanks
    117
    Thanked 799 Times in 720 Posts
    Is the network type set to Public? If so, try changing it to Home:
    http://windows.microsoft.com/en-us/w...twork-location

    Jerry

  9. #9
    New Lounger
    Join Date
    Dec 2009
    Location
    Jefferson City, MO
    Posts
    9
    Thanks
    0
    Thanked 1 Time in 1 Post
    No, the network type was already set to home.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •