Results 1 to 1 of 1
  1. #1
    Lounger
    Join Date
    Nov 2010
    Location
    Pine Bluff, Arkansas, USA
    Posts
    31
    Thanks
    5
    Thanked 3 Times in 3 Posts

    Question How can I prevent a local drive from being backed up by Windows 7 Backup?

    Hello Loungers,

    Please forgive me for posting this; it was caused by an apparently very stubborn brain-infarct. Try as I might, I just can't get around this infuriatingly stubborn block in my comprehension.

    The background is this: I am running Windows 8 Pro, 64-bit flavor, and on that OS, I'm using TrueCrypt version 7.1a. I've started using TrueCrypt because of, mainly, Fred Langa's caveats on using Windows Bitlocker, since the only files I really wanted encrypted are financial files. I'm not paranoid enough to go for whole-disk encryption, yet.

    I throw in the "yet" because of a recently discovered 'weakness'. What I did was create a container file using TrueCrypt, and I moved my financial records from the last few years into it. I then dismounted it, and found that all I could 'see' of the files as the container file; any attempt at reading inside this file without mounting it just yields gobbledegook. All seemed well in the land, and I was happy.

    UNTIL I decided to check the contents of the backup drive. There, I discovered that not only did I have a copy of the encrypted container file, I also had the unencrypted files that was meant to reside only inside the encrypted container file listed as the mounted volume! In other words, when I mount my container file as, say, Drive G:, Windows will fatefully make a backup of that drive, IN the Unencrypted form! Yikes! I think this is kind of a "defeat of the purpose" of going thru the whole encryption thing.

    Anyway, I had a mini-panic, deleting the 'G:' drive directory structure on the backup drive, and then I dismounted the TrueCrypt-mounted drive. Then I ran a backup operation again. After that, I checked the results on the operation after the backup had competed, and I see an error message in the log file that indicates it had to skip the 'G:' drive because it could not find it.

    So I've two questions. First, how do I tell Windows 7 File Recovery to ignore the drive if it is there, meaning "when I mount it, I do NOT want it backed up." And secondly, how do I do the same for Windows 8's new File History utility? File History seems to concentrate on the files that a user creates. All well and good, until you hit the situation I am in, when you only want encryption on some of my files, and not all of them, as not all of them needs to remain private.

    If I can't tell either of this utilities that I want it to ignore the mounted drive when present, I may be forced to do the whole-disk encryption thing, which seems very much like overkill. But it is my understanding that the backups, both by Windows 7 File Recovery and Windows 8 File History, would also be encrypted, which would cover my financial information. I do not WANT to do this, as it seems that I SHOULD be able to tell the utilities what NOT to make a copy of, but I will if there is no other way.

    I wonder, do I have to first mount the container file as a drive, THEN go into the settings of each utility in order to tell them to ignore backing up the drive is question?

    UPDATE: I remembered that I had added the folder/directory that I had made inside the container file to the Documents Library. Removing the folder/directory in question from the Documents Library might be a kludgy workaround for the File History issue, but it's certainly not ideal. And it still leaves the issue with the Win 7 File Recovery utility unaddressed. I want only the encrypted container file on the boot drive to be backed up, not the apparently unencrypted files themselves that reside inside the container file. In fact, I've just verified that even with the container file mounted as "G:", File Recovery does not 'see' it so I can deselect it, yet the previous backup attempt logged that it tried to find it, as evidenced by the following error: "Windows Backup skipped G:\ArbitName because it cannot be found on drive G:\."
    Last edited by AtraEquus; 2013-06-02 at 08:14.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •