Results 1 to 6 of 6
  1. #1
    New Lounger websquad's Avatar
    Join Date
    Dec 2009
    Location
    Kentucky
    Posts
    18
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Win 7 Printer Dev Driver Issue

    Am running Windows 7 with all the latest fixes/patches/SP. My printer is an HP Officejet Pro 8500 A909g Series printer. I've just added a second paper tray to the printer; however, to get the system to recognize the second tray, the HP software (I've checked: it is the latest version) requires the following:

    After you install the device software on Windows computers, Tray 2 must be turned on in the print driver in order for it to work with the device. (The duplexer does not need to be turned on.)

    1 Click Start, point to Settings, and then click Printers or Printers and Faxes.
    - Or -
    Click Start, click Control Panel, and then double-click Printers.

    2 Right-click the printer icon, and then click Properties, Document Defaults, or Printing Preferences.
    3 Select one of these tabs: Configure, Device Settings, or Device Options. (The name of the tab depends on the print driver and the operating system.) On the selected tab, click the accessory that you want to turn on, click Installed from the drop-down menu, and then click OK.

    I've spent hours trying to find these device options, and the closest thing I got was ControlPanel>HardwareSound>DivicesPrinter ... but this lead to a dead end. Lots of options (some looked like familiar registry variables), but nothing about "Tray 2" being enabled -- indeed, nothing about a second tray. I even poked around the registry, but could fine nothing about Tray 2.

    Can anyone help?

  2. #2
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,433
    Thanks
    371
    Thanked 1,456 Times in 1,325 Posts
    WebSquad,

    Click Start.
    Click Devices and Printers
    Right-Click on your HP Printer Icon
    Click on Printer Properties {Not the item that says just Properties}.
    Click on the Preferences button.
    The menus you find should have what you are looking for and it will set the defaults for the printer.

    HTH
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  3. #3
    New Lounger websquad's Avatar
    Join Date
    Dec 2009
    Location
    Kentucky
    Posts
    18
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Interesting results. Got to the Preferences window (step 5 above) and changed paper source to 2. My default paper source had been "Automatic Select" ... I saved this as "Draft" (the default name) and overwrote the old "Draft" definition. I then rebooted, and again selected Printer Properties > Preferences. On that pane checked Features > Paper source and it was Tray 2. Looked promising. Closed out all that stuff and got a document to print. Cntl-P brought up the print window, and in Properties > Features I observed that Paper Source was "Automatically Select" -- Yikes! It printed from the top tray (Tray 1).

    So, to see what "Automatically Select" was, I reprinted the document (didn't manually change the Paper Source to Tray 2 -- just left it at "Automatically Select." Printer printed from Tray 1.

    So, when I'm dealing with the Printer Properties from the Control Panel, Tray 2 is the default. But in the real world of printing a document, Tray 1 is "Automatically Selected." And nowhere in this process did I click an accessory (Tray 2) that I wanted the device driver to select.

    I'm back at square 1 ...

  4. #4
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,433
    Thanks
    371
    Thanked 1,456 Times in 1,325 Posts
    Websquad,

    You might want to investigate this page.

    Here's a link to the User Manual PDF. HTH
    Last edited by RetiredGeek; 2013-06-02 at 18:51.
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  5. #5
    New Lounger websquad's Avatar
    Join Date
    Dec 2009
    Location
    Kentucky
    Posts
    18
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Dear RetiredGeek:

    For what it is worth, I'm also a retired geek ... regarding the HP user manual, the text on page 24 is identical to the text on the pop-up help screen you get from the "HP Solution Software" application that I quoted in my original post.

    However, desperate as I am to fix this, I tried something else: I explored the menu options on the printer and there was a setting for the default printer: #1 or #2 ... it was set for #1, so I change it to #2. Then I grabbed a document, entered CNTL-P, checked the setting for the printer (it was "Automatically Select"), and printed. It selected paper from tray 2. So now I'm powering the device off and then back own and will retest to see if the setting in the printer holds, and if the Automatically Select printer is still #2.

    Details to follow....

  6. #6
    WS Lounge VIP mrjimphelps's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    3,396
    Thanks
    445
    Thanked 404 Times in 376 Posts
    This may or may not address your issue, but I have found it to be true with HP printers, when you are printing from Word or Excel:

    Make sure that your printer properties match the characteristics of the document.

    For example, if you have letter size in tray 1 and legal size in tray 2, and your document is legal size:

    When you print the document, go into the printer properties and select Tray 2 and Legal Size.

    Word, etc., doesn't always pass the document characteristics successfully to the printer driver, so you need to check to make sure that the printer driver has the correct settings for the document.

    I haven't seen this problem when printing from Paint; Paint always prints the document correctly.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •