Results 1 to 10 of 10
  1. #1
    New Lounger
    Join Date
    Jun 2013
    Posts
    7
    Thanks
    4
    Thanked 0 Times in 0 Posts

    External drive contents show the C: drive contents

    In Windows explorer, my external drive (letter i:) shows the c: drive contents. i: is only 10 GB, c: has 300 GB of data. All the folders and files are shown, except the Windows folder. I am reluctant to format or wipe the i: drive.

    I have used different USB ports, restarted several times, changed the i: drive from Active to Inactive, still get same problem.

    How do I get the i: drive to show its contents, and not the c: drive contents. I would have more confidence to wipe the drive in that case.

    The external drive used to be the only drive on an old system I upgraded from, including transfering my data and settings over to the new system and its hard drive.

    Win 7, 32 bit. WD external drive.

    From Disk management:
    Disk 0:
    - System reserved: Simple, Basic, NTFS, healthy (System, Active, Primary partition). Capacity = 100 MB, Free = 70 MB
    - C: Simple, Basic, NTFS, healthy (Boot, Page file, Crash dump, Primary partition). Capacity = 465 GB, Free = 162 GB.

    Disk 6:
    - (blank): Simple, Basic, (blank), healthy (OEM partition). Capacity = 47MB, free = 47 MB
    - J: Simple, Basic, NTFS, healthy (Primary partition). Capacity = 222 GB, free = 222 GB (I formatted full, not quick)
    - I: Simple, Basic, NTFS, healthy (Primary partition). Capacity = 10 GB, free = 502 MB (I changed this from Active to Inactive).
    Last edited by RetiredGeek; 2013-06-10 at 12:56. Reason: added noparse for drive letter

  2. Get our unique weekly Newsletter with tips and techniques, how to's and critical updates on Windows 7, Windows 8, Windows XP, Firefox, Internet Explorer, Google, etc. Join our 480,000 subscribers!

    Excel 2013: The Missing Manual

    + Get this BONUS — free!

    Get the most of Excel! Learn about new features, basics of creating a new spreadsheet and using the infamous Ribbon in the first chapter of Excel 2013: The Missing Manual - Subscribe and download Chapter 1 for free!

  3. #2
    Platinum Lounger
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    3,626
    Thanks
    7
    Thanked 231 Times in 219 Posts
    All Windows disks look much the same because the file structure is the same.

    Eject the USB disk and confirm that it disappears from Disk Manager.
    Insert the USB disk and wait for it to show in Disk Manager - you may need to refresh.
    Remove all partitions from the USB disk.
    Create 1 new primary partition on the USB disk and format as NTFS.

    cheers, Paul

  4. The Following User Says Thank You to Paul T For This Useful Post:

    paul-91 (2013-06-13)

  5. #3
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    6,228
    Thanks
    202
    Thanked 795 Times in 729 Posts
    Paul,

    Welcome to the Lounge as a new poster.

    Is it possible you have assigned the I drive to point to the C drive?

    You can check by going into Computer Management -> Disk Management
    Then right click on a drive and select Change Drive Letter and Paths...
    In the Dialog click the Change... button.
    Use the drop down arrow to the right of the Assign the following drive letter option and see if I shows up.
    Attachment 35458
    If it doesn't then it is already assigned to something else.
    Cancel your way out ... make sure you don't hit anything but CANCEL buttons or Big Red X's!. HTH
    May the Forces of good computing be with you!

    RG

    VBA Rules!

    My Systems: Desktop Specs
    Laptop Specs


  6. The Following User Says Thank You to RetiredGeek For This Useful Post:

    paul-91 (2013-06-13)

  7. #4
    New Lounger
    Join Date
    Jun 2013
    Posts
    7
    Thanks
    4
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Paul T View Post
    All Windows disks look much the same because the file structure is the same.

    Eject the USB disk and confirm that it disappears from Disk Manager.
    Insert the USB disk and wait for it to show in Disk Manager - you may need to refresh.
    Remove all partitions from the USB disk.
    Create 1 new primary partition on the USB disk and format as NTFS.

    cheers, Paul

    It does not look like the c drive, it is the c drive contents, as I can delete a file that is on c from the i drive, and it is deleted on c. I also created a file on i, that, even when i drive is disconnected, appears on c.

    Removing the partitions I will try later, after I backup my entire c drive to another external that I can boot from, just in case.
    Last edited by paul-91; 2013-06-10 at 14:02.

  8. #5
    New Lounger
    Join Date
    Jun 2013
    Posts
    7
    Thanks
    4
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by RetiredGeek View Post
    Paul,

    Welcome to the Lounge as a new poster.

    Is it possible you have assigned the I drive to point to the C drive?

    You can check by going into Computer Management -> Disk Management
    Then right click on a drive and select Change Drive Letter and Paths...
    In the Dialog click the Change... button.
    Use the drop down arrow to the right of the Assign the following drive letter option and see if I shows up.
    Attachment 35458
    If it doesn't then it is already assigned to something else.
    Cancel your way out ... make sure you don't hit anything but CANCEL buttons or Big Red X's!. HTH
    I tried this, i drive shows up in the list, so unassigned. But for sure, when the external drive is attached, it is pointing to c somehow.

  9. #6
    Silver Lounger
    Join Date
    Oct 2012
    Posts
    2,116
    Thanks
    12
    Thanked 242 Times in 235 Posts
    When Windows seems completely confused or it's doing something completely confusing like this, use a LINUX boot disc with GParted on it, like Parted Magic, or anything that will boot independently and give you a good graphical layout of the drives, and let you make partition and formatting changes while not under the purview of Windows. Backing up first good idea in any case.

  10. The Following User Says Thank You to F.U.N. downtown For This Useful Post:

    paul-91 (2013-06-13)

  11. #7
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    6,228
    Thanks
    202
    Thanked 795 Times in 729 Posts
    Paul,

    Have you tried this USB stick in another computer? Do you get the same results?
    You might try a utility like EaseUS Partition Manager Free and see how it shows the drive.
    You could also use PM to format the drive and maybe fix th
    May the Forces of good computing be with you!

    RG

    VBA Rules!

    My Systems: Desktop Specs
    Laptop Specs


  12. #8
    2 Star Lounger
    Join Date
    Feb 2010
    Location
    U.K.
    Posts
    106
    Thanks
    0
    Thanked 17 Times in 13 Posts
    Reparse Points / symbolic links are almost certainly your problem.
    http://www.itninja.com/blog/view/rep...oints-bulletin

    Your external I:\ was once Windows C:\,
    and both Vista and Windows 7 have many such links to user documents.
    so I:\ now APPEARS to contain user documents that are held in your new C:\

    I suggest you dowmnload and run this portable software
    http://www.rekenwonder.com/linkmagic.htm

  13. The Following User Says Thank You to alan.b For This Useful Post:

    paul-91 (2013-06-13)

  14. #9
    New Lounger
    Join Date
    Jun 2013
    Posts
    7
    Thanks
    4
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by F.U.N. downtown View Post
    When Windows seems completely confused or it's doing something completely confusing like this, use a LINUX boot disc with GParted on it, like Parted Magic, or anything that will boot independently and give you a good graphical layout of the drives, and let you make partition and formatting changes while not under the purview of Windows. Backing up first good idea in any case.
    I did this, thanks. The file manager that comes on the iso file still had the external drive pointing to my c drive even under the boot off the CD using Linux. I used this to delete the patition and make the drive one big partition as Paul T suggested, and then wiped the drive. And that all worked. I suspect I could have used Windows Disk Management for this as well, but it seemed safer to use the Linux CD boot.

  15. #10
    New Lounger
    Join Date
    Jun 2013
    Posts
    7
    Thanks
    4
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by alan.b View Post
    Reparse Points / symbolic links are almost certainly your problem.
    http://www.itninja.com/blog/view/rep...oints-bulletin

    Your external I:\ was once Windows C:\,
    and both Vista and Windows 7 have many such links to user documents.
    so I:\ now APPEARS to contain user documents that are held in your new C:\

    I suggest you dowmnload and run this portable software
    http://www.rekenwonder.com/linkmagic.htm
    thanks for the reply. I suspected as much, but was unsure how that might affect actions on the i drive. It seems microsoft must hard code references to the c drive, and not make them relative to the actual drive. I did not use the link, but will check it out for next time.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •