Results 1 to 5 of 5
  1. #1
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,583
    Thanks
    5
    Thanked 1,058 Times in 927 Posts

    Enhanced Mitigation Experience Toolkit 4.0

    A toolkit for deploying and configuring security mitigation technologies. From the download page:

    "EMET 4 supports the following operating systems and service pack levels:

    Client Operating Systems
    Windows XP service pack 3 and above
    Windows Vista service pack 1 and above
    Windows 7 all service packs
    Windows 8

    Server Operation Systems
    Windows Server 2003 service pack 1 and above
    Windows Server 2008 all service packs
    Windows Server 2008 R2 all
    Windows Server 2012"

    See Enhanced Mitigation Experience Toolkit 4.0 for download link and more information.

    Joe

  2. The Following User Says Thank You to JoeP517 For This Useful Post:

    BruceR (2013-06-19)

  3. #2
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    4,748
    Thanks
    171
    Thanked 649 Times in 572 Posts
    I found I had to uninstall EMET 4.0 (Beta) before I could install EMET 4.0. It said a newer version was already installed, but from my reading of full version numbers it was not so.

    Bruce

  4. #3
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    Sydney, Australia
    Posts
    254
    Thanks
    0
    Thanked 5 Times in 5 Posts
    Nice, they have brought this out of Beta.

    Thanks for the tip Bruce.

    Everyone should use EMET on their Windows based machines. Older OS such as XP won't can't utilise all the protection mechanisms provided by EMET but its still definitely worthwhile.

    A primary motivation for most people to use it would be malware mitigation. I'm not saying its a silver bullet but it will definitely help if your browser/adobe reader/adobe flash/java (shudder) are all EMET process aware.

    Quick Tip: Once you install it, click Import and select "Popular" + "Recommend" Software. It will add in common software executables for you.

  5. #4
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    4,748
    Thanks
    171
    Thanked 649 Times in 572 Posts
    Quote Originally Posted by JDB1984 View Post
    Quick Tip: Once you install it, click Import and select "Popular" + "Recommend" Software. It will add in common software executables for you.
    According to the User Guide, this full EMET 4.0 has introduced a Configuration Wizard which runs on installation and sets the "Popular Software" protection profile (if Use Recommended Settings is selected); so I think any separate file import is unnecessary with this version.

    Bruce

  6. #5
    Super Moderator satrow's Avatar
    Join Date
    Dec 2009
    Location
    Cardiff, UK
    Posts
    4,490
    Thanks
    284
    Thanked 577 Times in 480 Posts
    The 'wizard' is basic, pictured below (yes, that's all it is):

    Emet4Wizard.jpg

    There is also a 'popular software' list supplied that can be imported later:

    The profiles that are included with EMET are:

    Recommended Software.xml: Enables mitigations for supported versions of Microsoft Internet
    Explorer, WordPad, applications that are part of the Microsoft Office suite, Adobe Acrobat 8-11,
    Adobe Reader 8-11, and Oracle Java 6 and 7.

    Popular Software.xml: Enables mitigations for common applications, including Microsoft
    Internet Explorer and the Microsoft Office suite.

    CertTrust.xml: Enables certificate pinning rules for the login services of Microsoft Account,
    Microsoft Office 365, and Skype, and other popular online services such as Twitter, Facebook,
    and Yahoo!.
    Open the xml file in IE to see the full list: C:\Program Files (x86)\EMET 4.0\Deployment\Protection Profiles\Popular Software.xml <--- default install location.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •