Results 1 to 5 of 5
  1. #1
    New Lounger
    Join Date
    Mar 2013
    Location
    Atlanta, Ga
    Posts
    15
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Admin Privilege to save hosts file

    I am in Administrators group (Win7 Pro), yet when manually inserting to hosts file, I am told that I do not have permission on C:\Windows\System32\drivers\etc\Hosts.txt to save the file.
    What do you all think?

  2. #2
    Star Lounger
    Join Date
    Apr 2011
    Posts
    99
    Thanks
    5
    Thanked 18 Times in 17 Posts
    1. I think you'll find many posts similar to yours. Right click the file, Properties, Security, Advanced, Owner...take ownership of the file.
    2. If your file is really hosts.txt, it probably won't work. The file name should be simply hosts.

  3. The Following User Says Thank You to riffraff For This Useful Post:

    lfh003 (2013-06-20)

  4. #3
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,162
    Thanks
    47
    Thanked 976 Times in 906 Posts
    This is Windows security attempting to stop you / a virus breaking things. HOSTS is normally targeted by viruses so the security is warranted.

    cheers, Paul

  5. The Following User Says Thank You to Paul T For This Useful Post:

    lfh003 (2013-06-20)

  6. #4
    Super Moderator satrow's Avatar
    Join Date
    Dec 2009
    Location
    Cardiff, UK
    Posts
    4,482
    Thanks
    283
    Thanked 572 Times in 476 Posts
    I just untick the Read-only box before I start work on it, then retick the box once I've saved it (without an extension, of course).

  7. #5
    New Lounger
    Join Date
    Mar 2013
    Location
    Atlanta, Ga
    Posts
    15
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Admin Privilege

    riffraff & Paul T:
    You guys are the best!! I won't tell you that years ago I was an admin for a large international company. While working to become CCNA, I have missed some basic items. I did go to the 'Properties' and added myself to the 'Group or user names'. Thank you both for the timely...and correct...solution. Now, to eliminate the greyed out area that does not allow me to tick the box for hosts to open automatically in Notepad. Luther

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •