Results 1 to 7 of 7
  1. #1
    Lounger
    Join Date
    Dec 2009
    Location
    Werribee Sth. Vic. Australia
    Posts
    39
    Thanks
    18
    Thanked 0 Times in 0 Posts

    Cannot partition new hard disk

    I have 2 hard drives in my PC. I have replaced the 2nd hard drive with a 2TB drive but I cannot partition or format it. If I right click on the striped area for the drive in the Computer Management screen the partition and format items are greyed out as per below screen capture.
    ScreenHunter_002.jpg

    If I right click on the grey area for the drive and click on properties I get the following:
    ScreenHunter_003.jpg

    The above screen capture shows that the drive is working properly. What do i need to do to enable the partition and format options?

    I'm running XP Home SP3.

    Bob
    Last edited by BarcodeBob; 2013-06-23 at 03:01.

  2. #2
    Silver Lounger
    Join Date
    Oct 2012
    Posts
    2,335
    Thanks
    13
    Thanked 267 Times in 260 Posts
    It's a GPT-type disk, you need a MBR type disk for XP. Look for command line options for converting GPT to MBR if you want to do it natively in XP. Otherwise it can be done on any Win 7 or 8 system in Disk Management. Or partition programs like MiniTool or EaseUS have to offer for free should do the trick as will GParted.

  3. The Following User Says Thank You to F.U.N. downtown For This Useful Post:

    BarcodeBob (2013-06-25)

  4. #3
    Lounger
    Join Date
    Dec 2009
    Location
    Werribee Sth. Vic. Australia
    Posts
    39
    Thanks
    18
    Thanked 0 Times in 0 Posts
    Thanks for the reply F.U.N. downtown, much appreciated. I'll get one of the programs and give it a go.

  5. #4
    Bronze Lounger DrWho's Avatar
    Join Date
    Dec 2009
    Location
    Central Florida
    Posts
    1,501
    Thanks
    30
    Thanked 205 Times in 163 Posts
    Windows cannot even SEE a hard drive that has NO partitions on it.

    That's the reason why I always boot up in DOS to run FDISK and set at least ONE partition on any new HD that I acquire.
    Then Windows will see it and can format it.
    Personally, I'd rather do that in DOS too.

    In spite of all the nay-sayers, XP actually runs better on a FAT-32 partition than it does on an NTFS partition, and you have better control over what's on the drive.

    Cheers Mates!
    The Doctor
    Experience is truly the best teacher.

    Backup! Backup! Backup! GHOST Rocks!

  6. #5
    Lounger
    Join Date
    Dec 2009
    Location
    Werribee Sth. Vic. Australia
    Posts
    39
    Thanks
    18
    Thanked 0 Times in 0 Posts
    I tried the command line options but got the message "The disk you specified cannot be converted to MBR".

    I tried EaseUS. I right click on the drive but there is no option to convert to MBR. I also clicked on Disk as per the help file and there is no option under there to convert to MBR.

    I did a bit more searching and found that you have to have to clear the partition first so I did that with the command line option 'clear'. I then went back to EaseUS and was able to create the partition and format it. At no time did I actually convert from GPT to MBR but it's now showing as MBR.

  7. #6
    Silver Lounger
    Join Date
    Oct 2012
    Posts
    2,335
    Thanks
    13
    Thanked 267 Times in 260 Posts
    I knew you'd figure it out because there was only one direction in which to figure it out.
    You could/can complete the entire task in EaseUS as well after deleting all partitions:

    Solution 1: Convert GPT disk to MBR disk with EaseUS Partition Master
    EaseUS Partition Master can only convert empty disk without partitions. Please delete all the partitions on the disk. We suggest you back up the disk before converting by the built-in Copy Wizard of EaseUS Partition Master. Please read this article for the detailed steps: Disk Copy Wizard in EaseUS Partition Master to protect data.

    1. Launch EaseUS Partition Master. Right click the disk; choose "Delete all partitions".

    2. Click "OK" to confirm the deletion.

    3. Choose the empty disk, right click it and then select "Initialize to MBR".

    4. Click "Apply" to do all the pending operations. The disk is in MBR format now.

  8. The Following User Says Thank You to F.U.N. downtown For This Useful Post:

    BarcodeBob (2013-06-25)

  9. #7
    Lounger
    Join Date
    Dec 2009
    Location
    Werribee Sth. Vic. Australia
    Posts
    39
    Thanks
    18
    Thanked 0 Times in 0 Posts
    Yep it's all working well now. I'll remember Solution 1 if this happens again and the odds are it will. Thanks very much for your help, very much appreciated.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •