Results 1 to 11 of 11
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    New Orleans, LA, USA
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Can't edit shortcut target path

    I try to reserve my C drive for my OS (Win 7 Pro 64bit) and for any programs that donít give me a choice of their installation location. My data is all on Drive D, and my other programs are on Drive E. Recently I installed Chrome to test as an alternative to Firefox. Chrome installed on C by default (no other choice). When I created desktop and taskbar shortcuts to chrome.exe the proper icons appeared in the proper place, but when I clicked on either one, the icon switched to a generic folder and I got an error message saying the Target path is incorrect Ė it points to E. If I go into the shortcut properties dialogue and attempt to change the target path to the correct one, and click apply or OK Ė it always reverts to E. Iíve tried several variations, have uninstalled and reinstalled chrome three times, but I cannot edit the Target path for the shortcut. Diving into various registry parameters has not helped either, but perhaps Iím in the wrong place. Do you have any suggestions?

  2. #2
    4 Star Lounger SpywareDr's Avatar
    Join Date
    Dec 2009
    Location
    Riviera Beach, Maryland, USA
    Posts
    490
    Thanks
    10
    Thanked 52 Times in 43 Posts
    To create a shortcut to Google Chrome on your Desktop, click Start, type in chrome , right-click the Google Chrome that appears in the list and select Sent to > Desktop (create shortcut).

    To pin Google Chrome to your Taskbar, start the same way but after right-clicking Google Chrome, select Pin to Taskbar.

  3. #3
    New Lounger
    Join Date
    Dec 2009
    Location
    New Orleans, LA, USA
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by SpywareDr View Post
    To create a shortcut to Google Chrome on your Desktop, click Start, type in chrome , right-click the Google Chrome that appears in the list and select Sent to > Desktop (create shortcut).

    To pin Google Chrome to your Taskbar, start the same way but after right-clicking Google Chrome, select Pin to Taskbar.
    I did all of that -- sorry if my message wasn't clear enough -- but when I click on the shortcuts I get the error message about the wrong target path.

  4. #4
    WS Lounge VIP mrjimphelps's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    3,396
    Thanks
    445
    Thanked 404 Times in 376 Posts
    Create a new shortcut, and browse to find Chrome when setting up the shortcut.

  5. #5
    New Lounger
    Join Date
    Dec 2009
    Location
    New Orleans, LA, USA
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by mrjimphelps View Post
    Create a new shortcut, and browse to find Chrome when setting up the shortcut.
    Done that (several times) -- the problem is in editing the Target in the properties dialogue -- no matter what I do, it changes to E:\.....chrome.exe when it should be C:\.....chrome.exe.

  6. #6
    Silver Lounger
    Join Date
    Oct 2012
    Posts
    2,335
    Thanks
    13
    Thanked 267 Times in 260 Posts
    Which version of Chrome did/are you install? There is a standalone install if you aren't onto that one; perhaps that one would let you do as wished. The default one does install rather unconventionally.

    https://www.google.com/intl/en/chrome/browser/index.html?standalone=1#eula
    Last edited by F.U.N. downtown; 2013-06-24 at 17:09.

  7. #7
    New Lounger
    Join Date
    Jan 2014
    Posts
    3
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Hi, I am having the same exact problem as OP. The Chrome desktop shortcut target is being changed to E:\Program Files (x86) instead of C Drive where chrome is installed.
    An earlier version was installed on my E Drive, but since updating, it has changed to C Drive.

    I have tried manually creating a shorcut as suggested here, but windows changes the target within seconds to E Drive. If i copy the whole google chrome folder to E:\Program Files (x86), I can create a working shortcut, but Chrome thinks it is a new install, and I have to login each time.

    I have tried the standalone install as well, to no avail.

    If anyone has an answer or a workaround, I would appreciate it.
    Thanks

  8. #8
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    What happens if you uninstalled Chrome, clean up any left over folder, and then reinstall Chrome?

    Joe

  9. The Following User Says Thank You to JoeP517 For This Useful Post:

    vanquish (2014-01-05)

  10. #9
    New Lounger
    Join Date
    Jan 2014
    Posts
    3
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Hi Joe,
    I Have deleted Chrome folders from C and E drives after uninstalling, then reinstalled, still same problem.
    I have also searched for and deleted all references to e:\program files (x86) .... chrome in the registry

  11. #10
    New Lounger
    Join Date
    Jan 2014
    Posts
    3
    Thanks
    2
    Thanked 0 Times in 0 Posts
    I have found out the problem with my particular issue with the Chrome Shortcut.

    I had previously installed an SSD, and installed windows on that drive, and because it was only a 128GB drive, I was using E drive for most of my installs. I had Set the ProgramFilesDir and x86 values in Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Win dows\CurrentVersion in the Registry to E:Program Files where applicable, and because Chrome auto installs now to C Drive, Windows somehow got confused and kept changing the shortcut target to E Program Files.

    I have since changed these values back to C Program Files in the registry in the 3 applicable places, and the shortcut target does not change anymore, problem solved.

    Hope this helps for anyone with a similar problem.

  12. #11
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,572
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    Glad you got it resolved. Thanks for posting back.

    Joe

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •