Results 1 to 11 of 11
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    Brussels, Belgium
    Posts
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Thorny printer issue

    I'm on Vista, all patched up with the latest Microsoft patches.

    For some reason I can't get my printer sharing set to ON...
    I go to the Network & Sharing Center, choose Printer sharing, approve with User Access Control, .... and it stays off

    Is there a registry key I need to tweak? some other setting?

    Thanks for any insight!

  2. #2
    New Lounger
    Join Date
    Dec 2009
    Location
    Brussels, Belgium
    Posts
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts
    congtyseovb,

    thank you for replying, but I can't read what you wrote?

  3. #3
    Super Moderator jwitalka's Avatar
    Join Date
    Dec 2009
    Location
    Minnesota
    Posts
    6,794
    Thanks
    117
    Thanked 799 Times in 720 Posts
    Try going to
    Start orb
    Devices and printers
    right click on your printer
    select printer properties
    click on the sharing tab
    check "share this printer" and give it a name.
    click OK

    Jerry

  4. #4
    New Lounger
    Join Date
    Dec 2009
    Location
    Brussels, Belgium
    Posts
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Jerry,

    Thanks for the suggestion.

    I did as you indicated, On the 'Sharing' tab, I click 'Change Sharing Options' & confirm the UAC prompt.
    I activate sharing, name the printer, and confirm.

    When I go back into the properties, it's as if I wasn't even there a moment ago - still not shared.
    *grumble*

  5. #5
    Super Moderator jwitalka's Avatar
    Join Date
    Dec 2009
    Location
    Minnesota
    Posts
    6,794
    Thanks
    117
    Thanked 799 Times in 720 Posts
    In the Network and Sharing center, did you click on
    Change Advanced Sharing Settings
    Check Turn on File and Printer Sharing
    Check Turn on Network Discovery
    Go back to printer properties and enable sharing again

    Do you have a third partysoftware firewall? If so, disable it to check to see if it is the problem.

  6. #6
    New Lounger
    Join Date
    Dec 2009
    Location
    Brussels, Belgium
    Posts
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts
    jwitalka,

    1. where would I find Advanced Sharing Settings?
    Capture.JPG
    2. When I try to activate Network Discovery, I get the same thing as with Printer Sharing - I go through the procedure, but the result is unchanged

    I use the Windows firewall

  7. #7
    Super Moderator jwitalka's Avatar
    Join Date
    Dec 2009
    Location
    Minnesota
    Posts
    6,794
    Thanks
    117
    Thanked 799 Times in 720 Posts
    I assumed the Windows 7 Network Center would look the same as Windows Vista. Sorry about that.

    Check your Services. Ensure that the required services are Started on all the computers:
    Go to Start\Control Panel\ Administrative Tools\ Services.
    o Computer Browser
    o DHCP Client
    o DNS Client
    o Network Connections
    o Network Location Awareness
    o Remote Procedure Call (RPC)
    o Server
    o TCP/IP Netbios helper
    o Workstation
    All of these services should be started, and their startup type should be automatic.
    To change the startup type, double-click on the service name and change accordingly.
    This should do the trick.
    For additional information on Networking issues, see this help article.
    Why can’t I connect to a network?
    http://windows.microsoft.com/en-US/w...t-to-a-network

    Jerry

  8. #8
    New Lounger
    Join Date
    Dec 2009
    Location
    Brussels, Belgium
    Posts
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts
    All the services are started & automatic, EXCEPT Computer Browser, which doesn't run.
    When I start it, it stops..
    This is the error message:
    Capture.JPG

  9. #9
    New Lounger
    Join Date
    Dec 2009
    Location
    Brussels, Belgium
    Posts
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts
    update!

    I think I found the solution - your previous question about a firewall set me to thinking
    so I checked technet for firewall and printer sharing
    found this answer : http://technet.microsoft.com/en-us/l...(v=ws.10).aspx
    I ran the suggested command in elevated mode
    (netsh firewall set service type = fileandprint mode = enable)
    DOS prompt said 'OK'
    Checked in Services, and Computer browser is active
    Checked in network & sharing center & printer & file sharing ON

    Thanks all for getting the grey matter running again!

  10. #10
    Super Moderator jwitalka's Avatar
    Join Date
    Dec 2009
    Location
    Minnesota
    Posts
    6,794
    Thanks
    117
    Thanked 799 Times in 720 Posts
    Happy to hear you were able to solve your problem. Nice work. Thanks for posting the solution.

    Jerry

  11. #11
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    Courtenay, BC
    Posts
    244
    Thanks
    9
    Thanked 16 Times in 15 Posts
    Thanks for the suggestions. A few years back, I went though some 10 fixes to get a Vista box to reliably share it's printers. It would appear to share but block the print file without an error, then refuse to share, etc. etc. In the end, I moved the printer to a print server that was then shared with all. That did the job.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •