Page 1 of 2 12 LastLast
Results 1 to 15 of 17
  1. #1
    Bronze Lounger
    Join Date
    Jan 2010
    Location
    Birkirkara, Malta
    Posts
    1,467
    Thanks
    205
    Thanked 15 Times in 14 Posts

    4 Core 1333 Full HD Motherboard

    If someone could give me a link to download the correct chipset drivers for the 4 Core 1333 Full HD Motherboard I would be grateful.

    Thanks in anticipation, Roy
    OS Dual Boot Windows 10 Pro 64 Bit & Windows 7 Pro With SP1 64 bit. (Intel Core i7 2600K Processor LGA1155-Asus P867 Pro Motherboard-GTX550 Ti DirectCU Graphics Card-Memory 8GB)

    Roy Whitethread

  2. #2
    Super Moderator satrow's Avatar
    Join Date
    Dec 2009
    Location
    Cardiff, UK
    Posts
    4,490
    Thanks
    284
    Thanked 577 Times in 480 Posts
    ASRock download page: http://www.asrock.com/mb/ATI/4Core13.../?cat=Download

    If you have a more recent OS than listed there or would like more recent drivers, try the Intel Support site, the chipset is the Intel® i965x.

  3. #3
    3 Star Lounger bassfisher6522's Avatar
    Join Date
    Jul 2013
    Location
    NC
    Posts
    373
    Thanks
    53
    Thanked 40 Times in 39 Posts
    In his signature, he has an Asus mobo listed. So what is the actual mobo does the OP have?

  4. #4
    Bronze Lounger
    Join Date
    Jan 2010
    Location
    Birkirkara, Malta
    Posts
    1,467
    Thanks
    205
    Thanked 15 Times in 14 Posts
    Hi satrow, thanks for the quick reply. My question related to my partner's Win 7 Pro 32 bit system, so as you implied the first link doesn't apply. The second link doesn't list the same motherboard as my partner's. Having said all that, my local computer technician says the Windows drivers are OK for the motherboard.

    bassfisher, sorry for the confusion. I should have made it clear it was not my motherboard I was asking about.
    OS Dual Boot Windows 10 Pro 64 Bit & Windows 7 Pro With SP1 64 bit. (Intel Core i7 2600K Processor LGA1155-Asus P867 Pro Motherboard-GTX550 Ti DirectCU Graphics Card-Memory 8GB)

    Roy Whitethread

  5. #5
    Super Moderator satrow's Avatar
    Join Date
    Dec 2009
    Location
    Cardiff, UK
    Posts
    4,490
    Thanks
    284
    Thanked 577 Times in 480 Posts
    The Intel site will only list Intel-built hardware; the downloads relevant to the i965x motherboard chipsets will contain the correct drivers for your (partner's) 'board. You might try the auto-detect on the Intel Support landing page, too. But, as your tech suggested, the Windows-installed drivers should work fine for it.

  6. #6
    Super Moderator CLiNT's Avatar
    Join Date
    Dec 2009
    Location
    California & Arizona
    Posts
    6,121
    Thanks
    160
    Thanked 609 Times in 557 Posts
    Come on Roy you ought to know better, at least by now, we are not mind reader here.
    Give us the make and model of the board.

    If you don't know it download this, or open the case up and take a look.
    DRIVE IMAGING
    Invest a little time and energy in a well thought out BACKUP regimen and you will have minimal down time, and headache.

    Build your own system; get everything you want and nothing you don't.
    Latest Build:
    ASUS X99 Deluxe, Core i7-5960X, Corsair Hydro H100i, Plextor M6e 256GB M.2 SSD, Corsair DOMINATOR Platinum 32GB DDR4@2666, W8.1 64 bit,
    EVGA GTX980, Seasonic PLATINUM-1000W PSU, MountainMods U2-UFO Case, and 7 other internal drives.

  7. #7
    Bronze Lounger
    Join Date
    Jan 2010
    Location
    Birkirkara, Malta
    Posts
    1,467
    Thanks
    205
    Thanked 15 Times in 14 Posts
    Hi CLiNT, I do know better, or I am getting very confused, because I said from the start that the motherboard is the 4 Core 1333 Full HD Motherboard. CPU-Z confirms this and says the Chipset is the ATI Xpress 1250 (RS600), Southbridge ATI SB600, LPCIO Winbond W83627EHF, BIOS American Megatrends, Version P1.70, Date 19 Feb 2008.

    I await your further comments.

    Regards, Roy

    PS. If I am confused it's because my partner died in hospital on Tuesday morning, and it's going to take me a very long while to get over it. The shock was made worse by the fact that the specialist told me and her family the day before she died that he thought she might live for another 10 years, so you can imagine how I and her family felt when we were told that she died at 5.30 a.m. the next morning. We were with her until after 10 p.m. the previous evening, and had we known what was going to happen we would have stayed with her overnight.
    OS Dual Boot Windows 10 Pro 64 Bit & Windows 7 Pro With SP1 64 bit. (Intel Core i7 2600K Processor LGA1155-Asus P867 Pro Motherboard-GTX550 Ti DirectCU Graphics Card-Memory 8GB)

    Roy Whitethread

  8. #8
    3 Star Lounger bassfisher6522's Avatar
    Join Date
    Jul 2013
    Location
    NC
    Posts
    373
    Thanks
    53
    Thanked 40 Times in 39 Posts
    because I said from the start that the motherboard is the 4 Core 1333 Full HD Motherboard
    This is not a mobo name....all mobo have a brand name. Even store bought PC's mobo's have a brand name. Some of the more common mobo names are: Asus, Gigabyte, ASRock, BioStar, MSI and so on. What you've listed are some of the specifications of the mobo not the brand. We need the make and model of your mobo....here's mine as an example.

    Gigabyte: GA-MA790X-DS4

  9. #9
    Super Moderator satrow's Avatar
    Join Date
    Dec 2009
    Location
    Cardiff, UK
    Posts
    4,490
    Thanks
    284
    Thanked 577 Times in 480 Posts
    FYI: the ASRock support page I linked back in #2 gives the motherboard name as "4Core1333-FullHD".

    Don't rush back with a reply to confirm this, Roy, I can only imagine how shocked you must feel right now. Take your time, our thoughts are with you.

  10. #10
    3 Star Lounger bassfisher6522's Avatar
    Join Date
    Jul 2013
    Location
    NC
    Posts
    373
    Thanks
    53
    Thanked 40 Times in 39 Posts
    FYI: the ASRock support page I linked back in #2 gives the motherboard name as "4Core1333-FullHD".
    Ahh...thanks satrow...I missed that completely. Looks like that mobo is ancient, like my old Asus M4N78 Pro, I couldn't get a chipset driver either for it to properly work with windows 8. The OP just might be out of luck with trying to run windows 8 on that board.

  11. #11
    Bronze Lounger
    Join Date
    Jan 2010
    Location
    Birkirkara, Malta
    Posts
    1,467
    Thanks
    205
    Thanked 15 Times in 14 Posts
    satrow, thanks for your kind remarks. I am trying to carry on with life, but it's very difficult.

    Could you please give me a link to the Intel Support landing page, so I can try the auto detect option.
    OS Dual Boot Windows 10 Pro 64 Bit & Windows 7 Pro With SP1 64 bit. (Intel Core i7 2600K Processor LGA1155-Asus P867 Pro Motherboard-GTX550 Ti DirectCU Graphics Card-Memory 8GB)

    Roy Whitethread

  12. #12
    Super Moderator satrow's Avatar
    Join Date
    Dec 2009
    Location
    Cardiff, UK
    Posts
    4,490
    Thanks
    284
    Thanked 577 Times in 480 Posts
    http://www.intel.com/p/en_US/support/ left side for the auto detect link.

    Stay strong, Roy.

  13. #13
    Bronze Lounger
    Join Date
    Jan 2010
    Location
    Birkirkara, Malta
    Posts
    1,467
    Thanks
    205
    Thanked 15 Times in 14 Posts
    satrow, thanks again. I ran the auto detect app but for every device type listed it said the device was unknown or unsupported. Do you have any other suggestions?

    I am doing my best to stay strong.
    OS Dual Boot Windows 10 Pro 64 Bit & Windows 7 Pro With SP1 64 bit. (Intel Core i7 2600K Processor LGA1155-Asus P867 Pro Motherboard-GTX550 Ti DirectCU Graphics Card-Memory 8GB)

    Roy Whitethread

  14. #14
    Administrator
    Join Date
    Jun 2010
    Location
    Portugal
    Posts
    12,519
    Thanks
    152
    Thanked 1,398 Times in 1,221 Posts
    Sorry, Roy, it's not clear to me what you are trying to accomplish. Are you trying to setup Windows 7 on that computer? At what point of the process are you at?

    Allow me to extend my condolences for you loss.
    Rui
    -------
    R4

  15. #15
    Bronze Lounger
    Join Date
    Jan 2010
    Location
    Birkirkara, Malta
    Posts
    1,467
    Thanks
    205
    Thanked 15 Times in 14 Posts
    Rui, thanks. The computer concerned is running Win 7 Pro 32 bit with SP1 and is running well, but I wanted to check that the chipset drivers were up to date.
    OS Dual Boot Windows 10 Pro 64 Bit & Windows 7 Pro With SP1 64 bit. (Intel Core i7 2600K Processor LGA1155-Asus P867 Pro Motherboard-GTX550 Ti DirectCU Graphics Card-Memory 8GB)

    Roy Whitethread

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •