Results 1 to 12 of 12
  1. #1
    Star Lounger
    Join Date
    Nov 2006
    Posts
    97
    Thanks
    11
    Thanked 2 Times in 2 Posts

    Existing documents, with no macros, load with Security Warning - Macros have been disabled

    I run Word 2010 under Windows 7.

    Many of my existing Word 2010 documents load with a yellow stripe across the top with the text [!] Security Warning - Macros have been disabled.

    I'm sure these documents have no embedded macros, and if they do, I want to eliminate them.

    How do I fix this? Is there a mass macro-delete utility I can run in my Word Documents Library?

    Thanks.

  2. #2
    2 Star Lounger
    Join Date
    Feb 2001
    Location
    Willow Grove, Pennsylvania, USA
    Posts
    196
    Thanks
    4
    Thanked 46 Times in 38 Posts
    What is the extension of the files that show the warning?

    If it's .doc or .docm, then the problem is caused by where the file is stored. You need to either move the file to a trusted folder, or trust the folder where the file is now stored. To find out which folders are trusted or to trust more folders, go to File > Options > Trust Center > Trust Center Settings > Trusted Locations. The list in the dialog shows the current set of trusted locations. To add another one, click the Add New Location button and select the folder that contains the document.

    If it's .docx, there's some other problem, because .docx files can't contain macros or even look like they might contain macros. In fact, that's one way to eliminate macros from a .docm file -- save it as a .docx, and the saving process will strip out the macros.

  3. #3
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,538
    Thanks
    3
    Thanked 148 Times in 141 Posts
    You need to check the attached document on those documents. The document itself may not contain a macro but perhaps the attached template does and if that template is not in a 'trusted location' then you could expect this message.

    Despite JJ's suggestion, I wouldn't recommend setting your documents folder as a trusted location other than for testing purposes. The templates directory is a whole different kettle of fish though - that location should be trusted.

    If ALL documents give you the same problem then I would suspect an add-in located in an untrusted location.
    Andrew Lockton, Chrysalis Design, Melbourne Australia

  4. #4
    Silver Lounger Charles Kenyon's Avatar
    Join Date
    Jan 2001
    Location
    Madison, Wisconsin, Wisconsin, USA
    Posts
    1,708
    Thanks
    57
    Thanked 65 Times in 63 Posts
    If the file type is .docx this should not happen (unless the document is attached to a template with macros in a non-trusted location).

    For a .doc file, once it has a macro, it will always be marked as a macro file, even if the macros are removed. Those could probably be saved as .docx files.

    I would also advise against setting your documents folder as a trusted location.
    Last edited by Charles Kenyon; 2013-08-02 at 18:22.
    Charles Kyle Kenyon
    Madison, Wisconsin

  5. #5
    New Lounger
    Join Date
    Jun 2014
    Posts
    5
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Was anyone able to solve this issue?

    I have MS Word 2010 and it never used to do this, but now every time I open any document...even a blank, new document, it gives me the security warning and asks me if I want to enable macros. All the documents are .docx. Some of the documents are saved on my desktop and some are saved on a network drive. I've added the drive and it's sub-folders to my trusted locations, but in reality it makes no difference where the document is...on my desktop or on the network drive...I get the warning no matter where the document is saved. I've considered changing my macro security setting, which is currently set to Disable with notification, but a I'm a bit weary of doing that.

    It's really annoying when you're on your laptop with a small screen, which is already half way taken up by the ribbons to have another band at the top. And it's just generally annoying! I've considered I would really appreciate any help!

  6. #6
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,538
    Thanks
    3
    Thanked 148 Times in 141 Posts
    And can you tell us about the document's attached template location? Is that trusted?
    Andrew Lockton, Chrysalis Design, Melbourne Australia

  7. #7
    New Lounger
    Join Date
    Jun 2014
    Posts
    5
    Thanks
    2
    Thanked 0 Times in 0 Posts
    I'm not sure what an attached template is, but I'm pretty sure a brand new document (i.e. going to file, New, new document) wouldn't have one, would it?
    Last edited by needhelpwithMS; 2014-06-06 at 08:26.

  8. #8
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,538
    Thanks
    3
    Thanked 148 Times in 141 Posts
    Every document has an attached template. If you set the attached template to nothing then the 'Normal template' is the attached template.

    Despite the dotx file itself containing no macros when you open a dotx file, macros in the attached template, the Normal template and any loaded addins become available. If any of these are in untrusted locations then this would cause your nagging message.
    Andrew Lockton, Chrysalis Design, Melbourne Australia

  9. The Following User Says Thank You to Andrew Lockton For This Useful Post:

    needhelpwithMS (2014-06-09)

  10. #9
    New Lounger
    Join Date
    Jun 2014
    Posts
    5
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Great!

    How do I figure out where the template is saved?

  11. #10
    2 Star Lounger
    Join Date
    Feb 2001
    Location
    Willow Grove, Pennsylvania, USA
    Posts
    196
    Thanks
    4
    Thanked 46 Times in 38 Posts
    There are a couple of ways to find the name of the attached template by using buttons on the ribbon, but if that happens to be the Normal template then all you'll see is "Normal" and not the folder path -- not helpful. To see the full path regardless of which template is attached, follow these steps:
    • Press Alt+F11 to open the macro editor.
    • Press Ctrl+G to open the Immediate window at the bottom right.
    • Type or paste this line in the Immediate window and press Enter:

    Print ActiveDocument.AttachedTemplate.FullName

  12. The Following User Says Thank You to jjfreedman For This Useful Post:

    needhelpwithMS (2014-06-09)

  13. #11
    Super Moderator
    Join Date
    May 2002
    Location
    Canberra, Australian Capital Territory, Australia
    Posts
    3,947
    Thanks
    0
    Thanked 204 Times in 185 Posts
    You will get a macro alert if a document contains any ActiveX controls with code attached, or a macro code module, even if that module is empty. Docx files can't contain macros, including in code attached to ActiveX controls. If you're getting alerts about docx files, that suggests they're using a template that isn't stored in a trusted location. To se what template a document uses and where that template is stored (if it's not the 'Normal' template, click on Developer>Document Template.
    Quote Originally Posted by Charles Kenyon View Post
    For a .doc file, once it has a macro, it will always be marked as a macro file, even if the macros are removed.
    Not so. Simply deleting the code module will resolve that.
    Cheers,

    Paul Edstein
    [MS MVP - Word]

  14. #12
    New Lounger
    Join Date
    Jun 2014
    Posts
    5
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Got it! I found the template location and added it to trusted locations. Seems to work now.

    Thank you guys!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •