Results 1 to 15 of 15
  1. #1
    Lounger
    Join Date
    Feb 2010
    Location
    calgary, alberta, canada
    Posts
    29
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Connecting computer with two printers

    I have my main computer wire connected to one printer but I would like to also connect the computer to a wireless all in one printer for scanning etc. Is it possible to have both a wired and a wireless connection to my router at the same time. If so How?
    Alan

  2. #2
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,436
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts
    Alan,

    You state that your main computer wire is to one printer. What type of wire would that be RJ-45 (network cable) or USB (printer cable)?
    If it's a RJ-45 you only need to connect the wireless printer to your router (assuming you have a wireless router) then you'll be able to select either printer. Please provide more detail including router make/model, printers make/model, and how the main printer is connected.
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  3. #3
    Lounger
    Join Date
    Feb 2010
    Location
    calgary, alberta, canada
    Posts
    29
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Sorry! The printer (epson R2260) is connected to the main computer with USB and the computer is connected to the router by RJ-45 cable. The wireless computer is an epson artisan 730 al in one printer.
    Alan

  4. #4
    Administrator
    Join Date
    Jun 2010
    Location
    Portugal
    Posts
    12,519
    Thanks
    152
    Thanked 1,398 Times in 1,221 Posts
    All you need to do is to configure the wireless printer to access your wireless network (probably as simple as specifying network identifier - SSID- and network key) and then install the printer drivers in your computer. Somewhere along the driver installation process you should be able to specify you want to connect to the printer through the network.
    Rui
    -------
    R4

  5. #5
    Super Moderator jwitalka's Avatar
    Join Date
    Dec 2009
    Location
    Minnesota
    Posts
    6,796
    Thanks
    117
    Thanked 799 Times in 720 Posts
    You need to read the owners manual for the steps to enable the wireless printer. You also need to have printer and file sharing enabled in Windows. If you don't have the manual handy, you can download it from here:
    http://www.epson.com/cgi-bin/Store/s...odoid=63091349

    I have a parallel port laser printer and a wireless all in one wireless printer and i can acess both easily.
    Jerry

  6. #6
    Administrator
    Join Date
    Jun 2010
    Location
    Portugal
    Posts
    12,519
    Thanks
    152
    Thanked 1,398 Times in 1,221 Posts
    You also need to have printer and file sharing enabled in Windows
    Why Jerry? If I got it right, there is only one computer.
    Rui
    -------
    R4

  7. #7
    Super Moderator jwitalka's Avatar
    Join Date
    Dec 2009
    Location
    Minnesota
    Posts
    6,796
    Thanks
    117
    Thanked 799 Times in 720 Posts
    I could be wrong but I think its necessary for the wireless printer. You could always try it both ways nad see if it works. Turning off file sharing is a security plus if you don't need it. I need it to share my laser printer with my laptop.
    Jerry

  8. #8
    Administrator
    Join Date
    Jun 2010
    Location
    Portugal
    Posts
    12,519
    Thanks
    152
    Thanked 1,398 Times in 1,221 Posts
    Quote Originally Posted by jwitalka View Post
    I could be wrong but I think its necessary for the wireless printer. You could always try it both ways nad see if it works. Turning off file sharing is a security plus if you don't need it. I need it to share my laser printer with my laptop.
    Jerry
    You don't need sharing to use a wireless printer, you can use it directly. That's how I have mine configured.
    Rui
    -------
    R4

  9. #9
    Super Moderator jwitalka's Avatar
    Join Date
    Dec 2009
    Location
    Minnesota
    Posts
    6,796
    Thanks
    117
    Thanked 799 Times in 720 Posts
    Quote Originally Posted by ruirib View Post
    You don't need sharing to use a wireless printer, you can use it directly. That's how I have mine configured.
    By directly, do you mean a wireless connection or a wired USB connection? When I disabled File and printer sharing in my Windows 7 PC, I got a "printer off line" error message when I tried to print wirelessly. Windows 7 has a separate setting for public folders sharing so turning on File and printer sharing is not a major security issue. As i said earlier, the OP can try it both ways.

    Jerry

  10. #10
    Administrator
    Join Date
    Jun 2010
    Location
    Portugal
    Posts
    12,519
    Thanks
    152
    Thanked 1,398 Times in 1,221 Posts
    I mean a network connection. You can print either from a computer connected to the network through Ethernet or wirelessly. If you had to share it, there really would be no point in having a network enabled printer. It would work like any shared printer back on 2000.
    The main advantage of having a networked printer is the ability to print to it without intermediaries. No server or sharing pc needed.
    Rui
    -------
    R4

  11. #11
    Lounger
    Join Date
    Feb 2010
    Location
    calgary, alberta, canada
    Posts
    29
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Thanks all. I guess I wasn't as clear as I should be.
    I have already set up my printer for wireless connection and I am able to print/copy etc from my wireless laptop. My main computer is wired (USB) to another printer which works well. The main computer is also wired directly to the cable modem. What I want to do is connect to the epson all in one printer. I have installed the epson software on the main, but when i try to scan etc the printer cannot see the main computer. I think I have to make the main computer able to use wireless connections but when I try to add wireless capability using "network and sharing" it wont allow it.
    In a nutshell all I want to do is make my main computer capable of using either wired connection or wireless connection
    Alan

  12. #12
    WS Lounge VIP mrjimphelps's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    3,407
    Thanks
    447
    Thanked 405 Times in 377 Posts
    Alan:

    There are two types of connections here: networked and local.

    "Local" means that the printer is connected directly to your computer via a wire, rather than indirectly to your computer via the router.

    "Networked" means that the printer is connected indirectly to your computer via the router. And it could be connected wirelessly, or with an ethernet cable.

    Wireless printers are an example of networked printers, because they connect to the router rather than to a specific computer. The computer accesses these printers via the router, not via a direct link to the printer.

    By connecting to the router rather than to the computer, the printer is easily accessed by all computers which are connected to the router.

    I've never heard of a wireless printer connecting directly to a computer; they always connect to the router. In this way, your computer doesn't need any sort of wireless connectivity to be able to access the printer.

  13. #13
    Administrator
    Join Date
    Jun 2010
    Location
    Portugal
    Posts
    12,519
    Thanks
    152
    Thanked 1,398 Times in 1,221 Posts
    Quote Originally Posted by alanwdixon View Post
    Thanks all. I guess I wasn't as clear as I should be.
    I have already set up my printer for wireless connection and I am able to print/copy etc from my wireless laptop. My main computer is wired (USB) to another printer which works well. The main computer is also wired directly to the cable modem. What I want to do is connect to the epson all in one printer. I have installed the epson software on the main, but when i try to scan etc the printer cannot see the main computer. I think I have to make the main computer able to use wireless connections but when I try to add wireless capability using "network and sharing" it wont allow it.
    In a nutshell all I want to do is make my main computer capable of using either wired connection or wireless connection
    Alan
    First, your wired computer is already on the network. Doesn't matter whether you used a wireless or wired connection, it is there, so it's not the fact that you are connecting it through Ethernet that prevents the "scanner" from seeing it. In my own setup, my 3 in 1, when scanning only sees my wired desktop and most times, it does not "see" my wirelessly connected laptop. Sometimes, even with the laptop connected through a wired connection, it still wasn't seen.

    What I did with my Canon was to start the scanning process from the computer. That usually works. I decided not to waste time trying to figure out why this happened, since I can always scan from the desktop and the I just transfer the file, if I need it elsewhere.

    Why doesn't see one computer when scanning? You can check firewall, maybe, and make sure the printer software is running when you scan.
    Rui
    -------
    R4

  14. #14
    Star Lounger
    Join Date
    May 2010
    Posts
    57
    Thanks
    1
    Thanked 12 Times in 9 Posts
    Hi Alan,

    Quick question: When you are trying to start a scan, are you using the control panel on the printer or using Epson's desktop software? If you're using the LCD panel on the printer, which option are you using? (See page 98 in the Artisan 730 User's Guide.)

    You mentioned that "the printer cannot see the main computer", which if that's what you'd like to do, it requires a different setup on your desktop computer because you would be pushing scans from the printer to the desktop computer. In order for that to work, your desktop computer would need to run WSD (Web Services for Devices). That in turn would require certain changes to your desktop computer's firewall settings, etc.

    As far as the wired and wireless connections, if the router is a combination router and WiFi access point, then the wired network ports and wireless connection will typically share the same IP address range (in more technical terms, the networks are "bridged"). However, most decent WiFi routers will allow you to assign separate IP address ranges to the wired network and the wireless network. If that's the case, then the laptop and printer running on the wireless network will be invisible to the wired network (and vice versa).

    If you're familiar with the web interface for the router, check the settings. Otherwise you can also easily compare the network setting between the laptop and desktop by running a simple command. Assuming that you're using Windows 95 or newer, start up a command prompt either from the Start Menu or the shortcut key combination [Windows Key] + [R] and typing "cmd". In the command prompt window, type "ipconfig". Compare the "Default Gateway" address from each computer. Chances are it's a private IP address in the Class C address range (e.g. 192.168.0.1).

  15. #15
    Star Lounger
    Join Date
    Dec 2009
    Location
    Southern California
    Posts
    78
    Thanks
    1
    Thanked 8 Times in 8 Posts
    I have just added a wireless HP laserjet printer to my home setup. I also have an HP inkjet connected by USB to one computer. I can print wirelessly from all three of my computers through my home network, although I did have to install print drivers on each computer separately.

    I can also print directly (Airprint) to the wireless printer from my iPod Touch and iPad. In addition I can eprint wirelessly from any computer where I can access my email address.

    It did take a phone call to HP Support to get all of the above implemented. If your all-in-one is still under warranty you should be able to call Epson for help without extra charges.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •