Results 1 to 14 of 14
  1. #1
    Star Lounger
    Join Date
    Dec 2009
    Location
    Poole, UK
    Posts
    95
    Thanks
    22
    Thanked 2 Times in 2 Posts

    Windows 8 wi-fi problem

    I wonder if anyone else had had, and found a solution to, the following wi-fi problem.

    I bought a new Asus laptop a few months ago and connect it to my router using wi-fi (there are several other pcs in the house which connect via cables). To start with all went well.

    However, recently, although it seems able to connect to the network ok, frequently an exclamation mark appears in front of the wi-fi signal strength icon in the system tray - indicating a limited connection ie no internet access. Sometimes after a while this clears by itself and sometimes I can make it do so by switching the flight safe mode one and off. Sometimes it happens on boot up and sometimes when waking from sleep, and sometimes it just happens randomly. Needless to say, the other pcs on the network can connect to the internet without a hitch!

    I've googled the problem and tried a number of suggested remedies - inc renewing the ip address and forgetting and reconnecting to the wi-fi network - but the problem persists and is becoming very annoying.

    I don't know if it's a clue but I have noticed that if I hover the mouse pointer over the wi-fi icon, the name of the network is followed by a number - which can vary between 2 and 4.

    Any ideas please? Thanks.
    Last edited by Victor Delta; 2013-08-03 at 15:04.

  2. The Following User Says Thank You to Victor Delta For This Useful Post:

    kaybee (2014-03-06)

  3. #2
    Super Moderator bbearren's Avatar
    Join Date
    Dec 2009
    Location
    Polk County, Florida
    Posts
    3,760
    Thanks
    26
    Thanked 424 Times in 338 Posts
    I have my laptop set to connect manually. So I always see the exclamation mark over the WiFi symbol on the taskbar. Hovering the mouse get me "No internet connection; connections are available". I click on the symbol, click on my network and then click Connect. It always does, and I have not more difficulties.

    Do you have your home network set as a preferred network in the Network and sharing center? Have you run the network troubleshooter when you have these difficulties?
    Create a fresh drive image before making system changes, in case you need to start over!

    "The problem is not the problem. The problem is your attitude about the problem. Savvy?"—Captain Jack Sparrow "When you're troubleshooting, start with the simple and proceed to the complex."—M.O. Johns "Experience is what you get when you're looking for something else."—Sir Thomas Robert Deware.
    Unleash Windows

  4. #3
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,631
    Thanks
    161
    Thanked 936 Times in 856 Posts
    I was also thinking the Network Troubleshooter might help isolate the problem. Right click the Network Icon and select Troubleshoot Problems and see what happens.
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  5. #4
    New Lounger
    Join Date
    Mar 2013
    Posts
    16
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Try disabling fast boot (if enabled) and see if that fixes your issue. It appears this feature shortens the allowable window for network responses.
    You can also try ipconfig /release and ipconfig /renew from a command prompt to see if that helps.

  6. #5
    Star Lounger
    Join Date
    Dec 2009
    Location
    Poole, UK
    Posts
    95
    Thanks
    22
    Thanked 2 Times in 2 Posts
    Thanks for all the suggestions. Last night I could not gain access via wi-fi and so ran the troubleshooter as suggested. It could not fix the problem and concluded "Wi-fi doesn't have a valid IP configuration".

    I then switched off the wi-fi and connected the pc and router via an ethernet cable. This time the network symbol appeared in the system tray but again with an exclamation mark and no internet access. Ran the troubleshooter and again it couldn't fix the problem but concluded "DNS server isn't responding".

    Left the cable connected overnight and this morning, when the pc awoke from it's slumbers, the exclamation mark soon disappeared and I've had an internet connection all day!

    Don't know if this provides any more clues as to what's wrong? Certainly looks as if it's a network issue rather than just a wi-fi problem.

    By the way, hovering over the network icon shows the name of the router with a '4' after it. I do wonder if this shows that the pc has multiple network settings stored for the one router and is therefore getting confused. Is there any way to flush out the old settings and start again with a clean slate (I've tried 'Forget' the wi-fi network and then reconnecting, but the numbers persist)? Also, should the network and wi-fi names be the same or could this be causing conflicts perhaps. Just thoughts...

    Thanks again.

    PS norepli - I have already tried ipconfig /release and ipconfig /renew to no avail.

  7. #6
    Silver Lounger
    Join Date
    Oct 2012
    Posts
    2,335
    Thanks
    13
    Thanked 267 Times in 260 Posts
    You could go into Network and sharing center>Change adapter settings>and right click on the wired adapter and choose properties or is it status and then details(?) whatever will get you to the I.P. address details in use because those settings are working. Note the address of your system and the default gateway address and the DNS server addresses.

    The wireless adapter there as well? Right click on that and choose properties and then the TCP/IPv4 line and click on properties and then tic the use following IP address and enter the address manually according to the address details from the wired adapter EXCEPT increment the last number of the first line by one or two. Duplicate everything else including the DNS. Note, you can substitute the DNS numbers with 8.8.8.8 and 8.8.4.4 (Google's DNS) if you like. Do not validate on exit (could change the numbers according to other inputs and screw things up).
    Then, pull or disable the wired connection/adapter and if you don't have the little wireless icon in the tray to click on and connect to your router, right click on the wireless adapter and choose connect and see if it works that way.

    If it works then everything is probably ok on the computer's end and could indeed be a problem with the DNS, especially if the Google DNS works pingitty-bop.

  8. The Following User Says Thank You to F.U.N. downtown For This Useful Post:

    Victor Delta (2013-08-03)

  9. #7
    Star Lounger
    Join Date
    Dec 2009
    Location
    Poole, UK
    Posts
    95
    Thanks
    22
    Thanked 2 Times in 2 Posts
    Hi FUN downtime

    Very many thanks for that. I followed your instructions, including using the Google DNS, and the wi-fi seems to be working again now.

    I'll keep it under review but thank you so much.

    PS Hovering over wi-fi icon shows name of network followed by 2. Any thoughts on how to get rid of the numbers...?

  10. #8
    WS Lounge VIP mrjimphelps's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    3,396
    Thanks
    445
    Thanked 404 Times in 376 Posts
    Quote Originally Posted by Victor Delta View Post
    Hi FUN downtime

    Very many thanks for that. I followed your instructions, including using the Google DNS, and the wi-fi seems to be working again now.

    I'll keep it under review but thank you so much.

    PS Hovering over wi-fi icon shows name of network followed by 2. Any thoughts on how to get rid of the numbers...?
    It sounds like somehow additional network connection profiles were created. If so, then delete all except for the one you are currently using, i.e., the one which works.

  11. #9
    Silver Lounger
    Join Date
    Oct 2012
    Posts
    2,335
    Thanks
    13
    Thanked 267 Times in 260 Posts
    You should be able to right click the connection name and rename it. Every time a different network configuration is detected, it makes a new one and adds a number.
    Also, the wireless as configured now is specific to that single connection; if you travel at all with it and try to connect to other wifi sources those numbers probably won't work; except for the Google DNS; they'll work unless Google shuts down.

  12. #10
    Star Lounger
    Join Date
    Dec 2009
    Location
    Poole, UK
    Posts
    95
    Thanks
    22
    Thanked 2 Times in 2 Posts
    Quote Originally Posted by mrjimphelps View Post
    It sounds like somehow additional network connection profiles were created. If so, then delete all except for the one you are currently using, i.e., the one which works.
    Yes, that's what I'd like to do... but where/how are the profiles stored please?

    "You should be able to right click the connection name and rename it" - doesn't appear to be an option in Windows 8 unless I'm looking in the wrong place...?

  13. #11
    Silver Lounger
    Join Date
    Oct 2012
    Posts
    2,335
    Thanks
    13
    Thanked 267 Times in 260 Posts
    Looks like the Network # remains now, I couldn't change that part either in Windows 7, but it does work, in XP.

  14. #12
    Super Moderator bbearren's Avatar
    Join Date
    Dec 2009
    Location
    Polk County, Florida
    Posts
    3,760
    Thanks
    26
    Thanked 424 Times in 338 Posts
    Quote Originally Posted by F.U.N. downtown View Post
    Looks like the Network # remains now, I couldn't change that part either in Windows 7, but it does work, in XP.
    FWIW, the only way I've been able to get rid of the #'s in Windows 7/8 is to completely remove the connection profile and then recreate it.
    Create a fresh drive image before making system changes, in case you need to start over!

    "The problem is not the problem. The problem is your attitude about the problem. Savvy?"—Captain Jack Sparrow "When you're troubleshooting, start with the simple and proceed to the complex."—M.O. Johns "Experience is what you get when you're looking for something else."—Sir Thomas Robert Deware.
    Unleash Windows

  15. #13
    Star Lounger
    Join Date
    Dec 2009
    Location
    Poole, UK
    Posts
    95
    Thanks
    22
    Thanked 2 Times in 2 Posts
    Quote Originally Posted by bbearren View Post
    FWIW, the only way I've been able to get rid of the #'s in Windows 7/8 is to completely remove the connection profile and then recreate it.
    How (in Windows 8)?

  16. #14
    Super Moderator jwitalka's Avatar
    Join Date
    Dec 2009
    Location
    Minnesota
    Posts
    6,792
    Thanks
    117
    Thanked 798 Times in 719 Posts

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •