Results 1 to 3 of 3
  1. #1
    New Lounger
    Join Date
    Sep 2013
    Posts
    3
    Thanks
    0
    Thanked 1 Time in 1 Post

    Static IP for docking station, is lost?

    Hi,
    I have many users with Lenovo T410 laptops and Lenovo docking stations. They run Windows 7 64 bit.

    Because of a difficult issue related to multiple routers in the office (which we hope to clear up in a few months), we have to set static IP addresses for the Ethernet adapter in the Lenovo docking stations. We're seeing a problem though in that these laptops revert back to DHCP (automatically acquired) IP addresses for that Ethernet adapter in the docking station. We don't know for sure, but we suspect it happens when the laptop is taken home and booted up without the docking station attached. Perhaps Windows removes that IP setting entirely from the registry?

    I've tried googling for this issue (which is challenging) and haven't found anything.

    Any thoughts on this please?

    Regards,
    Clay Gibney

  2. #2
    Silver Lounger
    Join Date
    Oct 2012
    Posts
    2,147
    Thanks
    12
    Thanked 248 Times in 241 Posts
    Sounds like the docking station Ethernet is just passthrough? If so it does not get a separate network connection identity, relying on the laptop's network adapter, in which case, yes, any settings for that network are going to be lost as soon as a different network is identified and profiled. I don't think there is anything built into Windows to save a network profile so it can be quickly applied when connected to the same network again. I've heard of saving profiles manually in batch files but that might only apply to wireless connections.
    Sent from Windows ME thru Opera 10.63...just before they crashe

  3. #3
    New Lounger
    Join Date
    Sep 2013
    Posts
    3
    Thanks
    0
    Thanked 1 Time in 1 Post
    Thanks. I have confirmed that they are independent network controllers. The docking station has an Intel 82577LM chipset for Ethernet, while the laptop has an Intel Centrino 6250 for the network adapter. They each have unique MAC addresses as well which start with different prefixes.

    It's really annoying that Windows will just clear away the static IP address. It doesn't happen with a simple reboot while the laptop is still in the docking station but I'm thinking it must happen after a reboot when it's out of the docking station.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •