Results 1 to 5 of 5
  1. #1
    4 Star Lounger
    Join Date
    Feb 2001
    Location
    Gillingham, Kent, England
    Posts
    511
    Thanks
    0
    Thanked 0 Times in 0 Posts

    errors and lots of em! (97/SR2)

    Not sure if this is just an Access problem or a result of a more general one:

    To start with, the Active X controls list disappeared. Then, when running a database function I got the error: "Couldn't find installable ISAM"

    Our technical support guy handed me a troubleshooting document from technet and told me to try that which basically told me to rename a few dlls and remove then add the Data Access section in office setup. I now get "Active X component can't create object".

    I thought I'd post the errors here in the hope someone will recognise them and hopefully have a solution, before I bite the bullet and uninstall office completely (hope that works otherwise I see a Format coming!).

    Any help would be much appreciated.

  2. #2
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: errors and lots of em! (97/SR2)

    When and where do you get the error? Unfortunately, the error messages themselves are only helpful when we know what the context of the message was.
    Charlotte

  3. #3
    4 Star Lounger
    Join Date
    Feb 2001
    Location
    Gillingham, Kent, England
    Posts
    511
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: errors and lots of em! (97/SR2)

    Thanks for your reply Charlotte.

    The ISAM message was displayed when trying to export to text file. The Active X one appears when trying to open a more complex database, and I'm not sure of the processes it runs first, so I'll have to have a look at the .mdb and reply again when I have more info.

    10 minutes later..........
    Change of plan, the database gives the error when trying to display the login section and has security bits and won't display exactly where the error occurs. However, I tried another database and found the "Runtime error 429 - Active X component can't create object" is displayed when trying to run a module and the de###### highlights:

    Set dbs = CurrentDb

    Hope that helps some more.

  4. #4
    Plutonium Lounger
    Join Date
    Dec 2000
    Location
    Sacramento, California, USA
    Posts
    16,775
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: errors and lots of em! (97/SR2)

    That sounds highly suspicious. CurrentDb is built into Access, so you shouldn't be getting that error unless there's something odd about the way you declared the db variable, and I see no reason for you to get it in multiple databases unless there's something wrong with your installation of Access. I also assume you mean when trying to run a *routine*, since you don't run modules. You need to post more than just the line trying to set the db object, though. At least post the line where you dim the variable so we can see if that is contributing to the problem.

    The ISAM message sounds like you don't have the text converters installed for Office 97.
    Charlotte

  5. #5
    4 Star Lounger
    Join Date
    Feb 2001
    Location
    Gillingham, Kent, England
    Posts
    511
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: errors and lots of em! (97/SR2)

    Sorry about the lack of information.

    I have Office 2000 (except Access 2000) and Access 97 installed and yesterday I uninstalled the lot and started again, which seemed to fix the ISAM and Active X error. However my list of Active X controls is still empty, but I'm thinking of getting out part time IT technician to format my PC and start from scratch.

    Sorry again about the lack of info, next time I'll be sure to post a complete description.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •