Results 1 to 3 of 3
  1. #1
    2 Star Lounger
    Join Date
    Mar 2001
    Posts
    165
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Can't enable macros on 2010

    I'm moving my spreadsheets from my XP computer (Excel 2002) to my Win 7 computer (Excel 2010) since XP support ends next year. I use macros that I have (with help from here) written myself. When I open a spread sheet on Win 7 I get a warning that macros have been disabled. When I click on the Options it says that the Macros are disabled because the digital signature (which I signed myself on the other computer) is invalid. It doesn't expire until 1/1/2018, so it's not that it has expired. I can show signature details and view the certificate. The Certificate Information says the CA Root is not trusted. To enable trust, install this certificate in the Trusted Root Certification Authorities store. I click on Install Certificate, which opens the Certificate Import Wizard. It automatically selects a certificate store. Then I get a windows that says Completing the Certificate Import Wizard. I click finish and it says the import was successful. I close all the rest of the open boxes and the macros warning goes away. But I still can't run my macros because "The macro may not be available in this workbook or all macros may be disabled." If I look in Developer/Macros my macros are there. Saving the workbook as a macro-enabled workbook does solve the problem.

  2. #2
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,434
    Thanks
    371
    Thanked 1,457 Times in 1,326 Posts
    altdotcom,

    You can also add the directories/folders where your workbooks are stored to your "trusted locations" in the trust center. HTH
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  3. #3
    2 Star Lounger
    Join Date
    Mar 2001
    Posts
    165
    Thanks
    0
    Thanked 0 Times in 0 Posts
    That fixed it. Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •