Results 1 to 15 of 15
  1. #1
    Lounger
    Join Date
    Nov 2001
    Location
    SF Bay Area
    Posts
    42
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Prevent Word from Launching a Second Time (XP)

    Hi all,
    I am working with a client that is using Word XP integrated with iManage 5.3 DMS. Users are having a problem with accidently launching Word twice, causing system performance to choke. Is there a way to make Word check for an already running instance and if so, not launch a second time?

    Thanks!

  2. #2
    Super Moderator
    Join Date
    Dec 2000
    Location
    Renton, Washington, USA
    Posts
    12,560
    Thanks
    0
    Thanked 4 Times in 4 Posts

    Re: Prevent Word from Launching a Second Time (XP)

    I and running Windows 2K and Office XP. When a click the icon to open anther Word session it just opens a new Word document, NOT a complet new session.

    Now running HP Pavilion a6528p, with Win7 64 Bit OS.

  3. #3
    Lounger
    Join Date
    Nov 2001
    Location
    SF Bay Area
    Posts
    42
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Prevent Word from Launching a Second Time (XP)

    Hmm, interesting -- must be the way it's *supposed* to work. This client is also on Win2K, but not only do they have the DMS integration, but a professional template package, numbering assistant and document comparison add in, so perhaps one of these contains code that allows Word to launch twice. I thought maybe there would be a neat little switch upon launch, but now I think this sounds like a problem for the company programmers.

    Christie

  4. #4
    Gold Lounger
    Join Date
    Dec 2000
    Location
    New Hampshire, USA
    Posts
    3,386
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Prevent Word from Launching a Second Time (XP)

    Is Word actually getting started twice?
    Or do you think so only because you see more than 1 Word icon in the task bar?

    Check the Windows menu in Word, I'd guess that you have both files listed and it's only 1 Word session.

  5. #5
    Lounger
    Join Date
    Nov 2001
    Location
    SF Bay Area
    Posts
    42
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Prevent Word from Launching a Second Time (XP)

    It is definitely starting Word twice -- there is a single document under the Windows menu in each, and MDI is not turned on. The system starts to act like it's about to crash -- when switching windows the redisplay takes up to two minutes to refresh (usually it's immediate). I really think it must be something to do with their custom templates, because upon closing one instance of Word, there are error messages regarding a custom global template. Sigh!

  6. #6
    Super Moderator
    Join Date
    Dec 2000
    Location
    Renton, Washington, USA
    Posts
    12,560
    Thanks
    0
    Thanked 4 Times in 4 Posts

    Re: Prevent Word from Launching a Second Time (XP)

    Are you sure that you have Word XP (2002) and not Word 2000? This is how it worked in 2000 <img src=/S/devil.gif border=0 alt=devil width=15 height=15>

    Now running HP Pavilion a6528p, with Win7 64 Bit OS.

  7. #7
    2 Star Lounger
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    199
    Thanks
    8
    Thanked 0 Times in 0 Posts

    Re: Prevent Word from Launching a Second Time (XP)

    Hi all,

    New software - old problems!!

    For what its worth, I have Word97 with the following module to do the very same thing - its even WordBasic!

    Module AutoExec

    <pre>Public Sub MAIN()
    Dim Instances
    Dim Apps
    Dim i
    'Preventing Multiple Instances of Word
    'From the 01/06/98 issue of PC Magazine
    On Error GoTo -1: On Error GoTo bye
    Instances = 0
    Apps = WordBasic.AppCount() - 1
    ReDim winnames__$(Apps)
    WordBasic.AppGetNames winnames__$()
    For i = 0 To Apps
    If InStr(1, winnames__$(i), "Microsoft Word") Then
    Instances = Instances + 1
    End If
    If Instances > 1 Then
    WordBasic.MsgBox " There is currently another instance of Word running. _
    This instance will Close . ", 16
    WordBasic.AppClose
    i = Apps
    End If
    Next
    bye:
    End Sub</pre>


    Good Luck!

  8. #8
    Gold Lounger
    Join Date
    Feb 2001
    Location
    Dublin, Ireland, Republic of
    Posts
    2,697
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Re: Prevent Word from Launching a Second Time (XP)

    Check out MS KB article <A target="_blank" HREF=http://support.microsoft.com/support/kb/articles/Q102/4/96.asp?LN=EN-US&SD=gn&FR=0&qry=Explorer&rnk=1&src=DHCS_MSPSS_gn _SRCH&SPR=WRD97>Q102496</A>, it may give you some pointers.

    Andrew C

  9. #9
    New Lounger
    Join Date
    Nov 2001
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Prevent Word from Launching a Second Time (XP)

    I am very familiar with most issues involving iManage and Word both in Office XP and Office 2000 as we extensively integrate with both. Under certain circumstances, Word will be launched as a new process and sometimes it will add the document to the documents collection or just activate an existing instance. New processes may be created when users click on email attachments, documents located on websites, or starting the Outlook Mail Merge functionality.

    These actions are mostly predictable, can you be more specific about how users are starting Word "accidentally" a second time?

    Vick

  10. #10
    Lounger
    Join Date
    Nov 2001
    Location
    SF Bay Area
    Posts
    42
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Prevent Word from Launching a Second Time (XP)

    Thanks for all the suggestions -- I tried adding the autoexec macro to the normal.dot, but it doesn't work (I had to comment out the WordBasic msgbox, but otherwise it is all good code). They have a global template that I can't write to, perhaps it work if it was in that. Turns out they are running the application from the server, it's not a local installation of Word, so that might have something to do with it, as well.

  11. #11
    Lounger
    Join Date
    Nov 2001
    Location
    SF Bay Area
    Posts
    42
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Prevent Word from Launching a Second Time (XP)

    Hi Vick,

    They are *usually* starting a second version of Word because they are double clicking the icon on the QuickLaunch, which is new for them. They are migrating from NT 4.0 and Office 97 to Windows 2000 and Office XP. It is certainly a training issue, but I still think the double launch should be eliminated as a possibility, it causes such problems.

    It doesn't seem to launch a second instance when opening attachments, although we have had some intermittent problems with users opening attachments and being unable to save to iManage (error #91). If they forward the attachments to someone else, the other user can open the attachment and profile successfully -- we haven't figured that one out just yet.

  12. #12
    New Lounger
    Join Date
    Nov 2001
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Prevent Word from Launching a Second Time (XP)

    The default behavior of Word is to create a new document when clicking on the quicklaunch. 90% of the time, when this behavior is altered, it points to a setup issue. Here it is a matter of walking through the setup to find out where the actual change happens starting with a pristine wind2K machine and following the client's setup procedures comparing it to a regular XP setup. It may be related to the fact that Word is on the network, but most of the times it is due to some corrupt setting in the registry for either the shortcut or Word itself. Initially, I would stay away from trying to compensate through code for a behavior that should work in the first place.

    Vick

  13. #13
    3 Star Lounger
    Join Date
    Jan 2001
    Location
    Christchurch, New Zealand
    Posts
    250
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Re: Prevent Word from Launching a Second Time (XP)

    I have had the some clients with a similar problem, but with Word 2000. It appears to be double clicking the icon on the quick launch bar.

  14. #14
    New Lounger
    Join Date
    Feb 2001
    Location
    Richmond, Virginia, USA
    Posts
    17
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Prevent Word from Launching a Second Time (XP)

    Do away with the QuickLaunch bar -- at least as far as Office apps are concerned. Since going to Windows 2000 (and still Office 97), we have been having problems with users overwriting good files with blank files. They also sometimes get caught in a loop when closing Word that ends up with an overwritten normal.dot. People are so accustomed to the double-click that they do it on the QL bar without realizing it.

    I wondered why we did not have this problem with the good old Office Shortcut Bar. Well, a quick test shows that the OSB will not open another instance of an Office app! With Office XP, which we are testing, only Word is protected by OSB. Don't know why. But I will recommend bringing back the OSB for OXP, because Word is by far the most-used app here.

    This may come as no news to anyone at WOPR, but I thought I would share this revelation just in case.

  15. #15
    Star Lounger
    Join Date
    Jan 2001
    Location
    New York, New York, USA
    Posts
    84
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Prevent Word from Launching a Second Time (XP)

    Just my <img src=/S/2cents.gif border=0 alt=2cents width=15 height=15> but thought I'd jump in -- We also tracked this issue down to double-clicking on the quick launch icon.

    FWIW our users have the option of using a startmenu item and/or a desktop icon. This helps if old habits are deeply ingrained as they were here when users migrated from W95/Word 2000 to Windows 2000/Word 2000.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •