Results 1 to 6 of 6
  1. #1
    2 Star Lounger
    Join Date
    Jul 2013
    Posts
    171
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Default email problem in Windows 7

    My OS is Windows 7 Pro, SP1 (64 bit). Since I am the only user, there is no log-on password, and I have administrative rights.

    I am having a problem setting the default E-mail to recognize my E-mail program (Forté Agent). When I have a website open in my browser, and click on the website's link to send them an E-mail, Agent always opens just fine.

    But I have a couple of programs that also include a link to send them an E-mail. When I click on their link, I get this error message: "There is no email program associated to perform the requested action. Please install an email program or, if one is already installed, create an association in the Default Programs control panel".

    When I go to Default Programs, I have a couple of options:
    1. 'Set your default programs'. I click Agent in the left hand column, then click "Set this program as default'. Then OK. But even if I reboot my computer, and then go back to one of the programs that gave me the error message, I still get the error message.
    2. 'Set program access and Computer defaults'. There I choose the Custom dropdown. Under 'Choose a default e-mail program', the entry ''use my current e-mail program' is prechecked. So I change it to Agent, and click OK. But if I close the Default Programs screen, and then reopen it, 'use my current e-mail program' is AGAIN prechecked. And the programs still give me the error message.

    Agent itself does not seem to have a setting where I can select it as the default E-mail program (unlike my browsers) so that is not an option.

    What might be going on here, and how do I overcome it? I searched this forum, and could not find anything on the subject.

    Any help would be appreciated.


    Harry

  2. #2
    4 Star Lounger Jagworld's Avatar
    Join Date
    Jan 2011
    Location
    Florida
    Posts
    467
    Thanks
    79
    Thanked 2 Times in 2 Posts
    No bots, viruses or malware then IMHO it's your email choice web site issue !!

  3. #3
    Gold Lounger Roderunner's Avatar
    Join Date
    Dec 2009
    Location
    Scotland.
    Posts
    3,462
    Thanks
    16
    Thanked 216 Times in 183 Posts
    Hi Harry, if your using FF try this:-

    RR.jpg
    O wad some Power the giftie gie us, to see oursels as ithers see us!

  4. #4
    Star Lounger
    Join Date
    Feb 2012
    Posts
    58
    Thanks
    2
    Thanked 5 Times in 4 Posts
    When I have a website open in my browser, and click on the website's link to send them an E-mail, Agent always opens just fine.
    Email links on web pages operate by means of the MAILTO protocol. Forté Agent is your default program for MAILTO. You can verify this by looking at Default Programs > "Associate a file type or protocol with a program" (scroll to the bottom). Or try this: right-click your Desktop, select New > Shortcut, fill in
    Code:
    mailto:anybody@zzzzzz.com?Subject=Test%20message&Body=What%27s%20up%3F
    click Next, Finish, and then launch the shortcut.

    In most programs -- office software, PDF viewers, etc. -- that offer to email stuff, the email command operates via MAPI (not MAILTO).
    https://en.wikipedia.org/wiki/Messag...ming_Interface
    Some email clients support MAPI, some don't. Some might require tweaking. I am not familiar with Forté Agent. You might try googling for Forté Agent MAPI, or exploiting Forté Agent's support options,... or waiting and hoping that a Forté Agent guru drops by here.
    Last edited by iTobaman; 2013-11-18 at 08:01.

  5. The Following User Says Thank You to iTobaman For This Useful Post:

    zigzag3143 (2013-11-19)

  6. #5
    Star Lounger
    Join Date
    Feb 2012
    Posts
    58
    Thanks
    2
    Thanked 5 Times in 4 Posts
    A few more notes...

    Default Programs > "Set program access and computer defaults": These are global defaults, that is, defaults that apply to all users.

    Default Programs > "Set your default programs": These are defaults for individual users. Individual defaults override global defaults.

    Open "Set your default programs" > Forté Agent. Click "Set this program as default."

    Open "Set your default programs" > Forté Agent > "Choose defaults for this program." You should see the headings Extensions, Protocols, and MAPI. Every checkbox should be checked -- in particular, any MAPI items.

    That is what you can do in Windows. The rest is up to Forté Agent. Probably.

  7. #6
    New Lounger
    Join Date
    Nov 2013
    Posts
    1
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Same problem as Harry

    I use Firefox and Google mail and had the same problem, Harry. Being short on patience, I looked for a work-around and found the software, Affixa that handles the attachments. It's free for light use. Problem solved.

    Ruth

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •