Results 1 to 13 of 13
  1. #1
    New Lounger
    Join Date
    Nov 2013
    Posts
    2
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Excel: Clicking in one cell annoyingly highlights several cells

    In some of my Excel 2010 workbooks (and in some of my wife's), when I click on a cell to enter data or to drag its contents elsewhere, Excel annoyingly highlights several cells, usually cells below the originally selected cell. While holding down on the clicker, if I move the cursor up to above the cell, the multiple highlighting reduces until, maybe 2-3 cells above the target cell, I'm finally highlighting just the one cell. Note that now the cursor is, however, several cells higher. Why is this happening and how do I fix it. (I note that I tried Excel repair from the MS CD, and it fails. I use MS Office Professional 2010.)

  2. #2
    WS Lounge VIP sdckapr's Avatar
    Join Date
    Jul 2002
    Location
    Pittsburgh, Pennsylvania, USA
    Posts
    11,225
    Thanks
    14
    Thanked 342 Times in 335 Posts
    Are the cells merged?
    Steve

  3. #3
    Gold Lounger Maudibe's Avatar
    Join Date
    Aug 2010
    Location
    Pa, USA
    Posts
    2,640
    Thanks
    115
    Thanked 651 Times in 593 Posts
    Just a remote possibility that it may be more of a hardware issue....Make sure that ClickLock (If available) is not enabled for your mouse in control panel>Mouse>buttons tab. Is the problem reproducible if you open the same workbooks on another computer or if you use a different mouse? If laptop, try decreasing the sensitivity of the touch pad. You may be unintentionally dragging while you are clicking.

  4. #4
    5 Star Lounger
    Join Date
    Jan 2004
    Location
    Praha
    Posts
    990
    Thanks
    56
    Thanked 105 Times in 90 Posts
    This issue has been around for some years, and seems to be connected with using the Page Layout view - switch to the normal layout and it goes away.

    Alternatively I've heard that pressing F8 twice (its a toggle key in Excel) make effect a temporary cure if you really need to stay in the Page Layout view..

    HTH
    Last edited by MartinM; 2013-11-24 at 08:01.

  5. The Following 3 Users Say Thank You to MartinM For This Useful Post:

    kthrynileen (2015-05-21),Maudibe (2013-11-23),PaulHBS (2013-11-25)

  6. #5
    Gold Lounger Maudibe's Avatar
    Join Date
    Aug 2010
    Location
    Pa, USA
    Posts
    2,640
    Thanks
    115
    Thanked 651 Times in 593 Posts
    That's good to know, Martin

  7. #6
    5 Star Lounger
    Join Date
    Jan 2004
    Location
    Praha
    Posts
    990
    Thanks
    56
    Thanked 105 Times in 90 Posts
    It was there in Excel 2007 and is still there in 2010 but only happens rarely in specific files. Must be something fundamental or it would have been fixed.

    It isn't a hardware issue, it travels with the file, but I've never found a proper explanation - just workarounds.

    We 2003 stalwarts are immune

  8. The Following User Says Thank You to MartinM For This Useful Post:

    PaulHBS (2013-11-25)

  9. #7
    New Lounger
    Join Date
    Nov 2013
    Posts
    2
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Thank you. I will try this.

    For others that asked questions in order to help:
    1. I do not have ClickLock (which is available) selected for my mouse
    2. I have no merged cells. (An aside: I almost never merge cells, preferring center-across-selection immeasurably.)
    3. I am using a desktop.

  10. #8
    New Lounger
    Join Date
    Oct 2015
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    A Work Around

    I just looked this problem up today - but a work around I found was altering the zoom size in the lower right of the spreadsheet. Making it smaller fixed my issue... However zooming it larger only exacerbated the issue. Also I'm reading F8 temporarily "fixes" the issue.

  11. #9
    3 Star Lounger
    Join Date
    Apr 2001
    Location
    Levin, Manawatu-Wanganui, New Zealand
    Posts
    324
    Thanks
    9
    Thanked 28 Times in 26 Posts

    Extending selection with F8

    Hi
    It sounds to me as if you have (inadvertently) activated "Extend Mode" in excel.
    This is done by pressing "F8". Having done so the selection is extended to the next cell you click on.
    Look that the status bar at bottom left of screen.

    PaulHBS_extend.png

    You turn off "extend Mode" by either
    • pressing F8 again or
    • pressing F9


    F8, right arrow, right arrow will select the current cell and the next two to right.
    F8 is an alternate manner to using shift and arrows or Shift + Click to extend the selection.
    We used to teach these keyboard alternatives because this gave more control when selecting cells close to screen boundaries.

    Hope it helps
    Geof

  12. #10
    WS Lounge VIP
    Join Date
    Mar 2002
    Location
    Newcazzle, UK
    Posts
    2,832
    Thanks
    136
    Thanked 484 Times in 461 Posts
    Hi Geof

    I totally agree with you.

    ..we used to call this the 'ScrollLock' annoyance (when keyboards had a 'ScrollLock' key)

    zeddy

  13. #11
    3 Star Lounger
    Join Date
    Apr 2001
    Location
    Levin, Manawatu-Wanganui, New Zealand
    Posts
    324
    Thanks
    9
    Thanked 28 Times in 26 Posts
    Hi Zeddy

    I was surprised to read that some thought it was associated with layout and pagebreak views. I don't recall that but I cant refute it either.

    As far as I can remember extend mode was there forever.

    Off topic ...
    Something similar in Word with F8 key. Multiple successive presses select current word, sentence, paragraph and document.
    F9 to toggle extend mode off.

    You need to modify the status bar to view the mode.

    Cheers
    Geof

  14. #12
    WS Lounge VIP rory's Avatar
    Join Date
    Dec 2000
    Location
    Burwash, East Sussex, United Kingdom
    Posts
    6,280
    Thanks
    3
    Thanked 191 Times in 177 Posts
    The issue described is a bug that has been reported several times (but is hard to pin down). It is not related to Extended mode, and only seems to occur in Page Layout view.
    Regards,
    Rory

    Microsoft MVP - Excel

  15. The Following 2 Users Say Thank You to rory For This Useful Post:

    geofrichardson (2015-10-05),zeddy (2015-10-07)

  16. #13
    WS Lounge VIP
    Join Date
    Mar 2002
    Location
    Newcazzle, UK
    Posts
    2,832
    Thanks
    136
    Thanked 484 Times in 461 Posts
    Hi rory

    ..I too was unaware of this reported bug

    zeddy

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •