Results 1 to 9 of 9
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    CT
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    How to disable USB 1.1 ports?

    I need some wisdom from heavy duty geeks.
    I run Win XP SP3 on a Soyo Dragon 2 motherboard. The motherboard is spec-ed for 8 USB ports but my PC brings out only 6 ports; 4-USB 2.0 and 2-USB 1.1. I use a program that uses USB but selects the slowest available in the machine, so it runs on the USB 1.1 and the slowness drives me crazy. I have no use for the USB 1.1 ports at all. Is there a way that I can disable those ports so that my program will not see them and hopefully run on the 2.0s. I am including a pic of my device manager in the hope that someone can tell me what and how to disable the dinosaurs.
    Attached Images Attached Images

  2. #2
    Silver Lounger mrjimphelps's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    2,177
    Thanks
    207
    Thanked 213 Times in 205 Posts
    Something you might try: connect something to each 1.1 port (e.g. keyboard and mouse), thereby making them unavailable.

  3. #3
    New Lounger
    Join Date
    Dec 2009
    Location
    CT
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I tried that but the program just hung. I know that it can work with usb 2.0 because I run it on my laptop that has only usb 2.0 ports and it runs at the faster speed. Somehow I have to make the program think that there are no usb 1.1 ports in this computer. Maybe usb infrastructure is more complex that I imagine. Stiil, I would appreciate any ideas from folks who have dealt with such issues.

  4. #4
    Silver Lounger mrjimphelps's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    2,177
    Thanks
    207
    Thanked 213 Times in 205 Posts
    Try this:

    http://www.ehow.com/how_7308525_disa...g-usb-2_0.html

    The idea is that you go into the computer's BIOS and tell it to disable legacy USB 1.1 support.

  5. #5
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    20,613
    Thanks
    2
    Thanked 625 Times in 558 Posts
    Try this. With no devices plugged into the 1.1 USB ports, right click one of the USB root hubs and select Properties, then Power. Note which hubs have no devices. Plug a device into the 1.1 port. Repeat the procedure seeing which hub has a device now. That should be the hub to disable. After you remove the device and disable the hub plug the device into the other 1.1 port just to make sure it is disabled too.

    Joe

  6. The Following 2 Users Say Thank You to JoeP517 For This Useful Post:

    ruirib (2013-12-09),scaisson (2013-12-10)

  7. #6
    Star Lounger burger2227's Avatar
    Join Date
    Feb 2013
    Location
    Pittsburgh
    Posts
    76
    Thanks
    2
    Thanked 1 Time in 1 Post
    Norton, are you going to reply to this or just stand there wiggling your arms around?

    Ralph Cramden

  8. #7
    New Lounger
    Join Date
    Dec 2009
    Location
    CT
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks to mrjimphelps and joep517. I found the enable/disable usb in the BIOS. But the trick of plugging a usb 1.1 device in the ports and checking the power tab in the usb hub properties allowed me to map the hubs to the 1.1 ports. I diabled those drivers and that did it.

  9. #8
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    20,613
    Thanks
    2
    Thanked 625 Times in 558 Posts
    Great!! Glad you got it resolved. Thanks for posting back.

    Joe

  10. #9
    Star Lounger burger2227's Avatar
    Join Date
    Feb 2013
    Location
    Pittsburgh
    Posts
    76
    Thanks
    2
    Thanked 1 Time in 1 Post
    Good to know! Now you should try to contact that program's developers to fix their USB problem. I would.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •