Results 1 to 4 of 4
  1. #1
    New Lounger Ted Myers's Avatar
    Join Date
    Dec 2013
    Location
    South Bend, IN
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Windows 7: delay when keying duplicate characters

    I have just started having a problem when pressing the same key twice. Anytime I press the same key twice (characters, backspace, arrows, etc.) the computer ignores the second keystroke until I pause for 2 or 3 seconds between keystrokes. If the characters are not duplicated, there is no delay. For example, if I try to type "My address" the 2nd "d" and the 2nd "s" are skipped unless I pause between keystrokes. Other than this, I am experiencing no problems. The program being used has no effect on the problem.

  2. #2
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,434
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts
    Ted,

    Welcome to the lounge as a new poster!

    Check out the keyboard settings in the Ease of Access Center -> Make the keyboard Easier to use -> Keyboard settings and adjust the keyboard Repeat delay & Repeat rate.

    repeatrate.JPG

    HTH
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  3. #3
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,631
    Thanks
    161
    Thanked 936 Times in 856 Posts
    Ted, Welcome to the Lounge from me as well. By the way same name, thought I was looking in a mirror or something, LOL.

    I suppose it's also possible that somehow the keyboard drivers have been corrupted. Since this sounds like a recent problem, if the repeat procedure RG mentions does not help, perhaps deleting the keyboard in Device Manger and rebooting to let Windows reinstall the drivers might solve the problem.
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  4. #4
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    4,746
    Thanks
    171
    Thanked 649 Times in 572 Posts
    It's not Repeat delay or rate; that's for a single press of a key.

    Try Filter Keys/Bounce Keys:

    Bounce keys will ignore repeated keystrokes for a specific amount of time

    How to Turn Off FilterKeys

    Bruce
    Last edited by BruceR; 2013-12-05 at 07:39.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •