Results 1 to 13 of 13
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    Brisbane
    Posts
    8
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Windows 8.1 mouse lag

    There has been much joy (well some) that MS have released a patch for mouse lag in certain games.

    I have been having lag issues with a brand new 8.1 computer.

    NO GAMES INVOLVED.

    Using a Microsoft Wireless 800 Keyboard and 1000 Mouse both known to work well on a Win 7 laptop.

    The keyboard stops responding, eventually (2 to 3 seconds) it dumps its buffer to the PC and works OK for a while - then the same again.

    The mouse is fine for a while then starts being harder to move around and inaccurate to click.

    1st fix, I plugged in an old style PS2 plugged keyboard - 100% working.

    2nd fix - tried a Microsoft Explorer Mouse and then an Arc Touch mouse. Same symptoms.

    3rd fix - dug out an ancient wheels mouse optical 1.1a - Mouse now working perfectly.

    To me - and it will take some effort to convince me otherwise - this is some wireless usb problem. The peripheral hardware works with other computers. The 8.1 PC works with hard fired peripherals.

    What other conclusion am I to reach?

    Perhaps Microsoft can fix this before the 2nd hand market in discarded peripherals becomes hot!

  2. #2
    Star Lounger
    Join Date
    Feb 2010
    Posts
    98
    Thanks
    1
    Thanked 0 Times in 0 Posts
    I have the mouse lag problem with Win8.1. When I switched to 8.1, I was using a MS wireless mouse, but the problem is not related to it being wireless. I have subsequently tried 3 optical mice with wires and all behave the same way--lag problem. The MS patch did not solve the problem on my computer.

    The problem does not show up when I am doing clerical operations, such as opening browsers, file browsing, and the other usual things that we do with the mouse. It is only related to games. I only have one game that shows this (a breakout format game), so I simply don't play it on my 8.1 computer. The game runs perfectly under Win7 on my backup computer.

    My present plan is to see if I can get the game to run on XP under Virtualbox. I was surprised at how well XP runs as a virtual machine, but I didn't make the virtual drive large enough, so I have not yet gotten the game installed. I need to find a way to make the virtual drive larger, or a way to install the game from a thumb drive.

  3. #3
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,625
    Thanks
    161
    Thanked 932 Times in 853 Posts
    Are you both sure you have the latest drivers and S/W for the mice? This can cause the problems in question.
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  4. #4
    Star Lounger
    Join Date
    Feb 2010
    Posts
    98
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Medico - I'm not positive that my drivers are correct. I occasionally run Slim Drivers and otherwise trust that when I attach a mouse, Windows will select the proper driver. The mouse I use is a Logitech gaming mouse (400, I think). It starts its own software to assign macros to the buttons, and to allow the user to specify DPI sensitivity levels.

    I will check to see if there is a better driver. I assume Logitech has something that will allow me to find and install the latest driver.

    Thanks for the suggestion. It is strange that each of the mice have behaved identically with respect to lag.

  5. #5
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    20,655
    Thanks
    2
    Thanked 635 Times in 568 Posts
    The drivers included with Windows are often bare bones - just enough to get the device working and seldom the newest. Your best bet is to go to the Logitech site and download the drivers for your device.

    One thing to check is if you've added any new wireless devices or moved a wireless device closer to the PC recently.

    Joe

  6. #6
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,625
    Thanks
    161
    Thanked 932 Times in 853 Posts
    I also went to Logitech to get the latest drivers. As Joe mentions the bare bones drivers might work, but do not always give the full features the manufacturer drivers do. Logitech has the Setpoint software, which allowed my Logitech many more features, including the ability to reassign click clicks to other jobs than the default. I particular like to have a Refresh feature directly on my mouse and Setpoint allowed that.
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  7. #7
    Star Lounger
    Join Date
    Nov 2006
    Posts
    98
    Thanks
    11
    Thanked 2 Times in 2 Posts
    I have that problem when my hard drive has been idle for some time and has spun down. I have the (desktop tower) computer on my (physical) desk and can hear the drive starting up. My problem is made worse because I have my files on a separate internal hard drive.

    I don't know what setting will keep the main and extra hard drives spinning all the time. I'd welcome a solution.

  8. #8
    Silver Lounger mrjimphelps's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    2,185
    Thanks
    209
    Thanked 213 Times in 205 Posts
    Quote Originally Posted by krsmav View Post
    I don't know what setting will keep the main and extra hard drives spinning all the time. I'd welcome a solution.
    If your hard drives are continually spinning, they will wear out a lot quicker.

  9. #9
    Administrator
    Join Date
    Jun 2010
    Location
    Portugal
    Posts
    10,397
    Thanks
    131
    Thanked 1,167 Times in 1,071 Posts
    Quote Originally Posted by krsmav View Post
    I have that problem when my hard drive has been idle for some time and has spun down. I have the (desktop tower) computer on my (physical) desk and can hear the drive starting up. My problem is made worse because I have my files on a separate internal hard drive.

    I don't know what setting will keep the main and extra hard drives spinning all the time. I'd welcome a solution.
    You should consider buying a SSD. SSDs have none of these issues.
    Rui
    -------
    R4

  10. #10
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    20,655
    Thanks
    2
    Thanked 635 Times in 568 Posts
    Quote Originally Posted by krsmav View Post
    I have that problem when my hard drive has been idle for some time and has spun down. I have the (desktop tower) computer on my (physical) desk and can hear the drive starting up. My problem is made worse because I have my files on a separate internal hard drive.

    I don't know what setting will keep the main and extra hard drives spinning all the time. I'd welcome a solution.
    Have you changed the power settings for powering down an HD? Go to Control Panel | System and security | Power Options | Change Plan Settings | Change advanced power settings. Expand "Hard Disk" and then expand "Turn off hard disk after" and change the value.

    Joe

  11. The Following User Says Thank You to JoeP517 For This Useful Post:

    krsmav (2013-12-15)

  12. #11
    Star Lounger
    Join Date
    Nov 2006
    Posts
    98
    Thanks
    11
    Thanked 2 Times in 2 Posts
    JoeP517 -

    Thanks for the guidance. However, when I go to Control Panel | System and security | Power Options | Change Plan Settings | Change advanced power settings, the only options are "Choose when to turn off display" and "Change when the computer sleeps." In particular, there's no "Hard Disk" choice, let alone a "Turn off hard disk after" choice.

    I set the Power Plan to "High Performance" and customized it to max out all the options, but that menu has no option to "Turn off hard disk after" either, and the disks still spin down. How do I get there from here?

  13. #12
    Administrator
    Join Date
    Jun 2010
    Location
    Portugal
    Posts
    10,397
    Thanks
    131
    Thanked 1,167 Times in 1,071 Posts
    Quote Originally Posted by krsmav View Post
    JoeP517 -

    Thanks for the guidance. However, when I go to Control Panel | System and security | Power Options | Change Plan Settings | Change advanced power settings, the only options are "Choose when to turn off display" and "Change when the computer sleeps." In particular, there's no "Hard Disk" choice, let alone a "Turn off hard disk after" choice.

    I set the Power Plan to "High Performance" and customized it to max out all the options, but that menu has no option to "Turn off hard disk after" either, and the disks still spin down. How do I get there from here?
    If you choose Change Advanced Power Settings (highlighted in the picture), you are offered more configurable settings, including an option to specify settings for the hard disk.

    PowerSettings.JPG
    Rui
    -------
    R4

  14. #13
    Super Moderator CLiNT's Avatar
    Join Date
    Dec 2009
    Location
    California & Arizona
    Posts
    5,527
    Thanks
    130
    Thanked 500 Times in 460 Posts
    Check your OS's power settings, specifically for the hard drive...increase the time to power down, or disable it outright.
    You can also go into device manager and ensure the drive is setup for performance as opposed to quick removal.
    DRIVE IMAGING
    Invest a little time and energy in a well thought out BACKUP regimen and you will have minimal down time, and headache.

    Windows 8.1, 64 bit
    Motherboard: DX58SO2*Chipset: X58 Express/Intel ICH10*BIOS: SOX5820J.86A.0888.2012.0129.2203*Processor: Intel Core i7 CPU X 990
    GPU: Nvidia GTX 580*Memory: Corsair 12 GB, 4x3@1600*PSU: Corsair HX1000*Hard drives: REVO X2 160GB*OCZ VERT X3 120GB*5 mechanical storage drives (12 TB) total.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •