Results 1 to 5 of 5
  1. #1
    New Lounger
    Join Date
    Apr 2001
    Posts
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Inconsistent search

    If I search for "Selfcert error" I get 5 results. If I search for "Selfcert" I get 10 results which do not include several of the results from the first search. As I went back to the same search panel which searches All Forums and has Search Options at And, I'm confused.

    Can anyone explain why some of the messages with selfcert are not found by the search?

    Thanks

    Mike

  2. #2
    Plutonium Lounger Leif's Avatar
    Join Date
    Dec 2000
    Location
    U.K.
    Posts
    14,010
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Inconsistent search

    Just tried it here - searching 'All Forums', 'All posts'', 'And'.

    "selfcert error" 7 results

    "selfcert" 18 results - including all the results from the first search - and your post.

    <img src=/S/shrug.gif border=0 alt=shrug width=39 height=15>

  3. #3
    New Lounger
    Join Date
    Apr 2001
    Posts
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Inconsistent search

    Thanks.

    I found the cause of the problem.

    I had left the number of entries per page set at 10 and not noticed that there were more than 10 entries. (Text saying you're viewing messages 1-10 of 15 would help).

    In addition, the messages with "selfcert error" in the subject must have been on the second page.

    Sorry for question.

    Mike

  4. #4
    Bronze Lounger
    Join Date
    Feb 2001
    Location
    England
    Posts
    1,306
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Inconsistent search

    Hi
    No apology needed. Many of us have posted a question, only to find the answer about 5 secs later. The answer is, of course, still useful, as there may be those who do NOT find the answer at all.

    Cheers

  5. #5
    Platinum Lounger
    Join Date
    Feb 2001
    Location
    Yilgarn region of Toronto, Ontario
    Posts
    5,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Inconsistent search

    <pre>Number of results /page 50

    Forum Win98


    search "applog" returns No Matches
    search "applog" returns 8 Matches
    search "applog" returns No Matches

    search "C:windowsapplog" (pasted from message 134411) returns No Matches
    search "C:windowsapplog" (pasted from message 134411) returns No Matches
    </pre>



    At first I thought the trailing slash was the problem - perhaps the code that parses the search string sees the slash, thinks "Ah! here comes a turn-off switch", and then just disappears (because there's no string such as "I" or "serach" to be turned off)

    However my last essay disabused me of that notion.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •