Results 1 to 11 of 11
  1. #1
    New Lounger IveyLeaguer's Avatar
    Join Date
    Dec 2013
    Posts
    5
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Lost File Type Icons in Windows Explorer

    Hello Everyone,

    I keep losing the icons to two file types in Explorer, and only those two, even with a fresh install of Windows 7. It takes a little time, but sooner or later they disappear. It's always Internet Explorer icons first (the associated .mht files) soon followed by the Chrome icons (.htm, .html files). So it's only those two, .mht and .htm.

    For complicated reasons I'd rather not go into, it's important for me and my work to be able to see those file icons in Explorer at any time.

    I should also add the icons DO always appear in the Save/Save As windows, when I'm saving web pages to HD, as I do dozens of times every day (for work).

    File Associations & Icon Cache Rebuilds have been ruled out. Here is what my Explorer window looks like ...

    Windows 7 Explorer Window.jpg

    So, is there any way to restore these two icons in Explorer mode? I'm comfortable doing manual registry changes provided I have clear direction.

    Thanks so much, in advance.
    ~~~

  2. #2
    New Lounger
    Join Date
    Dec 2013
    Posts
    13
    Thanks
    0
    Thanked 6 Times in 4 Posts
    I have just spent some hours fixing icon problems with shortcuts so this may not be useful for you. Googling wrong icon windows 7 gets lots of hits. Some thoughts ...

    1 Delete C:\users\xxxx\appdata\local iconcache.db and reboot. This is the icon cache and it will be rebuilt on reboot. It is a hidden file.

    2 Your file associations may have gone wrong. Control panel > Default programs > Associate a file type with a specific program. Check what is associated with .mht, .htm and .html. Or r-click an .mht file > Open with > Choose default program > Browse ... and make sure you get the correct .exe for the program you want to use to open it. Tick Always use this program for this file type.

    3 You cannot disassociate a program from a file type (say .xyz) but this sneaky trick does it. Create a file fred.txt on the desktop. Rename it fred.exe. Now associate .xyz with fred. It picks up Fred.exe's icon. Now delete fred.exe. You should find that .xyz in not associated with anything (although it may take a while for the display to change).

    4 My problem was caused by making a copy of Notepad.exe and calling it Copy of Notepad.exe. I then set up a shortcut which called Copy of Notepad.exe to open a specific file. I gave the shortcut a unique icon. All sorts of problems then arose - whenever I opened a txt file, it got the unique icon! When I looked in Control panel > Default programs > Associate a file type with a specific program I had two Notepads, but no Copy of Notepad. I eventually deleted Fred and went round in circles for a while before eventually fixing it.

    5 W7 seems to get the icon which appears in the top left corner of tegh open window from somewhere; and the icon which appears in the system tray from somewhere else - I had them different.

  3. The Following 2 Users Say Thank You to John_Ha For This Useful Post:

    IveyLeaguer (2013-12-17),satrow (2013-12-17)

  4. #3
    New Lounger
    Join Date
    Dec 2013
    Posts
    13
    Thanks
    0
    Thanked 6 Times in 4 Posts
    D*mmit! It seems I have the identical problem - incorect icon for .htm and similar files. My icon is the same as yours.

    I have .htm associated with Firefox and it opens in Firefox when I click it. It seems to be related to Firefox because when I associate .htm with IE or another program, it gets the correct icon.

    But I then associated it with Notepad and it is now stuck with Notepad and I cannot change it back. r-click > properties > security and all the permissions are greyed out and cannot be changed. Also, whereas I used to have an "Opens with" and Change button on Properties, these have both disappeared.

    I need to look at it further ...

  5. #4
    New Lounger IveyLeaguer's Avatar
    Join Date
    Dec 2013
    Posts
    5
    Thanks
    5
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by John_Ha View Post
    I have just spent some hours fixing icon problems with shortcuts so this may not be useful for you. Googling wrong icon windows 7 gets lots of hits. Some thoughts ...
    1 Delete C:\users\xxxx\appdata\local iconcache.db and reboot. This is the icon cache and it will be rebuilt on reboot. It is a hidden file.
    2 Your file associations may have gone wrong. Control panel > Default programs > Associate a file type with a specific program. Check what is associated with .mht, .htm and .html. Or r-click an .mht file > Open with > Choose default program > Browse ... and make sure you get the correct .exe for the program you want to use to open it. Tick Always use this program for this file type.
    3 You cannot disassociate a program from a file type (say .xyz) but this sneaky trick does it. Create a file fred.txt on the desktop. Rename it fred.exe. Now associate .xyz with fred. It picks up Fred.exe's icon. Now delete fred.exe. You should find that .xyz in not associated with anything (although it may take a while for the display to change).
    4 My problem was caused by making a copy of Notepad.exe and calling it Copy of Notepad.exe. I then set up a shortcut which called Copy of Notepad.exe to open a specific file. I gave the shortcut a unique icon. All sorts of problems then arose - whenever I opened a txt file, it got the unique icon! When I looked in Control panel > Default programs > Associate a file type with a specific program I had two Notepads, but no Copy of Notepad. I eventually deleted Fred and went round in circles for a while before eventually fixing it.
    5 W7 seems to get the icon which appears in the top left corner of tegh open window from somewhere; and the icon which appears in the system tray from somewhere else - I had them different.
    Thanks, John. Appreciate it. Yeah, I tried those, and nothing worked.

    I suspect it's some kind of shortcut problem, or something in the registry, but of course I don't know that for sure.
    ~~~

  6. #5
    New Lounger IveyLeaguer's Avatar
    Join Date
    Dec 2013
    Posts
    5
    Thanks
    5
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by John_Ha View Post
    D*mmit! It seems I have the identical problem - incorect icon for .htm and similar files. My icon is the same as yours.

    I have .htm associated with Firefox and it opens in Firefox when I click it. It seems to be related to Firefox because when I associate .htm with IE or another program, it gets the correct icon.

    But I then associated it with Notepad and it is now stuck with Notepad and I cannot change it back. r-click > properties > security and all the permissions are greyed out and cannot be changed. Also, whereas I used to have an "Opens with" and Change button on Properties, these have both disappeared.

    I need to look at it further ...
    I think it's interesting that the problem only involves files that are saved web pages.

  7. #6
    New Lounger
    Join Date
    Dec 2013
    Posts
    13
    Thanks
    0
    Thanked 6 Times in 4 Posts
    It seems to be a Firefox problem for me. This Firefox post "Firefox icon won't appear on html files" discusses it in detail but I haven't had time to try it out

    http://forums.mozillazine.org/viewto...t&sd=a&start=0

    ... and every time I opened it in IE, the next time I ran FF it said FF wasn't the default browser. And when FF wasn't (or was) the default, I could change the program as I had the Change Program button.

    Bizarre (but then nothing surprises me with Windows...)
    Last edited by John_Ha; 2013-12-17 at 14:12.

  8. The Following User Says Thank You to John_Ha For This Useful Post:

    IveyLeaguer (2013-12-17)

  9. #7
    New Lounger IveyLeaguer's Avatar
    Join Date
    Dec 2013
    Posts
    5
    Thanks
    5
    Thanked 0 Times in 0 Posts
    I just changed the .htm association for Firefox, with the same result .. Firefox opens the file, etc., but the icon doesn't show in Explorer.

    So with me, it's the files that open with the browsers, in my case - IE, Firefox, and Chrome. All other icons appear just fine as they should. It's only the icons of saved web pages (which I have thousands) that won't show in Explorer.

    And as I said in the OP, it's interesting that when I'm in the process of saving a webpage, all the icons (from both .mht and .htm (.html) file types and associated browsers that open them) show in the "Save As" Explorer window, just like they're supposed to. It's only when I go to Explorer, in normal Explorer mode, to browse my files that the icons don't show.

    Somehow, the connection there is broken.
    ~~~
    Last edited by IveyLeaguer; 2013-12-17 at 14:25.

  10. #8
    New Lounger
    Join Date
    Dec 2013
    Posts
    13
    Thanks
    0
    Thanked 6 Times in 4 Posts
    This fixed it for me (from http://windowssecrets.com/forums/sho...ndows-Explorer)

    I found a fix for the problem. Something (possibly one of the recent installs) had added an Icon Handler for Firefox. In the registry I found registry key HKEY_CLASSES_ROOT\FirefoxHTML\ShellEx\IconHandler was set to {42042206-2D85-11D3-8CFF-005004838597}. I also found registry key HKEY_CURRENT_USER\Software\Classes\FirefoxHTML\Def aultIcon was set to %1.

    In fact, my HKEY_CURRENT_USER\Software\Classes\FirefoxHTML\Def aultIcon was set to C:\Program Files (x86)\Mozilla Firefox\firefox.exe,1

    Here is what I did to fix the problem:

    1. I deleted registry key HKEY_CLASSES_ROOT\FirefoxHTML\ShellEx\IconHandler (I completely deleted the key, not just set it to no value).

    I deleted it

    2. I set registry key HKEY_CURRENT_USER\Software\Classes\FirefoxHTML\Def aultIcon to C:\Program Files (x86)\Mozilla Firefox\firefox.exe,1

    Mine was already set to that.

    3. I changed the file association from Firefox to Internet Explorer and then from Internet Explorer back to Firefox.

    Now all is functioning properly.

    Mine too!

    Whether it survives a reboot is another question ...

  11. The Following 2 Users Say Thank You to John_Ha For This Useful Post:

    IveyLeaguer (2013-12-18)

  12. #9
    New Lounger
    Join Date
    Dec 2013
    Posts
    13
    Thanks
    0
    Thanked 6 Times in 4 Posts
    Quote Originally Posted by IveyLeaguer View Post
    It's only the icons of saved web pages (which I have thousands) that won't show in Explorer.

    And as I said in the OP, it's interesting that when I'm in the process of saving a webpage, all the icons (from both .mht and .htm (.html) file types and associated browsers that open them) show in the "Save As" Explorer window, just like they're supposed to. It's only when I go to Explorer, in normal Explorer mode, to browse my files that the icons don't show.

    Somehow, the connection there is broken.
    ~~~
    After the fix above, everything is OK for me. htm and html files show the FF icon on the desktop and in Windows Explorer listings. When I save a file, Save As shows the FF icons on htm and html files.

  13. #10
    New Lounger
    Join Date
    Dec 2013
    Posts
    13
    Thanks
    0
    Thanked 6 Times in 4 Posts
    ... and at some time, I gave Firefox all its defaults ... Control Panel > Default Programs > Set Default Programs > choose FF > Choose defaults for this program > select all. I also set FF to default on the previous step.

  14. The Following User Says Thank You to John_Ha For This Useful Post:

    IveyLeaguer (2013-12-18)

  15. #11
    New Lounger IveyLeaguer's Avatar
    Join Date
    Dec 2013
    Posts
    5
    Thanks
    5
    Thanked 0 Times in 0 Posts
    It worked!!! The above fix worked for me, using the Chrome key instead of Firefox .. changing the 0 to 1. Didn't have to do anything to the second key (HKEY CURRENT USER) for Chrome.

    There was no similar sequence for Internet Explorer. But I fooled around in both trees with the .mht values, and suddenly it worked. Sorry I can't recall the exact fix, as I tried a number of them, just fishing. But I suspect that changing the .mht file association to Firefox and back to Internet Explorer may have done it alone, since the first time I did that, it worked.

    All survived the reboot as well.

    So thanks, John_Ha. You the man!!

    Here's a picture of the handiwork.......

    Windows 7 Explorer Window (fixed).jpg
    ~~~
    Last edited by IveyLeaguer; 2013-12-18 at 00:25.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •