Results 1 to 3 of 3
  1. #1
    New Lounger
    Join Date
    Dec 2013
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Unhappy New Dell XPS27 touch screen failure

    I have recently bought an XPS27 from the Microsoft Store. It is a Dell all in one and it worked great after I received it (running windows 8.0). After a couple of days and some windows updates the touch screen stopped working. I followed some of the blogs and found one that said update to windows 8.1 and it will fix the problem. I did the update and sure enough it began working again. However after a week and some more updates (I now have shut off the updates based on the Windows 8.1 for dummies advice) it has stopped again. Anyone experience the same thing or have an opinion on whether it is Windows of Dell? I would appreciate any help
    Thanks

  2. Subscribe to our Windows Secrets Newsletter - It's Free!

    Get our unique weekly Newsletter with tips and techniques, how to's and critical updates on Windows 7, Windows 8, Windows XP, Firefox, Internet Explorer, Google, etc. Join our 480,000 subscribers!

    Excel 2013: The Missing Manual

    + Get this BONUS — free!

    Get the most of Excel! Learn about new features, basics of creating a new spreadsheet and using the infamous Ribbon in the first chapter of Excel 2013: The Missing Manual - Subscribe and download Chapter 1 for free!

  3. #2
    Super Moderator jwitalka's Avatar
    Join Date
    Dec 2009
    Location
    Minnesota
    Posts
    4,613
    Thanks
    66
    Thanked 525 Times in 474 Posts
    If its still under warranty, call Dell support.

    Jerry

  4. #3
    New Lounger
    Join Date
    Feb 2012
    Location
    Fort Wayne
    Posts
    4
    Thanks
    3
    Thanked 0 Times in 0 Posts
    I had the same problems with HP and DELL touch screens. After a windows update, that appeared 1/1/2014, the HP screen started working.
    I have reinstalled the DELL drivers and rechecked the system. Still no joy. I will wait a day or two and see if a similar update appears for my DELL. I am running Win 8.1 on both systems.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •