Results 1 to 10 of 10
  1. #1
    Lounger
    Join Date
    Sep 2013
    Posts
    25
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Windows 8 Security certificates error

    Already spent hours trying to research and figure this out, but no luck.

    New PC with Windows 8.

    First I was getting security certificate errors with Outlook 2007. Finally corrected that by turning off "Scan Outgoing Mail" in my Avast antivirus.

    But keep getting them on a number of websites with IE10.
    Have tried resetting IE 10 under tools, options
    Checked PC date and Time
    Tried adding as a trusted website the websites with problems.
    Search goggle. Others have the problem but I could not find any solutions.
    Also tried turning off Avast. Running Malwarebytes and Super AntiSpyware.
    With the same websites the popups will only appear 75% of the time. So not always with the same regular websites I go to.
    Also no popups with Chrome but would like to stick with IE.

    Thanks for any suggestions
    Last edited by Rayh78; 2014-01-03 at 22:33.

  2. Subscribe to our Windows Secrets Newsletter - It's Free!

    Get our unique weekly Newsletter with tips and techniques, how to's and critical updates on Windows 7, Windows 8, Windows XP, Firefox, Internet Explorer, Google, etc. Join our 480,000 subscribers!

    Excel 2013: The Missing Manual

    + Get this BONUS — free!

    Get the most of Excel! Learn about new features, basics of creating a new spreadsheet and using the infamous Ribbon in the first chapter of Excel 2013: The Missing Manual - Subscribe and download Chapter 1 for free!

  3. #2
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,625
    Thanks
    161
    Thanked 928 Times in 851 Posts
    Be careful, Avast is a true AV app, MalwareBytes is not. MalwareBytes is a great add-on to work with your AV app. I might try a different AV app. You say you turned off Avast. If so, WD would not be re-enabled unless you uninstall Avast. When Avast, or any other AV app is installed the default WD is disabled automatically.

    I use AVG AV 2013 and see none of these security certificate problems.

    I do use IE, in my case IE 11 with Win 8.1.
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  4. #3
    Administrator
    Join Date
    Jun 2010
    Location
    Portugal
    Posts
    10,171
    Thanks
    129
    Thanked 1,138 Times in 1,049 Posts
    I think the first thing that needs to be established is whether the certificates issue exists or not. This can be done in several ways. I would start by downloading a different browser and see if the problem shows up in such browsers as well. If it does not, then you will have restricted your problem source to IE or something related to IE.

    I would suggest you try Chrome or Firefox with the problem sites and see how they fare regarding certificates.
    Rui
    -------
    R4

  5. #4
    Lounger
    Join Date
    Sep 2013
    Posts
    25
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Did try Chrome and NOT having the problem. But would still like to use and fix IE

    Thanks

  6. #5
    Administrator
    Join Date
    Jun 2010
    Location
    Portugal
    Posts
    10,171
    Thanks
    129
    Thanked 1,138 Times in 1,049 Posts
    Can you state the error messages you get?
    Rui
    -------
    R4

  7. #6
    Lounger
    Join Date
    Sep 2013
    Posts
    25
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by ruirib View Post
    Can you state the error messages you get?
    internet explorer blocked this website from displaying content with security certificate error"
    then show content or cancel

  8. #7
    Administrator
    Join Date
    Jun 2010
    Location
    Portugal
    Posts
    10,171
    Thanks
    129
    Thanked 1,138 Times in 1,049 Posts
    Are you up to date with Windows updates, especially those regarding IE?

    Does running IE with no addons help?
    Rui
    -------
    R4

  9. #8
    Lounger
    Join Date
    Sep 2013
    Posts
    25
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Yes had already did updates for Win 8 and MS Office, also tried disable add ons.

    Also don't think its connected to my problem. But a lot of time do have to hit the back button a few time in order for it to work in IE.

  10. #9
    New Lounger
    Join Date
    Oct 2012
    Posts
    7
    Thanks
    0
    Thanked 2 Times in 2 Posts
    After you click "Continue to Website (not recommended)" in internet explorer, you should see a red shield with an "x" if you click on that, it should tell you what the error of the certificate is. I have attached a sample image of what the error window should look like. Can you open the error message and let us know what it states, or attach a screen shot of the error message?

    certerror.png

  11. #10
    Lounger
    Join Date
    Sep 2013
    Posts
    25
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by douri View Post
    After you click "Continue to Website (not recommended)" in internet explorer, you should see a red shield with an "x" if you click on that, it should tell you what the error of the certificate is. I have attached a sample image of what the error window should look like. Can you open the error message and let us know what it states, or attach a screen shot of the error message?

    certerror.png
    Sorry took me a while to respond. But this is windows 8 and the option to click just saids show content. Then no other box or option appears. Just click show content or X out.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •