Page 1 of 3 123 LastLast
Results 1 to 15 of 37
  1. #1
    2 Star Lounger
    Join Date
    Dec 2003
    Location
    Bothell, Washington, USA
    Posts
    106
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Some sort of IE debugger keeps popping up

    For the past week or so when I am using IE 11, I get a popup window stating that the web page has some sort of script execution error in it and do I want to debug it. The popup window has yes and no response buttons as well as a check box to specify that I don't want the message again.

    This popup keep occurring multiple time a day. I always click the check box that specifies I don't want it to appear again which does silence it for a time but it keeps returning. Also note that the error that was encountered is shown in a window and it seems to be a different error each time.

    I have never seen this popup window before and I am not even sure it comes from windows. So while I don't know what is causing this but I suspect it may be a vendor's way to advertise their product. The popup window doesn't have any logos or other identifying items and it doesn't look like most Windows 7 popups or windows which leads me to believe that perhaps a vendor has installed something that is causing this to occur.

    I have run a full system antivirus scan with Kaspersky and found nothing. I have also looked at Add-Ins in IE but didn't see anything that I recognized as relevant.

    Another, perhaps related, issue is that also for the past week, I keep getting Kaspersky antivirus popups repeatedly throughout the day (something like 100 or so each day). Each and every time, so far, this popup says it found a virus or Trojan horse or some sort of offending virus and it disabled it. Since I did a full system virus scan and yet these popups keep occurring, I am guessing that there is some sort of kernel or virus that is either invisible to the Kaspersky scan or keeps getting re-infected somehow. The Windows component that the Kaspersky popup shows as being attacked seems to be the same one each time. The popup appears and disappears so quickly that I haven't been able to copy that detail yet. My Kaspersky software is up to date.

    I don't know with certainty that the Kaspersky virus advisory popup is related to the IE debug popup but I am suspicious because they both started happening about the same time. I am planning to contact Kaspersky for help but have not done so yet.

    Anyone have any ideas on how to solve at least the IE script debug problem? Screen shots of three of the debug popup windows are attached.

    Specs
    Windows 7-Pro, 64-bit, version 6.1 (Build 7601: Service Pack 1)
    IE 11 - 11.0.9600.16476, Update version 11.0.2
    Attached Images Attached Images

  2. #2
    4 Star Lounger SpywareDr's Avatar
    Join Date
    Dec 2009
    Location
    Miami, Florida, USA
    Posts
    415
    Thanks
    4
    Thanked 44 Times in 35 Posts
    In Internet Explorer, click Tools > Internet Options > Advanced tab, scroll down to the Browsing section and select(/check) these two boxes:

    • Disable script debugging (Internet Explorer)
    • Disable script debugging (other)



    then click Apply > OK.

  3. #3
    2 Star Lounger
    Join Date
    Dec 2003
    Location
    Bothell, Washington, USA
    Posts
    106
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Thanks for your suggestion. I looked at my IE settings and found that the script debugging for IE was already checked, i.e. already disabled. The other wasn't so I checked it. I don't know what this "Other" script debugging is for or what it controls. But I will wait and see if that solves the problem.

  4. #4
    4 Star Lounger SpywareDr's Avatar
    Join Date
    Dec 2009
    Location
    Miami, Florida, USA
    Posts
    415
    Thanks
    4
    Thanked 44 Times in 35 Posts
    Got my fingers crossed you.

  5. #5
    2 Star Lounger
    Join Date
    Dec 2003
    Location
    Bothell, Washington, USA
    Posts
    106
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Okay, new information.
    I looked at the IE advanced options and found that the entry "Disable Script debugging (Internet Explorer) was already checked but the entry "Disable Script debugging (other) was not checked. So I checked the other (as I stated in an earlier post) and at first I thought I had the problem solved. But it returned after a while.
    So I checked the "Other" entry again and, sure enough, eventually the popup debugger came back after a short while.
    So then I thought, I am changing this field in IE when I have it open. So I closed IE completely, went into control panel/Internet Options and found the same tab and entries. Once there I saw that the two entries were as before, IE checked, "Other" not checked. So I checked the Other and closed the window. Thought I had it, but no, after a while the debugging popup came back and after looking, I found the "Other" entry in Advanced options had unchecked itself once again.
    I am not even sure what these two entries mean, but I am guessing that the "Internet Explorer" entry means disable the IE debugging application or tool and the "Other" entry means disable any other script debugger (though which one its referring to is unknown to me). So assuming for the moment those meanings are correct, my guess is that the "Other" debugger is some vendor tool that got installed and is smart enough to keep unchecking the advanced options entry. I do also have Firefox installed and presumably any debugger it used would fall in the "Other" category but I don't use it as often and furthermore, the popup debugger happens when I am running IE only and Firefox isn't even running.

    As I stated in an earlier post, I have run Kaspersky antivirus and it found nothing and I also looked at Add-ins in IE but didn't see anything unusual.

    I also just looked at Programs in Control panel. I sorted by installation date hoping to find a program that had been installed about the time this started happening. Didn't see anything that stood out as the culprit.


    So my questions now are

    1) Is my understanding of these two Advanced Options entries correct?
    2) If my understanding is correct doesn't my experience imply that some debugger is getting invoked and it also keeps unchecking the entry?
    3) Suggestions on how to solve this problem.
    Last edited by dglarson; 2014-10-28 at 19:07.

  6. #6
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    2,918
    Thanks
    91
    Thanked 357 Times in 321 Posts
    This 10-year-old Microsoft page says Other means other MS programs like Outlook:


    Script debugging is turned off by default you can enable it by going to:
    Tools->Internet Options…->Advanced->Disable Script Debugging

    Prior to XPSP2 the above will turn script debugging on for all applications that host the WebBrowser control (Outlook for example).

    On XPSP2 we’ve split the option into two:
    Tools->Internet Options…->Advanced->Disable Script Debugging (Internet Explorer)
    Tools->Internet Options…->Advanced->Disable Script Debugging (Other)


    Scripting Debugging in Internet Explorer


    What about the next checkbox: Display a notification for every script error?


    Bruce

  7. #7
    Silver Lounger
    Join Date
    Aug 2012
    Location
    UK
    Posts
    2,262
    Thanks
    37
    Thanked 304 Times in 295 Posts
    Did you click on Apply - OK ?

  8. #8
    4 Star Lounger SpywareDr's Avatar
    Join Date
    Dec 2009
    Location
    Miami, Florida, USA
    Posts
    415
    Thanks
    4
    Thanked 44 Times in 35 Posts
    Try resetting IE back to its original defaults. In IE, click Tools > Internet Options > Advanced tab > Reset... button. Select "Delete personal settings", click the Reset button, then restart IE and test.

  9. #9
    4 Star Lounger RolandJS's Avatar
    Join Date
    Dec 2009
    Location
    Austin metro area TX USA
    Posts
    514
    Thanks
    42
    Thanked 31 Times in 30 Posts
    Quote Originally Posted by Sudo15 View Post
    Did you click on Apply - OK ?
    Ahh, yes, I have forgotten to press the Apply, then the Ok buttons before on other things! Might have happened with our nice OP?

  10. #10
    2 Star Lounger
    Join Date
    Dec 2003
    Location
    Bothell, Washington, USA
    Posts
    106
    Thanks
    3
    Thanked 0 Times in 0 Posts
    More new information.

    1) Yes, I have clicked on Apply then OK in all my workings with this problem.
    2) There is something very strange going on with this debugging pop-up. The two Browsing options that SpywareDr mentions above, keep getting unchecked by something. Every time the debugging window pops up I look at these two options. Most often the 2nd option is unchecked but sometimes both are unchecked. So something is unchecking these two options and doing it repeatedly.
    3) At first I had doubts that the debugging pop-up window that keeps appearing was even from IE or Microsoft. I was suspecting an Add-In that was installed without my knowledge was triggering it. But I have now determined that this pop-up window does indeed come from Microsoft and more specifically from "F12 Developer Tools" that was implemented in IE11. I am attempting to learn more about F12 to see if I can disable it or at least disable some part of it to prevent this pop-up window from appearing. I am not interested in debugging the dozens of web pages that apparently have scripts errors and thus cause this pop-up window to appear. Its a sad state of affairs that so many web pages in production have some sort of script error, but alas that is the world we live in.
    But more germane to the point, how do I stop this pop-up from appearing? The two "Disable script debugging..." options discussed above are not preventing it. Or perhaps more precisely, one or both of these two options are getting unchecked and thus allowing the debug pop-up window to appear. Some software code somewhere is unchecking these options. Why is that and how do I stop that from happening?

    If you know anything about how to disable or modify F12 Developer tools, please reply.

  11. #11
    4 Star Lounger SpywareDr's Avatar
    Join Date
    Dec 2009
    Location
    Miami, Florida, USA
    Posts
    415
    Thanks
    4
    Thanked 44 Times in 35 Posts
    The "F12 Developer Tools" is not causing any pop-ups, or changing IE's "Disable script debugging..." options here, on several different machines.

  12. #12
    Administrator
    Join Date
    Jun 2010
    Location
    Portugal
    Posts
    10,410
    Thanks
    131
    Thanked 1,167 Times in 1,071 Posts
    Quote Originally Posted by dglarson View Post
    If you know anything about how to disable or modify F12 Developer tools, please reply.
    The developer tools have been available in many previous IE versions (I would risk saying in all versions I can remember) and they don't cause such behavior.

    You may want to restore IE to its default settings and see if that helps with your problem.
    Rui
    -------
    R4

  13. #13
    4 Star Lounger SpywareDr's Avatar
    Join Date
    Dec 2009
    Location
    Miami, Florida, USA
    Posts
    415
    Thanks
    4
    Thanked 44 Times in 35 Posts
    To do so, in IE click Tools > Internet Options > Advanced tab > Reset... button. Select "Delete personal settings", click the Reset button, then restart IE.

  14. #14
    2 Star Lounger
    Join Date
    Dec 2003
    Location
    Bothell, Washington, USA
    Posts
    106
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Clarification - I didn't mean to imply that F12 is causing the pop-up window nor that it was unchecking the script disable option. The pop-up I have been getting repeatedly (20 to 30 times per day) IS F12 Developer tools. I know this because when the pop-up appears, if I check YES to debug, it displays a larger more detailed window that says "F12 Developer Tools" at the top. Nor do I necessarily think that F12 is unchecking the script options. But something is unchecking the script debugging options and once enabled, any script error IE11 encounters invokes F12 Developer tools and its window pops up.
    Here is the sequence of events as I see it.
    1) Some software application, subroutine or applet is unchecking one or sometimes both of the "disable script debugger" option(s) in IE. Just what applet is doing this I have absolutely no idea. Nor do I know why or under what conditions this unchecking occurs.
    2) As I browse the internet with IE, it encounters a script error on some of the pages (actually on many pages). Since "Script" debugging is now enabled, the F12 developer application is started and it displays the pop-up.
    3) When I click No to debugging in the F12 pop-up and then go into IE options to disable the script debuggers, IE runs without starting the F12 pop-up for a while (like around 5 to 10 minutes maybe). Then the options get unchecked by the unknown applet and it starts all over again.
    4) I mentioned that F12 Developer Tools was implemented in IE11 because I read a Microsoft web page that said that. After going back and rereading it here (http://msdn.microsoft.com/en-us/libr...v=vs.85).aspx) I see that it really said F12 had gone through a major reworking and revision in IE11.

    So aside from all of this I will try restoring IE defaults as SpywareDr and ruirib have suggested.
    I'll post again later with the results.
    Last edited by dglarson; 2014-11-23 at 23:53.

  15. #15
    Silver Lounger
    Join Date
    Aug 2012
    Location
    UK
    Posts
    2,262
    Thanks
    37
    Thanked 304 Times in 295 Posts
    You could try disabling F12 Developer Tools as elimination and then see if the boxes are still being unchecked to look elsewhere.

    http://www.sevenforums.com/tutorials...e-disable.html

    If it is a 3rd party program that is responsible, then checking to see if the same occurs in Safe Mode with Networking and a clean boot could help to identify the culprit.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •