Results 1 to 7 of 7
  1. #1
    Star Lounger
    Join Date
    Jul 2012
    Posts
    58
    Thanks
    10
    Thanked 0 Times in 0 Posts

    Why does Hotmail take so long to be usable?

    Hi,

    I seem to be the only person annoyed by this, but here goes:

    When I log into Gmail, it's ready to open messages straight away. But with Hotmail, in the browser tab, a little circle spins about 5 times in the first minute and says "connecting". And in that time you can't open a message properly. What is it connecting to? Can those connections be stopped? Why aren't other people annoyed by this? Am I missing something?

    TIA.

  2. Get our unique weekly Newsletter with tips and techniques, how to's and critical updates on Windows 7, Windows 8, Windows XP, Firefox, Internet Explorer, Google, etc. Join our 480,000 subscribers!

    Excel 2013: The Missing Manual

    + Get this BONUS — free!

    Get the most of Excel! Learn about new features, basics of creating a new spreadsheet and using the infamous Ribbon in the first chapter of Excel 2013: The Missing Manual - Subscribe and download Chapter 1 for free!

  3. #2
    3 Star Lounger bassfisher6522's Avatar
    Join Date
    Jul 2013
    Location
    NC
    Posts
    301
    Thanks
    41
    Thanked 32 Times in 31 Posts
    What are you referring to with "Hotmail"? What email client are you using to view, I assume your hotmail account?

  4. #3
    Star Lounger
    Join Date
    Jul 2012
    Posts
    58
    Thanks
    10
    Thanked 0 Times in 0 Posts
    I open Mozilla Firefox and type hotmail.com and it comes up outlook - xxxxx@hotmail.com. But the email address is replaced by "connecting" every few seconds for 30-60 seconds. I can see my emails, but when I click on them they don't open, or if they do it returns back to the inbox after it does another "connecting". After 60 seconds I can access everything like normal. It just seems silly to be waiting for a minute when all other webmail companies are instant.

  5. #4
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    2,828
    Thanks
    19
    Thanked 109 Times in 103 Posts
    Could it be Microsoft subtly suggesting that it was about time you moved to an outlook.com email address rather than the now-deprecated hotmail.com?! (Just a thought... )
    BATcher

    Dear Diary, today the Hundred Years War started ...

  6. #5
    3 Star Lounger bassfisher6522's Avatar
    Join Date
    Jul 2013
    Location
    NC
    Posts
    301
    Thanks
    41
    Thanked 32 Times in 31 Posts
    I have an old live.com email account and it works perfectly using MS new Outlook.com web service. BATcher may be on to something with the "MS subtle suggestion" to move to the new email. That's just an educated guess.

    Everything I've read so far indicates that service is/has moved to the new Outlook format but you can keep your old hotmail email. But nothing to explain the issue your having.

    http://www.geekwire.com/2012/farewel...bmail-service/

  7. #6
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    20,543
    Thanks
    1
    Thanked 614 Times in 550 Posts
    I have more than one old Hotmail.com address and do not have any problems with them.
    Do you have the latest version of Firefox?
    Have you tried clearing the Firefox cache?
    Have you tried a different browser?

    Joe

  8. #7
    New Lounger
    Join Date
    Aug 2014
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Me too!

    I'm in the same boat as the OP and I finally got frustrated enough by it to go searching for answers (or at least commiseration). I think my issue is slightly different in that after the initial minute where it starts working smoothly for you, in my case it's quite temperamental. I'll click on a message in the inbox, opens no problem. I click on "junk" it might open no problem or it might spin and wait for a minute. Once there, if I click to go back to the inbox, same thing. Is it gonna be an immediate transaction or do I have to wait a minute (or more sometimes) just to load the inbox. And I have a gmail too, this is just for all my "accounts" and a few holdover business contacts that I don't want to have my personal email address, but it's so mind-numbing to operate sometimes (well, more often than not actually) and I just can't figure out why. I've tried all the basics, clearing the cache, trying in a different browser, trying on a different computer, cursing, throwing things (strangely never seems to solve the problem), etc. I take it, OP, you haven't found any solution? If so, I'd love to hear about it. If not, I can only offer you the uplifting feeling that comes with knowing that someone else is suffer the exact same pain as you are....

    - Neil

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •