Results 1 to 5 of 5
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    Boston, massachusetts
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Pages opened in Chrome freeze

    I use Chrome exclusively. One day last week it suddenly died and the shortcuts wouldn't open it again. I searched my computer and the program was no longer there. It seems to have just disappeared.

    Using IE, I downloaded it again and reinstalled it and it's running, but now I have two problems:
    First, it came back at an earlier restore point and all of the favorites and shortcuts and extensions that I had added in the last few months were missing. That's a time consuming loss, but I can get by.
    The second (and more serious) problem is that now it will call up a page and the page will freeze. It will attempt to install for a few seconds (with the little circle spinning) and then the "Aw Snap, She's dead, Jim" pop up comes on.
    None of this happens with IE.

    Any clues, tid bits, advice? I can limp along with IE, but the thought of rebuilding everything from scratch in another browser is daunting.
    Last edited by standuncan; 2014-01-21 at 05:44. Reason: Earlier version was not written well

  2. Subscribe to our Windows Secrets Newsletter - It's Free!

    Get our unique weekly Newsletter with tips and techniques, how to's and critical updates on Windows 7, Windows 8, Windows XP, Firefox, Internet Explorer, Google, etc. Join our 480,000 subscribers!

    Excel 2013: The Missing Manual

    + Get this BONUS — free!

    Get the most of Excel! Learn about new features, basics of creating a new spreadsheet and using the infamous Ribbon in the first chapter of Excel 2013: The Missing Manual - Subscribe and download Chapter 1 for free!

  3. #2
    3 Star Lounger bassfisher6522's Avatar
    Join Date
    Jul 2013
    Location
    NC
    Posts
    242
    Thanks
    38
    Thanked 26 Times in 25 Posts
    I've been noticing some of the same symptoms you're describing as of late. Until I can figure out what it is, why it's happening...I've moved to a different browser...FireFox and completely removed Chrome. This is not just an isolated incident on one system, I've seen this on both my systems....desktop and laptop.

  4. #3
    New Lounger
    Join Date
    Dec 2009
    Location
    Boston, massachusetts
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I wonder if others are having the same problem and are asking about it on other forums. Like you, in the short run, have moved on to another browser. In my case I'm trying out IE, but so far I don't care for it. If you try something that works tell me about it.

  5. #4
    Administrator
    Join Date
    Jun 2010
    Location
    Portugal
    Posts
    9,915
    Thanks
    126
    Thanked 1,098 Times in 1,010 Posts
    There have been some complaints about recent updates to Chrome, but I haven't seen this issue specifically addressed. Maybe next version will improve on this specific issue.
    Rui
    -------
    R4

  6. #5
    3 Star Lounger bassfisher6522's Avatar
    Join Date
    Jul 2013
    Location
    NC
    Posts
    242
    Thanks
    38
    Thanked 26 Times in 25 Posts
    Quote Originally Posted by standuncan View Post
    I wonder if others are having the same problem and are asking about it on other forums. Like you, in the short run, have moved on to another browser. In my case I'm trying out IE, but so far I don't care for it. If you try something that works tell me about it.
    I use FF as a backup to Chrome....I've also just recently started experimenting with Opera....TBH, it's not bad, not bad at all. A cool feature is the configurable home page tiles.

    http://www.opera.com/

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •