Results 1 to 6 of 6
  1. #1
    3 Star Lounger JC Zorkoff's Avatar
    Join Date
    Dec 2009
    Location
    Boston, Massachusetts, USA
    Posts
    226
    Thanks
    21
    Thanked 45 Times in 40 Posts

    Context menus expand to left - Win 8.1

    In all Windows versions before Win 8.1, when right clicking a file in windows explorer to get the context menu, the sub-menus always expanded to the right.

    In this screen shot you can see how the "Send To" sub menu expands to the left.

    Explorer-Context-Expand.jpg

    Does anyone know of a way to put this back to normal expansion to the right?

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,593
    Thanks
    5
    Thanked 1,059 Times in 928 Posts
    The only way this happens to me is if I'm too close to the right side of the display.

    Does this happen on all the context menus?
    What happens if you move File Explorer to the left?

    Joe

  3. #3
    3 Star Lounger JC Zorkoff's Avatar
    Join Date
    Dec 2009
    Location
    Boston, Massachusetts, USA
    Posts
    226
    Thanks
    21
    Thanked 45 Times in 40 Posts
    Joe, this happens with explorer in the center of the screen. If I move explorer left so it is almost touching the left side, the sub menu will expand to the right, probably because there is not enough room to put it on the left.

    I forgot to add that this happens to all context menus. The initial menu always appears to the left of the mouse position when the right button is clicked.
    Last edited by JC Zorkoff; 2014-01-23 at 13:35.

  4. #4
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    4,754
    Thanks
    171
    Thanked 652 Times in 575 Posts
    I just discovered that I can reproduce that effect on my Windows 8.1 laptop by going to;

    Windows Accessories, Tablet PC, Windows Journal, Tools, Options, Other, Tablet Settings, Other, Handedness, Right-handed (Menus appear to the left of your hand) [Phew!]

    (From the start screen, it appears that you just type Journal to get into Windows Journal.)

    It's possible that you've "played" with Windows Journal, stumbled across that setting, and thought (as I could easily have done) "I'm not left-handed"; yet that's the default!

    Change it back from Right-handed to Left-handed and you may find mouse-clicks produce menus on the traditional side.

    "Left-handed [Tablet PC] users continue to see current behavior, in which ToolTips and menus appear to the right of the mouse cursor or the active menu title."

    Bruce
    Last edited by BruceR; 2014-01-23 at 14:28.

  5. The Following User Says Thank You to BruceR For This Useful Post:

    JC Zorkoff (2014-01-23)

  6. #5
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,593
    Thanks
    5
    Thanked 1,059 Times in 928 Posts

  7. The Following User Says Thank You to JoeP517 For This Useful Post:

    JC Zorkoff (2014-01-23)

  8. #6
    3 Star Lounger JC Zorkoff's Avatar
    Join Date
    Dec 2009
    Location
    Boston, Massachusetts, USA
    Posts
    226
    Thanks
    21
    Thanked 45 Times in 40 Posts
    Thank you Bruce and Joe. Changing the Handedness setting solved the problem.

    Both of your solutions got to the same place. Joe's link provided the fastest way by pasting

    shell:::{80F3F1D5-FECA-45F3-BC32-752C152E456E}

    into the run command (Win+R)

    My thanks to both of you. My searches did not uncover the information you provided.

    On further reading in Joe's link, I found this even easier way to fix the setting:

    If your Tablet PC Settings are already in place you can just go to the Control Panel and search for Tablet PC Settings. Open these settings and click the Other tab and set the Handedness to Left-handed.
    Last edited by JC Zorkoff; 2014-01-23 at 14:42. Reason: more info

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •