Results 1 to 10 of 10
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    Erie, PA
    Posts
    21
    Thanks
    3
    Thanked 0 Times in 0 Posts

    usb ports not working

    I have a Lenovo Y570 with one usb 2 port and two usb 3 ports. Last week the usb 3 ports stopped working. USB 2 still working fine. Cannot figure out what changed. Have tried uninstalling all usb stuff in Device Settings and letting it find and reinstall. Have checked BIOS setup to make sure usb is enabled. have updated usb drivers. Any ideas??

  2. #2
    Silver Lounger
    Join Date
    Aug 2012
    Location
    UK
    Posts
    1,825
    Thanks
    30
    Thanked 248 Times in 242 Posts
    Have you tried Lenovo's Diagnostics tool http://support.lenovo.com/en_GB/diag.../default.page?

    That's for the Y570 Win 7 64bit but you can use the Modify button to reselect Laptops/Tablets and re-enter your model details to be more specific about your version of Windows - Home Premium etc.

  3. #3
    New Lounger
    Join Date
    Dec 2009
    Location
    Erie, PA
    Posts
    21
    Thanks
    3
    Thanked 0 Times in 0 Posts
    When I go to the page and put in my model ideapad y570 it is not listed in any of the supported systems for each of the diagnostic tools -- only thinks and essentials are listed so not sure what to do.

  4. #4
    Silver Lounger
    Join Date
    Aug 2012
    Location
    UK
    Posts
    1,825
    Thanks
    30
    Thanked 248 Times in 242 Posts
    Yes, I was wondering about that when I checked the site out, but as it was an auto tool, thought it may have run anyway.

    How old is your Y570 ?

    This fix it will run the hardware and devices troubleshooter http://windows.microsoft.com/en-gb/w...th-usb-devices

    While it probably is the Y570, have/can you try any devices in another machine ?

  5. #5
    New Lounger
    Join Date
    Dec 2009
    Location
    Erie, PA
    Posts
    21
    Thanks
    3
    Thanked 0 Times in 0 Posts
    MS FixIt troubleshooter did not find/solve problem. usb drive and usb devices (e.g., printer) work fine in usb 2 port and in other machines, just not in usb 3 ports on y570. Got computer in Nov.2012.

  6. #6
    Silver Lounger
    Join Date
    Aug 2012
    Location
    UK
    Posts
    1,825
    Thanks
    30
    Thanked 248 Times in 242 Posts
    Looks like it could be a common problem if Lenovo have released this fix http://support.lenovo.com/en_GB/diag...DocID=HT070256

  7. The Following User Says Thank You to Sudo15 For This Useful Post:

    cotcjim (2014-03-19)

  8. #7
    New Lounger
    Join Date
    Dec 2009
    Location
    Erie, PA
    Posts
    21
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Thought I had already done that but tried it again and it worked! THANK YOU for pursuing this with me.

  9. #8
    Silver Lounger
    Join Date
    Aug 2012
    Location
    UK
    Posts
    1,825
    Thanks
    30
    Thanked 248 Times in 242 Posts
    If they still don't work after that download, I've read that you may need to download the Energy Management Software which you can find at http://support.lenovo.com/en_GB/downloads/default.page? as well as the Chipset and BIOS downloads.

    Edit - Cross posting, but glad that worked - just didn't ask Google the right questions last time
    Last edited by Sudo15; 2014-03-19 at 20:37.

  10. The Following User Says Thank You to Sudo15 For This Useful Post:

    cotcjim (2014-03-19)

  11. #9
    New Lounger
    Join Date
    Dec 2009
    Location
    Erie, PA
    Posts
    21
    Thanks
    3
    Thanked 0 Times in 0 Posts
    It's working so I'm not going to mess with it!

  12. #10
    Silver Lounger
    Join Date
    Aug 2012
    Location
    UK
    Posts
    1,825
    Thanks
    30
    Thanked 248 Times in 242 Posts
    Quote Originally Posted by cotcjim View Post
    It's working so I'm not going to mess with it!
    That's the best way.

    Anyway, off to bed now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •