Results 1 to 4 of 4
  1. #1
    New Lounger
    Join Date
    May 2012
    Posts
    22
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Office 2007 keeps configuring itself over and again

    I have used Office without any hassle for several years in Win7, but recently I re-arranged the content of the hard drive so that downloads would go into a separate partition. Since then, when I want to open a WORD or EXCEL file, there is minutes of delay while Office 'configures' itself. How can I restore proper functioning ?

  2. Subscribe to our Windows Secrets Newsletter - It's Free!

    Get our unique weekly Newsletter with tips and techniques, how to's and critical updates on Windows 7, Windows 8, Windows XP, Firefox, Internet Explorer, Google, etc. Join our 480,000 subscribers!

    Excel 2013: The Missing Manual

    + Get this BONUS — free!

    Get the most of Excel! Learn about new features, basics of creating a new spreadsheet and using the infamous Ribbon in the first chapter of Excel 2013: The Missing Manual - Subscribe and download Chapter 1 for free!

  3. #2
    Silver Lounger mrjimphelps's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    2,137
    Thanks
    202
    Thanked 206 Times in 198 Posts
    My guess is that when you moved stuff around, Office no longer knew where to find its config info.

    I would completely uninstall Office, reboot, then install it into the new location. Doing this will correct all of the paths that Office is using.

  4. #3
    3 Star Lounger
    Join Date
    Dec 2009
    Posts
    273
    Thanks
    15
    Thanked 63 Times in 53 Posts
    Unfortunately it's a well-known problem for both Office 2007 and Office 2010.

    Method 1
    In Windows 7/Vista, click Start, click All Programs, click Accessories, and then select Run.
    In Windows XP, click Start, and then click Run.
    Type (or copy and paste) the following command, and then press Enter:
    Code:
    reg add HKCU\Software\Microsoft\Office\12.0\Word\Options /v NoReReg /t REG_DWORD /d 1
    Verify that the problem is resolved.

    Method 2
    Alternatively, copy and paste the following into Notepad then save it as something like norereg.reg to your desktop then double-click on it to import it into the registry. (Important: Make sure there is a blank line after "NoReReg"=dword:00000001.)

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Word\Options]
    "NoReReg"=dword:00000001
    (This does exactly the same as method 1.)

    Method 3
    If for any reason this doesn't work then navigate in an Explorer window to C:\Program Files\Common Files\microsoft shared\OFFICE12\Office Setup Controller and rename SETUP.EXE to something like SETUP(DISABLED).EXE. This will stop the Configuration Wizard from running but can always be reversed if you DO want to change Office 12's setup.

    office12.jpg
    Click to enlarge

    Hope this helps...
    Last edited by Rick Corbett; 2014-04-01 at 09:40.

  5. #4
    New Lounger
    Join Date
    May 2012
    Posts
    22
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rick Corbet - Your method 1 did not work for me, but luckily I managed to extract from it a manual procedure which fixed WORD. There is a complication with Excel and it may take further massaging.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •