Results 1 to 7 of 7
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    Gold Coast Australia
    Posts
    14
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Win7 File Explorer Very Slow Accessing Network Drive

    I am using a mapped network drive (SATA, DLink, ran very well for years in its current setup) and for some reason Win7 File Explorer recently started takeing a very long time to list the contents of the drive. Points to note:
    • I don't index this drive as I know its operating system is Linux based and therefore Win7 will index it by copying the entire contents to a local disk.
    • I've googled widely and tried just about every solution I can find including fiddling with page sizing, switching on/off Remote Differential Compression, switching on/off Windows Search, limiting details to display, setting folder display to 'general', tried using offline synching and others.
    • Every other third party file explorer displays the contents in seconds.
    • Loading Ubuntu in a virtual manager and viewing the drive there, the contents are displayed in seconds.
    • Loading Win XP in a virtual manager and viewing the drive there, the contents are displayed in seconds.

    At this point I've given up and am using a third party viewer (Free Commander XE) but I really shouldn't have to. When googling, there seem to be hundreds of people with this problem in a variety of forums but very few answers seem to work. It seems to just start out of the blue with no common (or even discernible) cause. None of the suggestions have worked for me. All I can think of is that one of my third party system managers/cleaners (eg. Ashampoo WinOptimizer 10) has done a deep change somewhere.
    Anyone in WSL willing to give it a go?
    Cheers, Andy.

  2. #2
    3 Star Lounger
    Join Date
    Apr 2012
    Posts
    237
    Thanks
    3
    Thanked 24 Times in 24 Posts
    I've heard that using a UNC name can bypass the problem, but not the ideal solution.

    I found this - haven't tried it though. It's a Vista fix, but may work, the commands are the same as in Win 7.

    http://support.microsoft.com/kb/934430

    Good luck!

  3. #3
    New Lounger
    Join Date
    Dec 2009
    Location
    Gold Coast Australia
    Posts
    14
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Hi Bigmac56,
    Okay, the support fix didn't work. So, next thing I tried was the UNC addressing. I currently have the drive mapped to M:\, so rather than remove that mapping, I just mapped to another letter. TADAH!!! Worked perfectly. So, I then went to map M:\drive using UNC, thinking that would fix everything and singing your praises as Win7 guru.
    Unfortunately, the behavior persists when using the 'M:' letter selection. I want to keep this as there are some paths that are expecting to see things in that drive.
    So, what is happening with M: that causes this never ending indexing/searching... etc?
    As a last resort I'm going to un-map, shutdown/reboot, re-map and see if it goes away.

    ... nope, didn't work. Still rebuilding the whole index.

    Thanks anyway, Andy.
    Last edited by AndyDap; 2014-04-09 at 00:12. Reason: words

  4. #4
    New Lounger
    Join Date
    Dec 2009
    Location
    Gold Coast Australia
    Posts
    14
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Just noticed something very interesting. If I'm in accessing an application that has me attaching files (e.g. happened 2 minutes ago in Thunderbird) the attachment window comes up and looks almost exactly the same as a standard Explorer window but it behaves as I'd expect. All folders and files are displayed almost instantly. Could there be some option I've selected in Explorer that causes some sort of intensive re-indexing every time? I don't have thumbnails displayed (generally go for a 'details' view) and I don't think I've got anything special selected in the details, as a matter of fact at the moment, it only displays filename but the 'indexing' problem persists.

  5. #5
    New Lounger
    Join Date
    Dec 2009
    Location
    Gold Coast Australia
    Posts
    14
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Differences Between Different Mountings of the Same Network Drive

    Went back to basics after finding out that re-mounting the drive with a new letter seems to fix the problem and tried a comparison between a working version (T: ) and the faulty version (M: ). Did this by selecting the menu options Tools\Folder Options... and the View\Customize this Folder...

    Tools\Folder Options... is the same for both mounts (and I have set all options to default where possible and made sure the options are the same if a default selection wasn't available).

    View\Customize this Folder... is different. I have attached screen snaps to help explain. M: has an extra tab called 'Locations' (as shown in first image) and under the 'Customize' tab it is missing the complete 'Folder pictures' selections you can see in the second image (T: ). Other than those differences, everything else is the same.

    No idea what this means.
    Attached Images Attached Images

  6. #6
    New Lounger
    Join Date
    Dec 2009
    Location
    Gold Coast Australia
    Posts
    14
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Okay, the locations tab is there because M:\ drive was a targeted location for 'My Documents'. I moved that location elsewhere, off a network drive (the process copied all my files to that new location, I think because M:\ was mapped network drive). This new location works perfectly and doesn't do the endlessly slow 'indexing'. M:\ is still slow but the 'Locations' tab has gone.

  7. #7
    New Lounger
    Join Date
    Dec 2009
    Location
    Gold Coast Australia
    Posts
    14
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Fixed it. It was all about either sorting or grouping in File Explorer. Sorry I can't be more specific but I was in a bit of a frustration filled mouse-clicking frenzy, jumping backwards and forwards between the new 'My Documents' folder on the non-network drive and the badly behaving M:\ drive. I think it was grouping based on date that I must have set up at some time (though I'm sure it was behaving badly before this). I've moved the 'My Documents' location back to M:\ and it is still behaving correctly. Anyway, all sorted.
    Guess it must have been struggling to group files on a non-indexed network drive.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •