Results 1 to 5 of 5
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Unhappy Word 2007 displaying bizarre macros warning dialog

    I'm running Word 2007 with the latest service pack. Today, a strange behavior occurred. When I started Word, a dialog box appeared with an extremely length message about macros. The heading: "The function you are attempting to run contains macros or content that requires macro support. When this software was installed you (or your administrator) chose not to install support for macros or controls." See the attached image.

    I have to dismiss the dialog several times before I can use Word. I have never seen anything like this before. What could be causing the problem? How can I fix it? By the way, in the Trust Center, I tried changing the macros setting to "disable all macros without notification", but this didn't help.
    Attached Images Attached Images

  2. #2
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,433
    Thanks
    371
    Thanked 1,456 Times in 1,325 Posts
    Lavoro,

    How did you start Word? If you clicked on a document in File Explorer the document may be in an untrusted location and contain macros or your macro security settings are set to high. With out more information, e.g. Macro Security level, secure locations, how you opened word, etc., it is hard to diagnose the exact problem. HTH
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  3. #3
    New Lounger
    Join Date
    Dec 2009
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    RetiredGeek, the behavior happens when I start Word from the Programs menu or when I double-click a file to open it. Files in all locations trigger the error: Desktop, My Documents, etc. I have not changed any macro settings since Office was installed, except to change the following setting to see if it would fix the problem: For macros in documents not in a trusted location - Disable all macros without notification.

  4. #4
    5 Star Lounger
    Join Date
    Mar 2001
    Location
    New York, NY
    Posts
    922
    Thanks
    2
    Thanked 12 Times in 11 Posts
    Here's some info from the Microsoft website:

    http://answers.microsoft.com/en-us/o...6-0adfd8b8ea95

  5. #5
    Silver Lounger Charles Kenyon's Avatar
    Join Date
    Jan 2001
    Location
    Sun Prairie, Wisconsin, Wisconsin, USA
    Posts
    2,048
    Thanks
    124
    Thanked 119 Times in 116 Posts
    A long-shot possibility would be that an Add-In installed in the Office STARTUP folder (not the Word Startup Folder). The Office STARTUP folder is not a trusted location by default.

    When I get weird behavior involving macros, the first place I look is Add-Ins, which can be in at least three different spots. Enable or disable add-ins.
    Charles Kyle Kenyon
    Madison, Wisconsin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •