Results 1 to 9 of 9
  1. #1
    New Lounger
    Join Date
    Jun 2014
    Posts
    4
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Connected to WiFi but no Internet access

    It shows that I'm connected to the wifi, but there is no internet access.
    Next, I connected an ethernet cable, and there was internet access.

    What could be the issue?
    Thanks!

  2. Get our unique weekly Newsletter with tips and techniques, how to's and critical updates on Windows 7, Windows 8, Windows XP, Firefox, Internet Explorer, Google, etc. Join our 480,000 subscribers!

    Excel 2013: The Missing Manual

    + Get this BONUS — free!

    Get the most of Excel! Learn about new features, basics of creating a new spreadsheet and using the infamous Ribbon in the first chapter of Excel 2013: The Missing Manual - Subscribe and download Chapter 1 for free!

  3. #2
    Platinum Lounger
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    3,626
    Thanks
    7
    Thanked 231 Times in 219 Posts
    That probably means you haven't really connected to wifi. Check that you have the correct wifi password.
    You can check the connection by running a command on your machine when connected by cable and by wifi - you can paste the result here if you want us to confirm it is OK.
    Commands
    Start > Run > cmd
    ipconfig /all

    The commands will show you the IP address you r computer is using. The IP address is like a "postal address" that you use to send and receive data on the internet.

    cheers, Paul

  4. #3
    New Lounger
    Join Date
    Jun 2014
    Posts
    4
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Thanks Paul!

    I do have the correct password, because I'm able to connect via my phone and another laptop.
    Here are the results..

    When connected via Ethernet cable:

    C:\>ipconfig /all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : nc-6400-2
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . : tx.rr.com

    Ethernet adapter Wireless Network Connection:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Intel(R) PRO/Wireless 3945ABG Networ
    k Connection
    Physical Address. . . . . . . . . : 00-19-D2-40-C3-6C
    Dhcp Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . : 192.168.1.98
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.1.1
    DNS Servers . . . . . . . . . . . : 8.8.8.8
    8.8.4.4

    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . : tx.rr.com
    Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet
    Physical Address. . . . . . . . . : 00-16-D4-A6-35-A8
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . : 192.168.0.5
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.0.1
    DHCP Server . . . . . . . . . . . : 192.168.0.1
    DNS Servers . . . . . . . . . . . : 209.18.47.61
    209.18.47.62
    Lease Obtained. . . . . . . . . . : Monday, June 02, 2014 9:24:49 AM
    Lease Expires . . . . . . . . . . : Monday, June 02, 2014 10:24:49 AM



    When connected to wifi

    C:\>ipconfig /all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : nc-6400-2
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Wireless Network Connection:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Intel(R) PRO/Wireless 3945ABG Networ
    k Connection
    Physical Address. . . . . . . . . : 00-19-D2-40-C3-6C
    Dhcp Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . : 192.168.1.98
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.1.1
    DNS Servers . . . . . . . . . . . : 8.8.8.8
    8.8.4.4

    Ethernet adapter Local Area Connection:

    Media State . . . . . . . . . . . : Media disconnected
    Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet
    Physical Address. . . . . . . . . : 00-16-D4-A6-35-A8

  5. #4
    Platinum Lounger
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    3,626
    Thanks
    7
    Thanked 231 Times in 219 Posts
    You have a manually configured wireless and it is very different to the wired.
    Wireless IP: 192.168.1.98
    Wired IP: 192.168.0.5
    To fix this you need to change the wireless config to use DHCP, not manual, unless you have a very specific set up with multiple networks and routers.

    cheers, Paul

  6. #5
    New Lounger
    Join Date
    Jun 2014
    Posts
    4
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Thanks Paul! But not to sound silly....how do I do that? :P

  7. #6
    Platinum Lounger
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    3,626
    Thanks
    7
    Thanked 231 Times in 219 Posts
    In Windows 7.
    1. Open Control Panel.
    2. Click Network and Internet.
    3. Click View network status and tasks.
    4. Click Change adapter settings.
    5. Right click the wireless adapter and select Properties.
    6. Select Internet Protocol Version 4.
    7. Click Properties.
    8. Tick both obtain automatically boxes.
    9. Click OK and OK.

    Capture.PNG

    cheers, Paul

  8. The Following User Says Thank You to Paul T For This Useful Post:

    Fatima Merchant (2014-06-03)

  9. #7
    New Lounger
    Join Date
    Jun 2014
    Posts
    4
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Thanks so much Paul! It worked!!

  10. #8
    Platinum Lounger
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    3,626
    Thanks
    7
    Thanked 231 Times in 219 Posts
    Yay!

    cheers, Paul

  11. #9
    Star Lounger
    Join Date
    Jan 2010
    Location
    Los Angeles, California, USA
    Posts
    96
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Quote Originally Posted by Paul T View Post
    In Windows 7.
    1. Open Control Panel.
    2. Click Network and Internet.
    3. Click View network status and tasks.
    4. Click Change adapter settings.
    5. Right click the wireless adapter and select Properties.
    6. Select Internet Protocol Version 4.
    7. Click Properties.
    8. Tick both obtain automatically boxes.
    9. Click OK and OK.

    Capture.PNG

    cheers, Paul
    Paul, this is an XP forum so the steps for Windows XP might be a little different. OP (Fatima) hasn't said what version of Windows was being used.
    In Windows XP, go to Control Panel > Network Connections > Wireless Network Connection, right-click on Wireless Network Connection and choose Properties, select "Internet Protocol (TCP/IP)" [not TCP/IP v6] and click on the Properties button to access the TCP/IP v4 properties dialog box.

    Note to OP (Fatima): I noticed that the Intel 3945abg wireless adapter was mentioned. I also use that Intel 3945abg WLAN adapter but under Win7. In that case be sure to install the latest XP drivers for the 3945abg adapter from this Intel page. Best to get the Wireless_15.3.1_Dx32.exe package if using 32bit version of Windows XP. Run that EXE file to install or update the 3945abg drivers to v13.4.0.139.
    Last edited by np-7930; 2014-06-06 at 16:49.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •