Results 1 to 13 of 13
  1. #1
    3 Star Lounger KritzX's Avatar
    Join Date
    Jun 2014
    Posts
    380
    Thanks
    15
    Thanked 42 Times in 42 Posts

    Angry Primary HD appears on Safely Remove Hardware menu

    Hey everyone I've been facing this really annoying problem ever since i reinstalled Win7 on my laptop (which was about 2 months ago). There's always an icon for "Safely Remove Hardware and Eject Media" icon and every single time it shows the INTERNAL, NON-REMOVABLE hard drive on the list. Every single time I want to eject a flash drive or my external hard drive I always seem to click the primary hard drive. Though it only pops up an error message about "files being in use", it's gone from mildly annoying to seriously frustrating. Is there any way to remove the hard drive from the list? Perhaps a registry hack? Please help me out on this as I plug in and plug out external devices numerous times a day and this annoying quirk is tempting me to toss the laptop out the window.

    Ironic how a reinstall is supposed to FIX problems huh?

    -maligo

    P.S: here's a screenshot. The WDC entry corresponds to my hard drive.

    Untitled.png
    Fact of Life:

    “Real stupidity beats artificial intelligence every time.”
    Terry Pratchett

  2. #2
    Super Moderator jwitalka's Avatar
    Join Date
    Dec 2009
    Location
    Minnesota
    Posts
    4,731
    Thanks
    67
    Thanked 542 Times in 490 Posts
    If you are willing to play with the registry, a fix is shown here:
    http://www.overclock.net/t/974023/fi...emove-hardware

    I would definitely make an image backup before trying it.

    Jerry

  3. #3
    3 Star Lounger KritzX's Avatar
    Join Date
    Jun 2014
    Posts
    380
    Thanks
    15
    Thanked 42 Times in 42 Posts
    Thanks for the suggestion. I'll try it out and post back.
    Fact of Life:

    “Real stupidity beats artificial intelligence every time.”
    Terry Pratchett

  4. #4
    3 Star Lounger KritzX's Avatar
    Join Date
    Jun 2014
    Posts
    380
    Thanks
    15
    Thanked 42 Times in 42 Posts

    Unhappy Erp!

    Nope sorry that didn't work out. In fact after doing the editing and rebooting the PC, the problem appeared to have been resolved. The icon wasn't visible in the tray. However when I plugged in my flash drive and checked the system tray, the icon still didn't appear. Tried right-clicking the clock and choosing Customise Notification Icons. Both the icon and notification were set to be shown, but still no icon appeared on the system tray. I clicked the Up arrow on the tray but still nothing! Then I decided to restore the backup copy of the registry i had made (Phew!) and rebooted. That brought back the icon ALONG with the HD!!!

    Sigh, any more options?
    Fact of Life:

    “Real stupidity beats artificial intelligence every time.”
    Terry Pratchett

  5. #5
    Platinum Lounger
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    3,610
    Thanks
    7
    Thanked 230 Times in 218 Posts
    I have the same, I just don't eject it.

    cheers, Paul

  6. #6
    3 Star Lounger KritzX's Avatar
    Join Date
    Jun 2014
    Posts
    380
    Thanks
    15
    Thanked 42 Times in 42 Posts

    Lightbulb Problem Solved!

    Found a solution thought I'd post it here:
    Basically all you have to do is open an Admin Command Prompt and enter the following command:

    reg.exe add "HKLM\SYSTEM\CurrentControlSet\Services\msahci\Con troller0\Channel0" /f /v TreatAsInternalPort /t REG_DWORD /d 0x00000001

    If it doesn't work out for anyone reading this post then here's a link to the original URL where a few other possibilities are stated.
    http://www.tomshardware.com/forum/26...emove-hardware

    Though the article was for a DVD drive I decided to try it out for my HDD. The solution suggested was extremely similar to the one Jerry suggested but the new key was made through a Command Prompt not the Registry Editor. Hmm...maybe I must have screwed up the steps on the link Jerry suggested. Anyways all is well now and the annoying HDD is banished from the list!

    Cheers
    maligo
    Fact of Life:

    “Real stupidity beats artificial intelligence every time.”
    Terry Pratchett

  7. #7
    3 Star Lounger KritzX's Avatar
    Join Date
    Jun 2014
    Posts
    380
    Thanks
    15
    Thanked 42 Times in 42 Posts
    Quote Originally Posted by Paul T View Post
    I have the same, I just don't eject it.

    cheers, Paul
    Hmm you can maybe take a look at the solution I posted if you want to Paul.

  8. #8
    Platinum Lounger
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    3,610
    Thanks
    7
    Thanked 230 Times in 218 Posts
    The two methods are the same, you probably made a typo or didn't create the data as a DWORD.
    I had to run 3 because I have 3 disks, now they don't appear as removable, thanks for the tip.
    Code:
    reg.exe add "HKLM\SYSTEM\CurrentControlSet\Services\msahci\Controller0\Channel0" /f /v TreatAsInternalPort /t REG_DWORD /d 0x00000001
    reg.exe add "HKLM\SYSTEM\CurrentControlSet\Services\msahci\Controller0\Channel1" /f /v TreatAsInternalPort /t REG_DWORD /d 0x00000001
    reg.exe add "HKLM\SYSTEM\CurrentControlSet\Services\msahci\Controller0\Channel2" /f /v TreatAsInternalPort /t REG_DWORD /d 0x00000001
    cheers, Paul

  9. #9
    2 Star Lounger
    Join Date
    Dec 2009
    Location
    New Brunswick, Canada
    Posts
    161
    Thanks
    10
    Thanked 2 Times in 2 Posts
    It's possible there is a BIOS setting to prevent this. I had this issue before and I'm certain there was a BIOS setting for each attached SATA drive to prevent this.
    George

  10. #10
    3 Star Lounger KritzX's Avatar
    Join Date
    Jun 2014
    Posts
    380
    Thanks
    15
    Thanked 42 Times in 42 Posts
    I think you mean the AHCI setting in the BIOS right? Yup a few websites pointed that out but I couldn't find any such setting in the BIOS. Anyways the problem is solved now. Thanks for your reply.
    Fact of Life:

    “Real stupidity beats artificial intelligence every time.”
    Terry Pratchett

  11. #11
    3 Star Lounger KritzX's Avatar
    Join Date
    Jun 2014
    Posts
    380
    Thanks
    15
    Thanked 42 Times in 42 Posts
    Sure Paul, glad I could help.
    Fact of Life:

    “Real stupidity beats artificial intelligence every time.”
    Terry Pratchett

  12. #12
    2 Star Lounger
    Join Date
    Dec 2009
    Location
    New Brunswick, Canada
    Posts
    161
    Thanks
    10
    Thanked 2 Times in 2 Posts
    Quote Originally Posted by maligo View Post
    I think you mean the AHCI setting in the BIOS right? Yup a few websites pointed that out but I couldn't find any such setting in the BIOS. Anyways the problem is solved now. Thanks for your reply.
    Yes it was something like that. Was a Gigabyte MB IIRC.
    George

  13. #13
    2 Star Lounger
    Join Date
    Jun 2014
    Location
    Queensland, Australia
    Posts
    161
    Thanks
    0
    Thanked 6 Times in 6 Posts
    If your computer's motherboard has an nVidia NForce4 chipset, then you might want to try below regedit hack.

    Run Regedit as Adiminstrator.

    In regedit navigate to:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\nvata

    Click Edit

    Select New > DWORD value

    Name this new DWORD: DisableRemovable

    Double click this new DWORD and set its value to one (1) i.e.: True

    Close Regedit and reboot

    Hopefully your Windows drive will no longer show in the "Safely remove hardware" list.
    Last edited by Coochin; 2014-07-06 at 08:41.
    Computer Consultant/Technician 15+ years experience.
    Most common computing error is EBKACB: Error Between Keyboard And Chair Back
    AMD FX8120 (8-core @ 3.1GHz) CPU, Gigabyte GA-990FXA-D3 motherboard, 8GB (2x4GB) DDR3 1866MHz RAM, ATI-AMD Radeon HD6770 PCI-E VGA, 480GB Kingston SSD, 2TB Seagate SATA3.0 HDD, ASUS DVD/RW.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •