Results 1 to 7 of 7
  1. #1
    New Lounger
    Join Date
    Jul 2014
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Excel 2010 not saving JPG image compression

    In Excel 2010 I can compress the JPG images and save the file without any issues. When I reopen the file the images revert back to the full size before compression. Iíve noticed that I can stop the problem if I disconnect from the internet. When I plug the CPU back to the network the picture return to the full size. Iím working with hundreds of pictures and I need a way to compress the images and have Excel save the information.

  2. #2
    Silver Lounger
    Join Date
    Mar 2014
    Location
    Forever West
    Posts
    2,072
    Thanks
    0
    Thanked 259 Times in 248 Posts
    if I disconnect from the internet
    When I plug the CPU back to the network
    Haven't worked with images in Excel but for many things dealing with images a whole lot depends upon the original source and the images may not be on your computer. The mention of 'network' suggests a company's Server and the mention of the Internet suggests you are getting them from an outside source. I've found it always best to save images to my HDD before working with them.

  3. #3
    New Lounger
    Join Date
    Jul 2014
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I’m working with thousands of pictures from different sources so saving to my hard drive wouldn’t be an option. I can trick excel from saving the links to the original picture size if I save to the old Excel 97-2003 worksheet but I end up losing information from some of the cells.

  4. #4
    WS Lounge VIP rory's Avatar
    Join Date
    Dec 2000
    Location
    Burwash, East Sussex, United Kingdom
    Posts
    6,280
    Thanks
    3
    Thanked 191 Times in 177 Posts
    What settings do you have checked under 'Image size and Quality' in Excel Options - Advanced section?
    Regards,
    Rory

    Microsoft MVP - Excel

  5. #5
    New Lounger
    Join Date
    Jul 2014
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have 220 ppi set in the advanced options. When I change to 96 ppi it didn't have any impact on saving the compression. I’m guessing the key would be to stop having Excel try to find the link to the image. When I first open the spreadsheet I often get the following error message (The Linked Image cannot be displayed. The file may have been moved, renamed, or deleted. Verify that the links points to the correct file and location). I’m using a macro to import the image into a cell from webpage links. For example http://g-ecx.images-amazon.com/image...349266777_.jpg

  6. #6
    New Lounger
    Join Date
    Jul 2014
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I figured out a temporally fix that’s a better option than saving to Excel 97-2003. Save the document as an ODS and close. Reopen the ODS file and Save back to XLSX. Reopen the XLSX and make adjustments to the pictures as needed and now Excel saves the compression. For some reason saving the Excel document to the ODS kills the hidden picture links.
    Hopefully somebody can explain how to turn off the hidden picture link.

  7. #7
    WS Lounge VIP rory's Avatar
    Join Date
    Dec 2000
    Location
    Burwash, East Sussex, United Kingdom
    Posts
    6,280
    Thanks
    3
    Thanked 191 Times in 177 Posts
    You said you're using a macro to get the pictures - what's the code? If it uses Pictures.Insert, that's the problem. You should use Shapes.Addpicture which allows you to specify whether to link or not.
    Regards,
    Rory

    Microsoft MVP - Excel

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •