Results 1 to 12 of 12
  1. #1
    2 Star Lounger AlanWade's Avatar
    Join Date
    Dec 2009
    Location
    Sweden
    Posts
    109
    Thanks
    12
    Thanked 3 Times in 3 Posts

    Cannot STOP My PC from Going to Sleep

    As the title says my PC insists on going to sleep after an hours inactivity. I have turn off hibernation/sleep in the Energy Saving app but still it goes to sleep. I have Googled the answer only to find that most people want their machines to go in sleep mode and not the other way around.
    Does anyone know of a registry setting or something similar so I can stop my machine from going to sleep mode.
    My system is Win 8.1 Update 1 if it helps.
    Thanks in advance

    Alan

  2. #2
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    3,420
    Thanks
    33
    Thanked 195 Times in 175 Posts
    On Windows 7, I use a program called Don't Sleep when I want my PC to continue working (backup copying, defrags, etc) overnight. There are 32-bit and 64-bit versions.

    I previously used to use a program called Caffeine, but I found that this didn't reliably work for me, even when running multiple instances!
    BATcher

    Time prevents everything happening all at once...

  3. #3
    Super Moderator bbearren's Avatar
    Join Date
    Dec 2009
    Location
    Polk County, Florida
    Posts
    3,760
    Thanks
    26
    Thanked 424 Times in 338 Posts
    Go to Control Panel > All Control Panel Items > Power Options > Edit Plan Settings. On that page, choose when to turn off the display, and select "Put the computer to sleep: Never". Then click on "Change advanced power settings". This will open a dialogue box, "Power Options" with the tab, Advanced settings.


    Next, click on "Change settings that are currently unavailable". That will open an extended list of power options on just about everything in your PC. Go through each and every item and select how you want it to behave. One of them is Sleep > Sleep after; select 0 minutes. Go through all of them, and you'll see that some have a sleep setting - select accordingly.
    Create a fresh drive image before making system changes, in case you need to start over!

    "The problem is not the problem. The problem is your attitude about the problem. Savvy?"—Captain Jack Sparrow "When you're troubleshooting, start with the simple and proceed to the complex."—M.O. Johns "Experience is what you get when you're looking for something else."—Sir Thomas Robert Deware.
    Unleash Windows

  4. #4
    4 Star Lounger
    Join Date
    Jun 2011
    Location
    Hampshire (the old one)
    Posts
    525
    Thanks
    21
    Thanked 72 Times in 62 Posts
    You don't say if it's a laptop - if it is, it might be a faulty lid switch.

  5. #5
    2 Star Lounger AlanWade's Avatar
    Join Date
    Dec 2009
    Location
    Sweden
    Posts
    109
    Thanks
    12
    Thanked 3 Times in 3 Posts
    Thanks for the suggestions.

    @bbearen I followed your instructions but didnt see anything untoward, howerever did do a little tweaking. Up to now the computer hasnt gone into sleep mode so hopefully your suggestion has cured it.

    @BATcher I downloaded the file and will try it out if bbearen's suggestion hasnt worked.

    @tonyl sorry for not mentioning it, its a desktop.

  6. #6
    WS Lounge VIP mrjimphelps's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    3,407
    Thanks
    447
    Thanked 405 Times in 377 Posts
    Quote Originally Posted by bbearren View Post
    Go to Control Panel > All Control Panel Items > Power Options > Edit Plan Settings. On that page, choose when to turn off the display, and select "Put the computer to sleep: Never". Then click on "Change advanced power settings". This will open a dialogue box, "Power Options" with the tab, Advanced settings.


    Next, click on "Change settings that are currently unavailable". That will open an extended list of power options on just about everything in your PC. Go through each and every item and select how you want it to behave. One of them is Sleep > Sleep after; select 0 minutes. Go through all of them, and you'll see that some have a sleep setting - select accordingly.
    Great tips! I found some items which were set to "sleep", which I have since changed: Lid closing now does nothing; power button now turns computer off.

  7. #7
    Super Moderator jwitalka's Avatar
    Join Date
    Dec 2009
    Location
    Minnesota
    Posts
    6,796
    Thanks
    117
    Thanked 799 Times in 720 Posts
    Are you sure its going to sleep and not just turning the screen off?

    Jerry

  8. #8
    2 Star Lounger AlanWade's Avatar
    Join Date
    Dec 2009
    Location
    Sweden
    Posts
    109
    Thanks
    12
    Thanked 3 Times in 3 Posts
    I think your right Jerry, just turning the screen off. Anyway I still havnt found a cure for it. The annoying part is that it seems to be random as in sometimes I can leave the PC for a couple of hours and the screen is still activated, sometimes it isnt.
    Its more of a "Why is it doing this" than an "annoyance".

  9. #9
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    4,752
    Thanks
    171
    Thanked 651 Times in 574 Posts
    Could this recent bug fix be relevant? (Depends whether an hour is "a short time period".) Computer goes back to sleep mode quickly in Windows 8.1 or Windows Server 2012 R2

    If you installed optional updates this month you may already have this fix as part of July 2014 update rollup for Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2

    Bruce

  10. #10
    2 Star Lounger AlanWade's Avatar
    Join Date
    Dec 2009
    Location
    Sweden
    Posts
    109
    Thanks
    12
    Thanked 3 Times in 3 Posts
    I have all the updates Bruce I am wondering if its a third party app that turning off the monitor. Going through everything slowly as its annoying me that its random and I dont know what it is rather than the fact that it is.

  11. #11
    2 Star Lounger AlanWade's Avatar
    Join Date
    Dec 2009
    Location
    Sweden
    Posts
    109
    Thanks
    12
    Thanked 3 Times in 3 Posts
    Found the cause!
    It was MalwareBytes Pro that was putting the monitor to sleep. Why? I dont know and cannot find any setting to disable this action but at least I know the cause now.

    Thanks to all for their suggestions.


    Alan

  12. #12
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,635
    Thanks
    147
    Thanked 883 Times in 844 Posts
    As you are using the Pro version, contact their Support to report the problem and they may have an answer for you.

    Sometimes it's a combination of one or more programs/services conflicting with each when enabled together and depending upon which one you come across first, that will appear to solve the problem - but further investigation with a clean boot and leaving the original one intact could find the other(s) when this is the case.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •