Results 1 to 3 of 3
  1. #1
    New Lounger
    Join Date
    Jul 2014
    Posts
    2
    Thanks
    1
    Thanked 0 Times in 0 Posts

    word 2010 mailmerge if-then problem

    Hi,

    I have not been able to get past this problem:
    I have various paragraphs that will go into mailmerge reports when students meet/fail to meet various threshholds. I have the data in an xls file. So I add a mailmerge rule to compare the score, and put the paragraphs into the if-then-else boxes and it looks like it should work. But when previewing, the paragraphs are cut off -- sometimes only one word shows up. The paragraph text is not in the xls file, so it's not the 255-character issue. Any suggestions?

  2. Get our unique weekly Newsletter with tips and techniques, how to's and critical updates on Windows 7, Windows 8, Windows XP, Firefox, Internet Explorer, Google, etc. Join our 480,000 subscribers!

    Excel 2013: The Missing Manual

    + Get this BONUS — free!

    Get the most of Excel! Learn about new features, basics of creating a new spreadsheet and using the infamous Ribbon in the first chapter of Excel 2013: The Missing Manual - Subscribe and download Chapter 1 for free!

  3. #2
    Super Moderator
    Join Date
    May 2002
    Location
    Canberra, Australian Capital Territory, Australia
    Posts
    3,899
    Thanks
    0
    Thanked 188 Times in 172 Posts
    That suggests your output text in the IF field isn't enclosed by double-quotes. Done properly, an IF field's output can span multiple pages, including tables and images. To verify that the field is constructed along the lines of:
    {IF{MERGEFIELD Score}< 50 "You have failed." "You have passed!"}
    select the whole field, press Shift-F9 to expose the field code and make sure the double-quotes appear as above and that there are spaces in the code where indicated. You can have more, but not less, spaces than I've indicated above.
    Cheers,

    Paul Edstein
    [MS MVP - Word]

  4. The Following User Says Thank You to macropod For This Useful Post:

    msmith708 (2014-07-17)

  5. #3
    New Lounger
    Join Date
    Jul 2014
    Posts
    2
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Thank you! Yes, the problem seems to have been with the quotes -- the faculty person has miscellaneous quotes in the feedback paragraphs. I replaced them with single quotes and it seems to be working now. I had thought it must have to do with line breaks, field limits, or weird formatting, but it must have been the quotes!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •