Results 1 to 4 of 4
  1. #1
    Star Lounger
    Join Date
    Dec 2009
    Posts
    88
    Thanks
    3
    Thanked 1 Time in 1 Post

    HP Pavilion laptop taking forever before connecting to Wi-Fi

    I have an HP Pavilion DM4-2070us with Windows 7 Home Premium (64-bit). The Wi-Fi network adapter installed is a Centrino Wireless-N 1000.

    For the past couple of weeks it has taken "forever" (about 3 minutes) before the laptop can connect to the Wi-Fi network. Upon booting up, a red "X" appears on top of the wireless network icon (the icon with five vertical bars) in the Taskbar. Approximately three minutes later the red "X" disappears and I have Internet connection.

    I am current with Microsoft patches and I have even installed the most current Centrino Wireless-N 1000 driver that I could find at the Intel web site. (The HP support site was of no use...)

    What could possibly be the culprit of this sudden three-minute delay in connecting to Wi-Fi?

  2. #2
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,609
    Thanks
    147
    Thanked 870 Times in 832 Posts
    Open a command prompt as an administrator by going Start - type cmd.exe - right click on cmd and select Run as administrator - accept the UAC then enter these commands -

    netsh winsock reset catalog
    netsh int ip reset resetlog.txt
    ipconfig /flushdns
    ipconfig /release

    ipconfig /renew - If you aren't wired up then you will get the error that no operation can be performed on the LAN when it is not connected, which you can ignore.
    ipconfig /registerdns
    exit


    Reboot the computer.

    If those commands don't do it then power cycle the modem and/or router by switching off the modem (if separate to router), the router, your computer and disconnect all cables for a couple of minutes.

    Reconnect the cables and switch just the modem back on (if separate) - wait until all of the lights are back on and then do the same for the router and then switch your computer on to see how it performs then.

    You can also check in Device Manager/View/Show hidden devices and check for any yellow alerts or Unknown Devices.

    You may also have to check for a firmware update for your router or re-flash the existing firmware, but back up your existing router config first.
    Last edited by Sudo15; 2014-08-24 at 19:35.

  3. #3
    Star Lounger
    Join Date
    Dec 2009
    Posts
    88
    Thanks
    3
    Thanked 1 Time in 1 Post
    Thanks for your reply.
    Did everything mentioned in your message but unfortunately still having the same problem.

  4. #4
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,609
    Thanks
    147
    Thanked 870 Times in 832 Posts
    Let's see what assigning the wireless adapter in the computer with a static IP address or assigning specific DNS servers will do.

    We'll try with just the DNS servers first.

    Open Network and Sharing Center by right clicking on the WiFi icon in the system tray - click on Change adapter settings and right click on the Wireless connection and select Properties.

    You can usually uncheck the box for TCP/IPv6 but click on TCP/IPv4 then Properties

    Click on the radio button for Use the following DNS server addresses and enter 8 into each of the top row of boxes and then 8 into the first two and 4 into the last two of the lower row so the top row will look like 8.8.8.8 and the lower row will display 8.8.4.4 - OK - Close and reboot to see if it connects any quicker.

    You need a bit more info to assign a static IP address but you go into the same window and use the upper radio button for Use the following IP address.

    You will need to log into the router using the Default Gateway and check to see the DHCP range that the router is using which should be somewhere in Wireless settings.

    The range will be something similar to 192.168.1.1 - 192.168.1.254 - if it is using the full range up to .254 then you will need to reduce it so that you can use an address outside of that, so DHCP doesn't assign the same one that you use to another device/machine.

    You can change the last three digits to .199 and then you could use anything between 192.168.1.200 - .253 for your static IP address.

    You will also need the IPv4 Subnet Mask - to obtain both the Default Gateway and Subnet Mask - go into Network and Sharing Center - click on the Wireless connection and then Details.

    When you have the IP address that you are going to use, together with the Subnet Mask and Default Gateway - click on the radio button for Use the following IP address and enter those into the relevant boxes.

    Check the box to Validate settings upon exit - OK - Close and that will open Troubleshooting and when that returns it can't find any problems, you are good to go and reboot.

    If you have had to try the static IP route because the DNS sever change didn't improve the boot connection, you can leave the changed DNS settings or click the auto DNS button to revert.

    Normally, slow connectivity on boot can be your ISP's default DNS servers but when it only improves by assigning a static IP address then the problem is usually with the router - which is why I suggested checking for a firmware update for it, but you could also try factory resetting the router to back out of the box condition and then set it up afresh with your ISP details if need be.
    Last edited by Sudo15; 2014-08-25 at 05:13.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •