Results 1 to 9 of 9
  1. #1
    Bronze Lounger
    Join Date
    Jan 2010
    Location
    Birkirkara, Malta
    Posts
    1,467
    Thanks
    205
    Thanked 15 Times in 14 Posts

    Keyboard Problem

    My keyboard works on Win 7 and was working on Win 8.1, but no longer works on the latter OS.

    Device Manager says:

    "Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39). Unable to load device driver. % hs device driver could not be loaded.

    Error status was Ox%x"

    Advice as to how to fix this would be greatly appreciated.

    Thanks and regards, Roy
    OS Dual Boot Windows 10 Pro 64 Bit & Windows 7 Pro With SP1 64 bit. (Intel Core i7 2600K Processor LGA1155-Asus P867 Pro Motherboard-GTX550 Ti DirectCU Graphics Card-Memory 8GB)

    Roy Whitethread

  2. #2
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,619
    Thanks
    147
    Thanked 875 Times in 837 Posts
    Have you tried unplugging it - rebooting and then plugging it back in ?

  3. #3
    Bronze Lounger
    Join Date
    Jan 2010
    Location
    Birkirkara, Malta
    Posts
    1,467
    Thanks
    205
    Thanked 15 Times in 14 Posts
    Sudo15, yes I did that and it made no difference. I got completely frustrated with having to use the On Screen Keyboard, so I used the Refresh Your PC option which worked fine, and the keyboard works on Win 8.1 now.

    Regards, Roy
    OS Dual Boot Windows 10 Pro 64 Bit & Windows 7 Pro With SP1 64 bit. (Intel Core i7 2600K Processor LGA1155-Asus P867 Pro Motherboard-GTX550 Ti DirectCU Graphics Card-Memory 8GB)

    Roy Whitethread

  4. #4
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,619
    Thanks
    147
    Thanked 875 Times in 837 Posts
    Ah well - at least it's sorted but it would have been nice to find why it happened in the first place

  5. #5
    4 Star Lounger
    Join Date
    Feb 2010
    Location
    Fairfax County, Virginia
    Posts
    584
    Thanks
    11
    Thanked 61 Times in 49 Posts
    Now would be a good time to go to Device Manager and check to see what your Keyboard Driver Provider, Driver Date, and Driver Version are. If you have a problem again, check to see if it has been "updated".

  6. #6
    Bronze Lounger
    Join Date
    Jan 2010
    Location
    Birkirkara, Malta
    Posts
    1,467
    Thanks
    205
    Thanked 15 Times in 14 Posts
    Hi Prescott, according to Device Manager the driver provider for my keyboard is Avast Software, which I can't believe. (I do use Avast Internet Security).

    I will ask Avast about this, but don't expect to get anything out of it.

    Regards, Roy
    OS Dual Boot Windows 10 Pro 64 Bit & Windows 7 Pro With SP1 64 bit. (Intel Core i7 2600K Processor LGA1155-Asus P867 Pro Motherboard-GTX550 Ti DirectCU Graphics Card-Memory 8GB)

    Roy Whitethread

  7. #7
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,619
    Thanks
    147
    Thanked 875 Times in 837 Posts
    Uninstalling Avast had knocked out keyboards for some and an Avast update had done it for others from a Google search.

    This one mentions an Avast keyboard filter driver http://www.sevenforums.com/hardware-...-t-work-2.html

  8. #8
    Bronze Lounger
    Join Date
    Jan 2010
    Location
    Birkirkara, Malta
    Posts
    1,467
    Thanks
    205
    Thanked 15 Times in 14 Posts
    Sudo15, thanks for the link and if my keyboard stops working in Win 8.1 again I will revisit it and try the solution mentioned there.

    Regards, Roy
    OS Dual Boot Windows 10 Pro 64 Bit & Windows 7 Pro With SP1 64 bit. (Intel Core i7 2600K Processor LGA1155-Asus P867 Pro Motherboard-GTX550 Ti DirectCU Graphics Card-Memory 8GB)

    Roy Whitethread

  9. #9
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,619
    Thanks
    147
    Thanked 875 Times in 837 Posts
    Quote Originally Posted by royw View Post
    Sudo15, thanks for the link and if my keyboard stops working in Win 8.1 again I will revisit it and try the solution mentioned there.

    Regards, Roy
    Found something for your product key one as well.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •