Page 1 of 2 12 LastLast
Results 1 to 15 of 18
  1. #1
    5 Star Lounger
    Join Date
    Jan 2004
    Location
    Praha
    Posts
    988
    Thanks
    56
    Thanked 105 Times in 90 Posts

    How to stop Word converting year (2014) to whole date format?

    When I type 2014 then hit [Return], Word 2003 turns it into 2014-11-02.

    I have tried, and failed to find the setting which controls this functionality.

    Help, please.

  2. #2
    WS Lounge VIP access-mdb's Avatar
    Join Date
    Dec 2009
    Location
    Oxfordshire, UK
    Posts
    1,723
    Thanks
    146
    Thanked 156 Times in 149 Posts
    Hmm, just tried it and it didn't change the string. Tried it again and it did change it. The difference, it kept the string as 2014 when I typed it from the numeric keypad. It converted it when I typed it on the 'normal' keys (above the letters). Don't yet know why, but if you have a numeric keypad you can get round the problem by using it.

    Now to see if I can find out why it happens....

    Well just found that when you type 2014 it asks you if you want to convert it - by pressing enter. Typing a space gets rid of this. Just keep an eye on the screen as you type...
    Last edited by access-mdb; 2014-11-02 at 10:58.

  3. #3
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,434
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts
    Martin,

    I tried this is both Word 2003 & 2010 and neither changes 2014 to a full date regardless of the keys used.

    I found this article but couldn't find the setting he was referring to in my copy of 2003.

    If you Google: word 2003 year changes to date you get a lot of hits.

    HTH
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  4. The Following User Says Thank You to RetiredGeek For This Useful Post:

    scaisson (2014-11-07)

  5. #4
    5 Star Lounger
    Join Date
    Jan 2004
    Location
    Praha
    Posts
    988
    Thanks
    56
    Thanked 105 Times in 90 Posts
    Got it, thanks to hints from responders - thank you both.

    Tools . . . AutoCorrect Options . . . AutoText tab . . . uncheck Show AutoComplete suggestions

    Job done

    Phew, that's been bothering me for ages but I only just got around to addressing it.

  6. #5
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,434
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts
    Martin,

    It's interesting but on my machine it doesn't do the substitution even with that item selected.
    WordAutoCompl.JPG
    Ignore the 2114 date in the graphic, I tried it with 2014 and it still doesn't correct to full date.

    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  7. #6
    5 Star Lounger
    Join Date
    Jan 2004
    Location
    Praha
    Posts
    988
    Thanks
    56
    Thanked 105 Times in 90 Posts
    It only substitutes when you press Enter directly after typing 2014.

    I can turn this on and off consistently with the setting mentioned above ON THIS PC but, curiously on another PC (which uses the same normal.dot and same OS it never happens.

    Probably going to be one of Words (many) unsolved mysteries.

  8. The Following User Says Thank You to MartinM For This Useful Post:

    scaisson (2014-11-07)

  9. #7
    WS Lounge VIP access-mdb's Avatar
    Join Date
    Dec 2009
    Location
    Oxfordshire, UK
    Posts
    1,723
    Thanks
    146
    Thanked 156 Times in 149 Posts
    Well done Martin - I also find checking and unchecking the option changes the behaviour.

    I think that Word is afraid of RG and gets itself confused!

  10. #8
    Lounger
    Join Date
    May 2011
    Posts
    43
    Thanks
    1
    Thanked 3 Times in 3 Posts
    Quote Originally Posted by MartinM View Post
    Got it, thanks to hints from responders - thank you both.

    Tools . . . AutoCorrect Options . . . AutoText tab . . . uncheck Show AutoComplete suggestions

    Job done

    Phew, that's been bothering me for ages but I only just got around to addressing it.
    In Word 2007, there is no option for "Show Auto-complete suggestions" - but there is, instead, "Show Auto-correct options buttons", which is not the same thing, and there appears to be no way of doing exactly the same as MartinM suggests... Any other solutions?
    Paul

  11. #9
    New Lounger
    Join Date
    Dec 2009
    Location
    West Bend, Wisconsin USA
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    In word 201 go to the insert tab and on the right of the layout is date and time. Click on it and there you can change to the option you want.

  12. #10
    New Lounger
    Join Date
    Dec 2009
    Location
    West Bend, Wisconsin USA
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    2010

  13. #11
    New Lounger
    Join Date
    Dec 2009
    Location
    West Bend, Wisconsin USA
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Go to the insert tab, on the right of the layout you will find Date and Time. Click on it and a menu will give you the option you want.

  14. #12
    Lounger
    Join Date
    Dec 2009
    Location
    Grand Cayman, Cayman Islands
    Posts
    30
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Quote Originally Posted by mojoann View Post
    Go to the insert tab, on the right of the layout you will find Date and Time. Click on it and a menu will give you the option you want.
    I have also seen this problem but rarely. I use Word 2007 with UK English and my observations suggest that the 2014-11-6 option only appears when editing other people's documents (ie documents where presumably that was the default option when created). Does Word keep this option as part of its formatting?

  15. #13
    Lounger
    Join Date
    May 2011
    Posts
    43
    Thanks
    1
    Thanked 3 Times in 3 Posts
    Quote Originally Posted by bryash View Post
    I have also seen this problem but rarely. I use Word 2007 with UK English and my observations suggest that the 2014-11-6 option only appears when editing other people's documents (ie documents where presumably that was the default option when created). Does Word keep this option as part of its formatting?
    I also use Word 2007 and UK English, and I find this problem occurs even in documents that I create myself.

  16. #14
    Lounger
    Join Date
    May 2011
    Posts
    43
    Thanks
    1
    Thanked 3 Times in 3 Posts
    Quote Originally Posted by mojoann View Post
    Go to the insert tab, on the right of the layout you will find Date and Time. Click on it and a menu will give you the option you want.
    In Word 2007, that only allows you to insert today's date in some chosen format. It does not solve the problem of unwanted auto-completion of the year by a complete date...

  17. #15
    Lounger
    Join Date
    Dec 2012
    Posts
    30
    Thanks
    4
    Thanked 1 Time in 1 Post
    I tried it in Word 2010 (Regional settings are UK English and date format is day/month/year). I typed 2014 and it did not expand the date. Typing 2014 and pressing Enter also did nothing. But if I type "06 N" a little box appears that says "Press Enter to Insert 06 Nov. 14." I think maybe I figured it out. If you type the first part of the date, Word thinks you are entering the current date, and it proposes to complete the date for you, but only if you type the date in the default date format. So if your default date format is year month day, and you type the year, Word proposes to complete the date in that format. If your default date format is Day Month Year, if you type only the year, it doesn't do that. The remedy is to change the default format to Day Month Year (or Month Day Year). Then when you type the year, Word will not autocomplete the date. I hope that's right.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •