Results 1 to 14 of 14
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    Auckland, NZ
    Posts
    11
    Thanks
    0
    Thanked 1 Time in 1 Post

    Windows 8.1 has an inconsistent internet connection

    I recently bought a shiny new Asus Ultrabook. This machine had Windows 8 pre-installed. After I booted it up and started setting it up the way I want it, it upgraded itself to Windows 8.1.

    Since that time I have had numerous problems connection to web pages (via Chrome and IE). The other machines in the house (4 x Win 7, plus two Android Tablets and one Android phone) have no such problem.

    The symptoms appear straightforward:

    Start Browser
    Enter URL (or select Favorite)
    Browser connects to site (50(-ish)% of the time)
    If the browser does not connect, I find that unplugging the ethernet cable and plugging it back in, then reloading the page usually works

    I Googled this issue and it seems to be relatively common...

    One solution I tried was "flushing the DNS cache" following these steps:

    Here are the steps you will need to flush the dns:
    1. Start screen
    2. Search
    3. cmd:control, shift & enter keys at same time, this gives you admin access
    4. type: netsh int ip reset then:
    5. netsh winsock reset
    Then restart your computer
    ..which I found in a post here: https://social.technet.microsoft.com...tpronetworking

    This seemed to work for an hour or so after restarting, but the machine has now reverted to its previous bad habit.

    Is this an artefact of a Win8 to Win8.1 upgrade? I have heard that a clean install of 8.1 does not exhibit this issue...

    Does anyone have a permanent solution?

  2. #2
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,645
    Thanks
    147
    Thanked 884 Times in 845 Posts
    Go to the ASUS support site and check the Network driver you are using also covers Win 8.1 and even reinstall it.

    Also go into Device Manager/Network adapters (I assume you are using Wireless) - right click on the Wireless adapter - select Properties and under the Power Management tab uncheck the box to Allow the computer turn off this device to save power and let us know if that improves.

    NB - This will revert to the box being checked after updating the driver.

  3. #3
    4 Star Lounger
    Join Date
    Feb 2010
    Location
    Fairfax County, Virginia
    Posts
    584
    Thanks
    11
    Thanked 61 Times in 49 Posts
    Quote Originally Posted by Sudo15 View Post
    Also go into Device Manager/Network adapters (I assume you are using Wireless) - right click on the Wireless adapter - select Properties and under the Power Management tab uncheck the box to Allow the computer turn off this device to save power and let us know if that improves.
    Quote from OP:
    If the browser does not connect, I find that unplugging the ethernet cable and plugging it back in, then reloading the page usually works

  4. #4
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,645
    Thanks
    147
    Thanked 884 Times in 845 Posts
    Thanks Prescott - misread that bit as I was posting in a hurry at the time, but the same setting is under the Power Managerment tab for the Ethernet adapter and reconnecting the cable will fire the adapter back up.

  5. #5
    New Lounger
    Join Date
    Dec 2009
    Location
    Auckland, NZ
    Posts
    11
    Thanks
    0
    Thanked 1 Time in 1 Post
    Quote Originally Posted by Sudo15 View Post
    Go to the ASUS support site and check the Network driver you are using also covers Win 8.1 and even reinstall it.

    Also go into Device Manager/Network adapters (I assume you are using Wireless) - right click on the Wireless adapter - select Properties and under the Power Management tab uncheck the box to Allow the computer turn off this device to save power and let us know if that improves.

    NB - This will revert to the box being checked after updating the driver.
    Thanks for your suggestions

    I have reinstalled the driver from the ASUS support site, as well as unticking the "Allow the computer turn off this device to save power" checkboxes against both the Realtek adapter and the wireless adapter.

    No really noticeable change - perhaps a slight improvement....

  6. #6
    2 Star Lounger
    Join Date
    Dec 2009
    Location
    Midwest, USA
    Posts
    108
    Thanks
    5
    Thanked 5 Times in 4 Posts
    This may sound a little strange, but your network adapter may just need to be completely powered down once in a while. Just turning off the laptop won't do it. Network adapters use a little bit of power even with the computer powered off. Easy to fix. Just shut down the laptop and remove the battery for 30 seconds or so. This will clean up a lot of network adapter problems.

  7. #7
    New Lounger
    Join Date
    Dec 2009
    Location
    Auckland, NZ
    Posts
    11
    Thanks
    0
    Thanked 1 Time in 1 Post
    Quote Originally Posted by caveman144 View Post
    This may sound a little strange, but your network adapter may just need to be completely powered down once in a while. Just turning off the laptop won't do it. Network adapters use a little bit of power even with the computer powered off. Easy to fix. Just shut down the laptop and remove the battery for 30 seconds or so. This will clean up a lot of network adapter problems.
    Will try that. Thanks

  8. #8
    New Lounger
    Join Date
    Dec 2009
    Location
    Auckland, NZ
    Posts
    11
    Thanks
    0
    Thanked 1 Time in 1 Post
    Quote Originally Posted by caveman144 View Post
    This may sound a little strange, but your network adapter may just need to be completely powered down once in a while. Just turning off the laptop won't do it. Network adapters use a little bit of power even with the computer powered off. Easy to fix. Just shut down the laptop and remove the battery for 30 seconds or so. This will clean up a lot of network adapter problems.
    Damn - just realised my shiny new Ultrabook has no removeable battery!!!

  9. #9
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,645
    Thanks
    147
    Thanked 884 Times in 845 Posts
    You could try adjusting the Power Plan so that it is set to High Performance - but if just using it on battery, this will reduce the times between a recharge.

    http://www.eightforums.com/tutorials...ndows-8-a.html

  10. #10
    New Lounger
    Join Date
    Dec 2009
    Location
    Auckland, NZ
    Posts
    11
    Thanks
    0
    Thanked 1 Time in 1 Post
    Quote Originally Posted by Sudo15 View Post
    You could try adjusting the Power Plan so that it is set to High Performance - but if just using it on battery, this will reduce the times between a recharge.

    http://www.eightforums.com/tutorials...ndows-8-a.html
    Will try the Power4Gear High Performance setting and see if there's an improvement...

  11. #11
    New Lounger
    Join Date
    Dec 2009
    Location
    Auckland, NZ
    Posts
    11
    Thanks
    0
    Thanked 1 Time in 1 Post
    Quote Originally Posted by johcar View Post
    Will try the Power4Gear High Performance setting and see if there's an improvement...
    Nope...

  12. #12
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,645
    Thanks
    147
    Thanked 884 Times in 845 Posts
    While IE will decide which mode it will open in, have you tried just opening it in Desktop Mode http://oxfordsbsguy.com/2014/04/10/h...n-windows-8-1/

  13. #13
    New Lounger
    Join Date
    Dec 2009
    Location
    Auckland, NZ
    Posts
    11
    Thanks
    0
    Thanked 1 Time in 1 Post
    The solution that appears to have worked for me is changing to GoogleDNS.

    Since this change I have had no connection issues.

    I understand that there is a known issue (locally - New Zealand) that Windows 8.1 and the default DNS settings for my ISP don't play nice...

  14. The Following User Says Thank You to johcar For This Useful Post:

    Sudo15 (2014-12-15)

  15. #14
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,645
    Thanks
    147
    Thanked 884 Times in 845 Posts
    Quote Originally Posted by johcar View Post
    The solution that appears to have worked for me is changing to GoogleDNS.

    Since this change I have had no connection issues.

    I understand that there is a known issue (locally - New Zealand) that Windows 8.1 and the default DNS settings for my ISP don't play nice...
    That's interesting - can you tell us the name of the ISP ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •