Results 1 to 12 of 12

Thread: Slow Wi-Fi

  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    Littleton, Colorado
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Slow Wi-Fi

    Quote Originally Posted by RetiredGeek View Post
    Sukki,

    Give this a try:
    1. Open Network and Sharing Center.
    2. In the left hand panel click Manage wireless networks.
    3. Click then Right-Click and select Delete for any networks you don't need or recognize.
    4. Re-boot just for grins!

    I have a Win 7 laptop connected to a Xfinity modem/router. With a cable connection I get up to 60Mb/s as reported by 'speedof.me'. With cable out and WiFi turned on the speed test starts at about 4Mb/s and degrades down to as low as 50Kb/s. The upload speed is equally dismal, but usually exceeds the download speed.
    I followed the steps above and found an old network. Deleted it. Restarted. Same issue persists.
    Suggestions?
    Last edited by RetiredGeek; 2014-12-26 at 17:52.

  2. #2
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,621
    Thanks
    147
    Thanked 877 Times in 839 Posts
    I would start with power cycling the modem/router.

    Switch the router and laptop off, disconnect all cables and leave off for a couple of minutes.

    Reconnect the cables (except Ethernet) and switch just the router on and when all of the lights are on and steady, switch the laptop on to see if there's any improvement.

    Do you have anything near the router such as a cordless phone or do you have any other devices in close proximity to the router or your laptop ?

    Do the bars on the WiFi icon reduce when the speed drops ?

    It's possible other local users could be interfering and downloading inSSIDer3 will show you if you have anyone "close by". http://www.techspot.com/downloads/5936-inssider.html

    These will be on the same or adjacent channels to you and within 15-20 of your RSSI - yours should be around the 50 mark.

    If this is the case, then log into the router and change channels to a less populated one and where the adjacent channels don't have strong users - which are those with upper 60s down to around your RSSI.

    Any other user with a RSSI value of 73+ shouldn't cause you any problems if you have to channel share or overlap.

  3. #3
    Star Lounger
    Join Date
    Nov 2010
    Location
    Largo, MD. USA
    Posts
    58
    Thanks
    4
    Thanked 0 Times in 0 Posts
    If you have a smartphone, download the Wi-Fi analyzer app. In it's default mode, you get a graphical mode strength v. channel display of all viable signals in the area. You can then tell if a change in router output frequency is required. I did it on my shop router from default ch. 6 to ch.3. Worked, it did.

  4. #4
    4 Star Lounger
    Join Date
    Jan 2010
    Posts
    496
    Thanks
    2
    Thanked 49 Times in 46 Posts

    Possible solutions

    Quote Originally Posted by bruceskis View Post
    Quote Originally Posted by RetiredGeek View Post
    Sukki,

    Give this a try:
    1. Open Network and Sharing Center.
    2. In the left hand panel click Manage wireless networks.
    3. Click then Right-Click and select Delete for any networks you don't need or recognize.
    4. Re-boot just for grins!
    I have a Win 7 laptop connected to a Xfinity modem/router. With a cable connection I get up to 60Mb/s as reported by 'speedof.me'. With cable out and WiFi turned on the speed test starts at about 4Mb/s and degrades down to as low as 50Kb/s. The upload speed is equally dismal, but usually exceeds the download speed.
    I followed the steps above and found an old network. Deleted it. Restarted. Same issue persists.
    Suggestions?
    Your laptop may be far enough away from the router that it's not receiving a strong signal. Is the laptop in a different room? If so, try moving closer to the router, say, a few feet away. This will at least confirm if it's a distance/location problem. If distance/location is the problem there are several remedies including do-it-yourself wi-fi antenna booster (search Youtube.com for a video tutorial), a bigger wi-fi antenna for the router, a new more powerful router, a powerline adapter kit with with one of the adapters being a wi-fi access point, or a plug-in USB wireless adapter for the laptop. The router or laptop may have a setting for which wireless channel is in use. You may change the channel to avoid interference from a cordless phone or a neighbor's wi-fi running on the same channel. Also, do you have any A/C adapters or charging cords plugged into power outlets in the same room as the router. Believe it or not, these can cause interference that reduces wireless performance as well as powerline adapter performance. So, unplug any charger cords even if they are not in use. Next, try comparing your wireless speed when your laptop is running on A/C power vs. running on battery. When running on battery, your laptop may be reducing power to the wireless adapter to save energy. In Windows Network and Sharing center click on Change Adapter Settings on the left-side menu. Then right-click on your wireless adapter and select Properties. In the properties window somewhere there's a configuration/properties list which contains a setting to enable Full Transmit Power or words similar to that.
    Last edited by RetiredGeek; 2014-12-26 at 17:54.

  5. #5
    New Lounger
    Join Date
    Dec 2009
    Location
    Littleton, Colorado
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    inssider not a good plan

    I downloaded inssider. According to WebRoot it was loaded with 3 pieces of malware and was not free to run. It required a fee for a key. Not willing to pay for malware.

    After eliminating the malware (I hope), I performed all the updates Dell suggested. Several pertained to wireless networks. No significant improvement.

    Your basic premise of interference makes sense to me so I ran tests with everything off and power cycled the modem/router. Then booted up the closest laptop. On wireless connection achieved a useable 15-30 Mbps. Same for the distant laptop. Then I turned on the wireless printer. No change. Plugged the mobile phone back in. No change. Turned on my stupid "smart phone" which used to connect to my home wireless connection. Speed went to Kilo bits per second. Both laptops. Cycled the modem/router again to repeat the test. All is fine until I turn the "smart phone" on. It is now set to NOT use a wireless connection.

    Have not tested the tablet - yet.


    Quote Originally Posted by Sudo15 View Post
    I would start with power cycling the modem/router.

    Switch the router and laptop off, disconnect all cables and leave off for a couple of minutes.

    Reconnect the cables (except Ethernet) and switch just the router on and when all of the lights are on and steady, switch the laptop on to see if there's any improvement.

    Do you have anything near the router such as a cordless phone or do you have any other devices in close proximity to the router or your laptop ?

    Do the bars on the WiFi icon reduce when the speed drops ?

    It's possible other local users could be interfering and downloading inSSIDer3 will show you if you have anyone "close by". http://www.techspot.com/downloads/5936-inssider.html

    These will be on the same or adjacent channels to you and within 15-20 of your RSSI - yours should be around the 50 mark.

    If this is the case, then log into the router and change channels to a less populated one and where the adjacent channels don't have strong users - which are those with upper 60s down to around your RSSI.

    Any other user with a RSSI value of 73+ shouldn't cause you any problems if you have to channel share or overlap.

  6. #6
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,621
    Thanks
    147
    Thanked 877 Times in 839 Posts
    If you use the link that I'd posted and hit the Windows version button you would get the free inSSIDer3, malware free - it's v4 which is the paid for version from MajorGeeks.

    Your router could also be set to Auto for the channel choice which could also cause problems should it land on a highly populated area.

    An alternative to a 3rd party program is the command prompt command netsh wlan show networks mode=bssid

    The signal strengths are displayed in % and as 50% equates to a RSSI value of -75dBm which is disconnection territory, you want to be well up from that.
    Last edited by Sudo15; 2014-12-26 at 19:08.

  7. #7
    New Lounger
    Join Date
    Dec 2009
    Location
    Littleton, Colorado
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Testing slow WiFi

    The attached pdf shows the status of my testing to date. Your thoughts?
    Attached Files Attached Files

  8. #8
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,621
    Thanks
    147
    Thanked 877 Times in 839 Posts
    That signal strength is excellent - I can only manage 94%.

    Is the xfinitywifi a Hotspot that your ISP provides by "piggy-backing" your connection - BT in the UK uses a similar practice.

    I've never known an iPhone to have been reported to pull speed down like that - it's as if it has been hijacked and permanently downloading something which is killing your bandwidth, although I don't know if that is possible with an iPhone.

    I don't know if factory resetting the iPhone would clear it, but would it be possible for you to get another SIM card for the iPhone from your provider - explain the circumstances to them.

    With the iPhone off you do seem to be losing quite an overhead in speed when using WiFi.

    This can happen when some of your devices are 802.11b/g as the router slows to the slowest device and can reduce speeds between 50 - 80% when they are transmitting/receiving.

    Apple products aren't too keen on the 40MHz Channel Width and changing that setting in the router from 20/40MHz to just 20MHz may or not improve matters when the iPhone is connected to the WiFi, but you would lose the n speeds of the router.

    I think getting another SIM card could be the better option if possible.
    Last edited by Sudo15; 2014-12-30 at 07:45.

  9. #9
    New Lounger
    Join Date
    Dec 2009
    Location
    Littleton, Colorado
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Yes, the xfinitywifi is a piggyback connection provided by Comcast.

    The drawdown of wifi speed occurs whether it is an Android phone or an iPhone. So, I'm not sure what will be accomplished by getting a new SIM card for either phone. Doesn't this actually point toward the modem as the culprit rather than either phone?

  10. #10
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,621
    Thanks
    147
    Thanked 877 Times in 839 Posts
    After reading this article https://fixdenver.com/blog/guides/di...-wifi-hotspot/ it's possible that it's the Xfinity hotspot that could be cause.

    See if disabling it does anything for the speed when you hook up either the Android or the iPhone to the WiFi.

  11. #11
    New Lounger
    Join Date
    Dec 2009
    Location
    Littleton, Colorado
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    First - Thanx to all who have offered assistance. Its been a learning experience.
    I was apparently successful in shutting down the Xfinity WiFi Hotspot. Even after cycling the modem. the 'netsh....' command seems to verify that it is gone. With Android and iPhone shut off, the speed is quite useable. Turning on the iPhone slows down the speed drastically. Turning on my Android may or may not make a difference. Speedof.Me showed a drastic drop in speed with both phones set to use my network (not the hotspot).

    I then downloaded the Xirrus tool. It is free. Seems to work well. WeRoot says its clean. Gives more info than the netsh command. Then I tried using the speedtest.net. It consistently reports much higher speeds than Speedof.me. All I can say at this point is that the download of the Xirrus tools went fast enough to suggest that speedtest.net may be in the right ball park.

    So, the plan for a few days/weeks is to see how useable the wireless connection is with the hotspot shut down. But, one thing is certain. If I am at my desk, I'll plug in the wire. Consistently much faster.

  12. #12
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,621
    Thanks
    147
    Thanked 877 Times in 839 Posts
    You could try factory resetting both the Android and iPhone and set those up again - but wired is always better than WiFi, although shouldn't make a great deal of difference when you are near the router - notwithstanding outside forces.
    Last edited by Sudo15; 2014-12-31 at 07:55.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •