Results 1 to 3 of 3
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    Shepherdstown, WV, USA
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Typeahead In CMD Doesn't Work As I Expect

    I have a question that puzzles me about typing within a CMD window. Until I had to reinstall Win7/64 on a new machine, I used to be able to "typeahead" -- that is, I could run a batch file (say MKALL) and while it was running continue to type the next command and hit ENTER so it would execute after the first batch file completed. Now the typeahead text is lost/ignored and I can't figure out what setting I'm missing in order to re-instate this nice feature. Googling for "windows typeahead" doesn't ring any bells, so I must be using the wrong words. This is such a simple (yet annoying) problem that I can't believe I can't find a solution. Please pull the wool from my eyes.

    My invocation of CMD specifies /E:ON /T:1E /K C:\AUTOEXEC.BAT. The latter batch files SETs some environment variables only, all specific to my development environment.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Command Processor\AutoRun and HKEY_CURRENT_USER\Software\Microsoft\Command Processor\AutoRun are both not present.

    Thanks for any help you can give.

    Bob Smith (a.k.a. 386MAX)

  2. #2
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    4,748
    Thanks
    171
    Thanked 649 Times in 572 Posts
    I think you could use DOSKEY /LISTSIZE=: Microsoft DOS doskey command

    But in Windows 7 or 8 you can set a buffer size with Command Prompt Properties: Windows 7 - Increase the buffer size of the command prompt

    (after right-clicking the Command Prompt window title bar)

    Bruce
    Last edited by BruceR; 2015-02-23 at 20:42.

  3. #3
    New Lounger
    Join Date
    Dec 2009
    Location
    Shepherdstown, WV, USA
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    In the Properties/Options for this invocation of CMD, the Command History Buffer size is already at the maximum of 999 with 4 buffers specified (as an aside, I have no idea of how 4 buffers differs from any other value). I also tried DOSKEY /LISTSIZE=30000, but nothing changed. My understanding of the CHB is that it accumulates commands as they are executed and makes them available via Up/Down arrows from the command line. The problem I'm having is typing while another command is executing. During that time, what I type is ignored, so it never makes it into the CHB.

    FWIW, I have set and unset "Quick Edit Mode" and "Insert Mode" in all four combinations without success.

    Does the form of "typeahead" I'm talking about work for anyone else?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •