Results 1 to 6 of 6
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    San Francisco, CA USA
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    By Adding a UTC Timestamp to File Names, File History Prevents Other Programs From Working Properly

    PLEASE DISREGARD THIS POST. I DISCOVERED THAT THE PROBLEM WAS CREATED BY A USER COPYING BACKED-UP FILES TO THEIR ORIGINAL LOCATION, RATHER THAN USING THE RESTORE FUNCTION.

    I am running Windows 8.1. About a week after turning on File History, I discovered that it is renaming the files in my Libraries by adding a UTC Timestamp.

    Figure 1.jpg

    This has the following adverse consequences:

    1. It results in two copies of each file in my cloud-based back-up set (iDrive), doubling the space consumed by the back-up and forcing me to pay for additional space.
    Figure 2.jpg
    2. It prevents programs that rely on filenames, such as Photoshop Elements’ Catalogs, from working properly

    3. It makes a mess of RoboForm’s passcard login screen by doubling (or more) the number of characters in each passcard
    There may be other problems as well that I haven’t detected, since I only became aware of the issue recently.

    My questions:

    1. Is it possible to turn-off or otherwise avoid time-stamping in File History?
    2. Is there an easy way to strip the timestamps from the files on my PC’s internal hard drive whose names have already been changed by File History?


    Thanks in advance for any help you can give me.
    Bill Hamm (Paid Content Subscriber)
    Last edited by billhamm; 2015-04-02 at 17:37.

  2. #2
    jwoods
    Guest
    This link from Microsoft Communities may be helpful...

    http://answers.microsoft.com/en-us/w...2-900222486956

  3. #3
    WS Lounge VIP access-mdb's Avatar
    Join Date
    Dec 2009
    Location
    Oxfordshire, UK
    Posts
    1,726
    Thanks
    147
    Thanked 156 Times in 149 Posts
    Where are you putting the backed up files in File History?

    Normally it doesn't let you put them on your c drive, which is where you appear to have put them. I've never seen it put a datetime stamp on the original files, only on the backed up ones. And you don't need to look at the backed up files in Explorer, just go to the folder you want to restore and click on history - there you can choose which files you want restored, and where you want them restored, and it will do it sans datetime stamp.

    Removing the datetime stamp on the backed up files will stop file history finding them (as well as producing duplicate filenames if the files have ever been changed.)

    I wouldn't put your backup in a cloud folder as the file history folder will always grow in size each time your files are changed.

    Note that jwoods link is a good one to look at.

  4. #4
    New Lounger
    Join Date
    Dec 2009
    Location
    San Francisco, CA USA
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    By Adding a UTC Timestamp to File Names, File History Prevents Other Programs From Working Properly

    Quote Originally Posted by access-mdb View Post
    Where are you putting the backed up files in File History?

    Normally it doesn't let you put them on your c drive, which is where you appear to have put them. I've never seen it put a datetime stamp on the original files, only on the backed up ones. And you don't need to look at the backed up files in Explorer, just go to the folder you want to restore and click on history - there you can choose which files you want restored, and where you want them restored, and it will do it sans datetime stamp.

    Removing the datetime stamp on the backed up files will stop file history finding them (as well as producing duplicate filenames if the files have ever been changed.)

    I wouldn't put your backup in a cloud folder as the file history folder will always grow in size each time your files are changed.

    Note that jwoods link is a good one to look at.
    1. I have pointed File History to my external hard drive; that's where the File History back-ups are saved. They are not being saved on the C:/ drive or in a cloud folder.
    2. Sadly, File History IS putting the UTC timestamp on the original files -- the ones that I want File History to back-up.
    3. The link provided by jwoods discusses restoring already-backed-up files to their original location (unless I don't understand the discussion). I don't need to restore files at this point; I just need to stop File History from changing the names of the files that I want to back-up

    Thank you for responding to my call for help, but I don't see a solution as yet.

  5. #5
    WS Lounge VIP access-mdb's Avatar
    Join Date
    Dec 2009
    Location
    Oxfordshire, UK
    Posts
    1,726
    Thanks
    147
    Thanked 156 Times in 149 Posts
    OK, I see now that your first screenshot was of your original files, not your backup ones. I have no idea how these files came to have the timestamp, but if you still have the filehistory ones, then try going to a folder in File Explorer (e.g. the one in your screenshot). Click on History (on the Home tab, second column from the end). Try a restore form that - it should give you the untimestamped files. If you right click on the folder name, choose 'restore to' - and restore to a new folder, just on one folder to test it out. If this works then you can do it for all others.

    Can you tell us what your settings are for FH please - Control panel/file history. Also the options on the left - select drive and those below, just so we can see if there's an issue there.

    Googling for the problem hasn't come up with anyone else having this issue, so it's a bit of a mystery.

    Good luck

  6. #6
    jwoods
    Guest
    You might take a look at this How-To for configuring and using File History and check it against what you are doing...

    http://blogs.windows.com/bloggingwin...-in-windows-8/

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •