Page 1 of 2 12 LastLast
Results 1 to 15 of 20
  1. #1
    5 Star Lounger ibe98765's Avatar
    Join Date
    Aug 2001
    Location
    Bay Area, California, USA
    Posts
    966
    Thanks
    19
    Thanked 4 Times in 4 Posts

    Auto startup in Win 8.1?

    Where do you put programs you want to auto-start in Win 8.1?

    I have tried dropping a program into the STARTUP folder but it won't start. The startup folder I am using is:

    Users\NAME\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup

    The program is called RealTemp and shows the CPU temps in the tray. Under Shortcut --> Advanced, I set the properties to run it as an administrator. I also tried running the compatibility troubleshooter. Which seemed to work and I saved the settings. But when I rebooted, the app still won't start on its own. It WILL run if I manually start it.

  2. #2
    Super Moderator jwitalka's Avatar
    Join Date
    Dec 2009
    Location
    Minnesota
    Posts
    6,792
    Thanks
    116
    Thanked 798 Times in 719 Posts
    That's the correct location for the Startup folder for the currently logged on user. For all users it's:
    C:\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp

    See: http://www.softwareok.com/?seite=faq-Windows-8&faq=206

    There has to be something wrong with your shortcut. I have an item in the first Startup location and it runs.

    By manually running the program, did you try double clicking on the shortcut in the startup folder?
    Jerry

  3. #3
    jwoods
    Guest
    Take off the Run As Administrator property and see if it auto-starts.

  4. #4
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,568
    Thanks
    5
    Thanked 1,056 Times in 925 Posts
    I would guess the shortcut has a problem. Can you create a shortcut on the desktop that successfully starts the program and then move or copy it to the startup folder?

    Joe

  5. #5

  6. The Following User Says Thank You to jwoods For This Useful Post:

    BruceR (2015-04-06)

  7. #6
    5 Star Lounger ibe98765's Avatar
    Join Date
    Aug 2001
    Location
    Bay Area, California, USA
    Posts
    966
    Thanks
    19
    Thanked 4 Times in 4 Posts
    The program will run out of the User startup folder if I double click it.

    I will try turning off admin priv and see what happens then.

    The eightforums link is helpful. Thanks.

  8. #7
    5 Star Lounger ibe98765's Avatar
    Join Date
    Aug 2001
    Location
    Bay Area, California, USA
    Posts
    966
    Thanks
    19
    Thanked 4 Times in 4 Posts
    I removed admin privileges but this did not auto start.

    I tried moving from the user startup folder to the global startup folder. Did not auto start.

    I tried with and w/o compatibility but made no difference, app wouldn't auto start.

    Looked in event logs but saw nothing related to this app.

    Nothing seems to work other than double-clicking to start the app.

    Here is the link if anyone has the time to try this on their machine:
    http://www.techpowerup.com/realtemp/

    Since this app doesn't look like it is being updated anyway, maybe I will replace it with something else.

  9. #8
    jwoods
    Guest
    You might check this thread on the TechPowerUp site...

    http://www.techpowerup.com/forums/th...altemp.194854/

    I personally don't have any programs in the Startup folder.

    They either run in Task Scheduler, or in the following registry keys...

    HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Run

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Run

  10. #9
    WS Lounge VIP Coochin's Avatar
    Join Date
    Jun 2014
    Location
    Queensland, Australia
    Posts
    2,147
    Thanks
    31
    Thanked 302 Times in 263 Posts
    Quote Originally Posted by jwoods View Post
    Link seems bad.

    OP might want to try http://www.almico.com/speedfan.php
    Computer Consultant/Technician since 1998 (first PC was Atari 1040STE in 1988).
    Most common computing error is EBKAC: Error Between Keyboard And Chairback
    AMD FX8120 (8-core @ 3.1GHz) CPU, Gigabyte GA-990FXA-D3 motherboard, 8GB (2x4GB) DDR3 1866MHz RAM, ATI-AMD Radeon HD6770 PCI-E VGA, 480GB Kingston SSD, 2TB Seagate SATA3.0 HDD, ASUS DVD/RW.

  11. #10
    WS Lounge VIP Calimanco's Avatar
    Join Date
    Dec 2009
    Location
    UK
    Posts
    717
    Thanks
    1
    Thanked 144 Times in 130 Posts
    Try this. It works for me.

    C:\Users\yourname\AppData\Roaming\Microsoft\Window s\Start Menu\Programs\Startup\yourprogram.exe

  12. #11
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,568
    Thanks
    5
    Thanked 1,056 Times in 925 Posts
    If you put the program.exe file in the startup folder, try putting the exe file in a different folder and create a shortcut in the startup folder.

    Joe

  13. #12
    jwoods
    Guest
    Reposting the TechPowerUp Support link...

    http://www.techpowerup.com/forums/th...altemp.194854/

  14. The Following User Says Thank You to jwoods For This Useful Post:

    ibe98765 (2015-04-07)

  15. #13
    5 Star Lounger ibe98765's Avatar
    Join Date
    Aug 2001
    Location
    Bay Area, California, USA
    Posts
    966
    Thanks
    19
    Thanked 4 Times in 4 Posts
    OK, it seems the only way to make Realtemp work in Win8 seems to be to drive it from the Task Scheduler.

    However, I don't understand WHY it won't work in either of the Startup folders (and why Windows doesn't issue some sort of informational msg on screen or in the event logs when it refuses to allow it to start).

    Is the problem UAC? I have been thinking of disabling UAC as I don't personally see much use in it. Would doing so solve this problem and allow the program to run from the Startup folders?
    Last edited by ibe98765; 2015-04-07 at 21:59.

  16. #14
    5 Star Lounger ibe98765's Avatar
    Join Date
    Aug 2001
    Location
    Bay Area, California, USA
    Posts
    966
    Thanks
    19
    Thanked 4 Times in 4 Posts
    Quote Originally Posted by JoeP517 View Post
    If you put the program.exe file in the startup folder, try putting the exe file in a different folder and create a shortcut in the startup folder.

    Joe
    I have the shortcut in the startup folder.

  17. #15
    5 Star Lounger ibe98765's Avatar
    Join Date
    Aug 2001
    Location
    Bay Area, California, USA
    Posts
    966
    Thanks
    19
    Thanked 4 Times in 4 Posts
    Quote Originally Posted by Calimanco View Post
    Try this. It works for me.

    C:\Users\yourname\AppData\Roaming\Microsoft\Window s\Start Menu\Programs\Startup\yourprogram.exe
    I used a shortcut in that folder and it did not work for me. Have not tried using the full program yet.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •